+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 42
Wired Networks Thread, VLAN Routing on 5406 zl in Technical; Right then, i've finally got my new core switch, a HP Procurve E5406 zl, and it's a beast. I've been ...
  1. #1
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29

    VLAN Routing on 5406 zl

    Right then, i've finally got my new core switch, a HP Procurve E5406 zl, and it's a beast. I've been advised to split my network so that each building is on it's own VLAN.

    So it will be something like this.

    Default - Vlan 1
    Servers - Vlan 2
    ICT - Vlan 3
    Technology - Vlan 4
    Maths Block - Vlan 5
    RSLA Block - Vlan 6
    Science Block - Vlan 7
    3 Storey Block - Vlan 8
    CCTV - Vlan 9
    Admin - Vlan 10

    I don't know whether or not to put printers on a seperate Vlan, what would you think.

    Also, we are running a 10.68.x.x ip range, from reading some of the other posts on here i've come to the conclusion that i'll have to create subnets for each of my 10 Vlans, is this correct. I want to have all my Vlans routing on the switch through to the servers vlan for dhcp (so ip helper-address i think on all the other vlans).

    How would I go about setting this up?

    Would I create scopes for each subnet on my DHCP server so that they could assign ip addresses to the clients on each vlan? And this may sound a bit silly, but what ip address do I put in for each default gateway? Is it the ip address that gets assigned to the Vlan on the switch?

  2. #2

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    Yes, add a printer VLAN, they are terrible culprits for broadcast traffic.
    Yes, split into subnets.
    You need to set a route up on the switch for each VLAN and set an IP address for the switch in each VLAN. In each VLAN you want to use DHCP you want to add an IP helper address pointing to your DHCP server. You also want to add an IP helper address to any server that you use for PXE boot such as a windows deployment server.
    On your DHCP server, yes set up seperate scopes. Have the default gateway as the IP address of the switch in that IP range.

  3. Thanks to teejay from:

    dezt (30th June 2011)

  4. #3
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    Thanks for that, can i just check one more thing, currently we have a subnet of 255.255.252.0 which has a masive range. This is set as one DHCP scope. If I create scopes for each Vlan on the DHCP server, do I then remove this current subnet and scope?

    Also, I read somewhere that you have to enter the subnets in AD sites and services, is this true?

  5. #4
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    Oh, and I forgot to ask, do I put all my switches and wireless points on the default Vlan, which will be the management Vlan, or should I put all the wireless points on a Vlan of their own?

  6. #5

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    Thanks for that, can i just check one more thing, currently we have a subnet of 255.255.252.0 which has a masive range. This is set as one DHCP scope. If I create scopes for each Vlan on the DHCP server, do I then remove this current subnet and scope? Yes, the easy way is to use a different private IP range if that's possible, especially if you're working on this with the network live.

    Also, I read somewhere that you have to enter the subnets in AD sites and services, is this true? Yes

  7. Thanks to teejay from:

    dezt (30th June 2011)

  8. #6

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    Quote Originally Posted by dezt View Post
    Oh, and I forgot to ask, do I put all my switches and wireless points on the default Vlan, which will be the management Vlan, or should I put all the wireless points on a Vlan of their own?
    Stick your wireless points on their own VLAN. It's also recommended by HP for better security to put the management interface of the switches on their own VLAN, but that can be a pita.

    To give you a rough idea of how to set up a VLAN from the command line on the switch:

    vlan 2
    name "Servers"
    untagged E1-E5
    tagged A1
    ip helper-address 1.2.3.4
    ip address 10.0.0.1 255.255.255.0
    ip igmp
    ip rip 10.0.0.1
    exit

  9. #7
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    I think what i'll do is get everything setup on a test server running DHCP in a test enviornment, and then when everything is woking fine I can implement it during the summer holidays.

    The Admin Vlan will be getting it's DHCP lease from a different range, 10.120.x.x, which is what we have been allocated for our admin domain, so i'm thinking that I would leave that domain as it is for the time being, with the server being a member of the 2 vlans we currently have, curric and admin, so it can send DHCP via it's 10.120.x.x address to admin clients and also allow SIMS to be used by curric clients.

    It works that way at the moment, with no routing in place on the current core, would that just be the same, or would I be better off setting up ip helper address for the admin vlan to point to the 10.120.x.x adaptor in the admin dc.

  10. #8

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    Leave it as it is, it's more secure, unless of course you want to start messing with Access Control Lists on the switches, which you may want to do anyway to prevent traffic routing between client VLANS.

  11. #9
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    So if i'm right, this would be how I would do it for my server vlan for 10 servers

    vlan 2
    name "Servers"
    untagged A2-A11
    tagged A1
    ip helper-address 10.68.x.x
    ip address 10.68.x.x 255.255.255.240
    ip igmp
    ip rip 10.68.x.x
    exit

    What are the ip igmp and ip rip commands for?

  12. #10

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    Yep, that's about right, the ip helper address wants to point to the ip address of your DHCP server, the ip address wants to be an address within the range you have assigned to that VLAN (I tend to use the first IP address in the range) and the ip rip address should be the ip address you've set in the ip address line. The ip rip command enables routing in the vlan and igmp enables multicasting, prob won't need that.

  13. 2 Thanks to teejay:

    dezt (30th June 2011), FragglePete (7th December 2011)

  14. #11
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    How do I set a route to my normal default gateway to allow internet access?

    my usual default gateway is 10.68.40.1

    Once I know how to do this I should be good to go.

  15. #12

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    without being in a VLAN config:

    ip routing (this will enable routing on th eswitch)
    ip route 0.0.0.0 0.0.0.0 10.68.40.1 (this adds your default gateway as the default route)

  16. Thanks to teejay from:

    dezt (30th June 2011)

  17. #13
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    Thanks for all your help, your a star.

  18. #14
    dezt's Avatar
    Join Date
    Dec 2005
    Location
    Lancs
    Posts
    1,026
    Thank Post
    157
    Thanked 58 Times in 46 Posts
    Rep Power
    29
    Just wondering, how would I manage my switches? Would I route from the server Vlan to the Management Vlan (or Default Vlan), as they are on different subnets.

    I'm guessing I would.

  19. #15

    teejay's Avatar
    Join Date
    Apr 2008
    Posts
    3,174
    Thank Post
    284
    Thanked 773 Times in 583 Posts
    Rep Power
    335
    You guessed right ;-)

  20. Thanks to teejay from:

    dezt (3rd July 2011)

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Procurve VLAN Routing Switch
    By Cache in forum Wired Networks
    Replies: 12
    Last Post: 7th June 2012, 12:30 PM
  2. To VLAN or not to VLAN... that is the question!
    By neilault in forum Wired Networks
    Replies: 7
    Last Post: 18th March 2012, 09:30 PM
  3. Routing to the internet...
    By synaesthesia in forum Wireless Networks
    Replies: 19
    Last Post: 4th April 2011, 12:17 PM
  4. HP 5412zl Routing
    By ithelp in forum Wireless Networks
    Replies: 3
    Last Post: 2nd September 2010, 08:18 AM
  5. 3Com 4500G VLAN Routing
    By ptenteges in forum Wireless Networks
    Replies: 1
    Last Post: 28th May 2008, 12:31 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •