Site Maintenance this evening The site will be offline for hosting changes. Time TBC

+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 29 of 29
Wired Networks Thread, Inter-VLAN woes between HP5308XL and 2610 in Technical; Originally Posted by andyrite Which Vlan can't your ping the SW from? Adding the VLAN ranges into the smoothwall is ...
  1. #16

    Join Date
    Sep 2012
    Posts
    57
    Thank Post
    9
    Thanked 4 Times in 2 Posts
    Rep Power
    4
    Quote Originally Posted by andyrite View Post
    Which Vlan can't your ping the SW from?

    Adding the VLAN ranges into the smoothwall is just creating a static route in the backgroud.
    Ah, so doing the config in Smoothwall is setting a static route between itself and the core?

    Pinging the SW on 10.50.4.24 from a device in either VLAN 100 or 200 fails.

  2. #17
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Can you post sh run from the core.

    Screenshot of the SW vlan page.

    What's the IP you ar etrying to ping from?

  3. #18
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    And make sure Networking Settings Advanced is unticked on the SW.

  4. #19

    Join Date
    Sep 2012
    Posts
    57
    Thank Post
    9
    Thanked 4 Times in 2 Posts
    Rep Power
    4
    Quote Originally Posted by andyrite View Post
    Can you post sh run from the core.

    Screenshot of the SW vlan page.

    What's the IP you are trying to ping from?
    The IP address of on eof the devices on VLAN 200 is 10.50.9.3. Pinging 10.50.4.24 fails.
    Here is the running config from the core -

    Code:
    ; J4819A Configuration Editor; Created on release #E.11.10
    
    hostname "Server Room - HP 5308xl" 
    snmp-server location "Main Switch Server Room" 
    module 2 type J4820B 
    module 3 type J4820B 
    module 4 type J4820B 
    module 5 type J4907A 
    module 6 type J4907A 
    module 8 type J4878B 
    module 7 type J4878B 
    ip default-gateway 10.50.4.24 
    ip routing 
    snmp-server community "public" Unrestricted 
    snmp-server host 10.50.4.64 "public" 
    snmp-server host 10.50.4.9 "public" 
    snmp-server host 10.50.4.13 "public" 
    vlan 1 
       name "DEFAULT_VLAN" 
       untagged B1-B24,C1-C5,C7-C24,D1-D24,E1-E16,F1-F16,G1-G4,H1-H4 
       ip address 10.50.6.14 255.255.252.0 
       tagged C6 
       ip igmp 
       exit 
    vlan 100 
       name "VLAN100" 
       ip address 10.50.8.1 255.255.255.0 
       tagged C6 
       exit 
    vlan 200 
       name "VLAN200" 
       ip address 10.50.9.1 255.255.255.0 
       tagged C6 
       exit 
    ip route 0.0.0.0 0.0.0.0 10.50.4.24 
    ip route 10.50.8.0 255.255.255.0 10.50.4.24 
    ip route 10.50.9.0 255.255.255.0 10.50.4.24 
    router rip
       exit
    password manager
    password operator
    
    
    ree
    Here is the SW VLAN page - SWVLANPage.jpg

    The local routing table on the SW box reflects these changes also.
    Last edited by MrJDH; 1st July 2014 at 12:35 PM.

  5. #20
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Wrong there. let me think.
    Last edited by andyrite; 1st July 2014 at 01:14 PM.

  6. #21
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    ip default-gateway 10.50.4.24 should be 10.50.6.14. (the ip of the switch. We want the switch to do all the routing.)

    no need for ip route 10.50.8.0 255.255.255.0 10.50.4.24
    ip route 10.50.9.0 255.255.255.0 10.50.4.24

    as the switch already will have that in the routing table.

    The Gateway in the VLAN screen on the smoothwal needs to be 10.50.6.14 for every vlan. (the switch is doing the routing)

    sh ip route on the core should comfirm this.
    Last edited by andyrite; 1st July 2014 at 01:23 PM.

  7. #22

    Join Date
    Sep 2012
    Posts
    57
    Thank Post
    9
    Thanked 4 Times in 2 Posts
    Rep Power
    4
    Quote Originally Posted by andyrite View Post

    The Gateway in the VLAN screen on the smoothwal needs to be 10.50.6.14 for every vlan. (the switch is doing the routing)
    As 10.50.6.14 isn't local for either of the VLAN IP ranges, Smoothwall won't allow us to enter this as the DG..

  8. #23
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,450
    Thank Post
    10
    Thanked 493 Times in 433 Posts
    Rep Power
    111
    You do not need and additional VLANs on the smoothwall, just the main interface and a route back for the relevant ip ranges.

    What are:

    ip route 10.50.8.0 255.255.255.0 10.50.4.24
    ip route 10.50.9.0 255.255.255.0 10.50.4.24

    for?

    The default route will send anything to unknown to smoothwall, the route on SW will send it back. SW needs only one default gateway, the internet.

  9. #24
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Quote Originally Posted by MrJDH View Post
    As 10.50.6.14 isn't local for either of the VLAN IP ranges, Smoothwall won't allow us to enter this as the DG..
    I've just tried it and it works.

  10. #25

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,680
    Thank Post
    516
    Thanked 2,451 Times in 1,897 Posts
    Blog Entries
    24
    Rep Power
    832
    Can I ask why you're implementing such a convoluted method of routing?

    The setup we have here is:

    All VLANS have the core as their DG (using the VLAN IP for the DG address).
    The core has the rule "ip route 0.0.0.0 0.0.0.0 10.5.143.254" in place, which is the default rule sending all unknown traffic to our edge router. In your case, this would point at your smoothwall box, which would have a DG of your edge router.

    From what I can tell, you're trying to route using your smoothwall box before the core router, meaning you have to bounce traffic back and forth.

    Is there a specific reason you need to do it that way?

  11. #26

    Join Date
    Sep 2012
    Posts
    57
    Thank Post
    9
    Thanked 4 Times in 2 Posts
    Rep Power
    4
    Is this what we need to have in place? Bit confused as advice from DMcCoy and andyrite seems to conflict - Do I need to dial the VLANs into SW, or not? Apologies for inducing much hair-pulling for folks..I think we're getting there. Easy when you understand the flow of traffic.
    Attached Images Attached Images

  12. #27
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    We are not adding vlans into the SW. We are just letting it know what subnets are on the network.

    Why not change one of the current school networks computers gateway to the core and see if it work's.

  13. #28

    Join Date
    Sep 2012
    Posts
    57
    Thank Post
    9
    Thanked 4 Times in 2 Posts
    Rep Power
    4
    Quote Originally Posted by andyrite View Post
    Why not change one of the current school networks computers gateway to the core and see if it work's.
    So doing this will test whether internet destined traffic is routed correctly through to SW, from the default 0.0.0.0 0.0.0.0 10.50.4.24 route?

  14. #29
    andyrite's Avatar
    Join Date
    Apr 2007
    Posts
    412
    Thank Post
    7
    Thanked 90 Times in 71 Posts
    Rep Power
    41
    Yep. You should be able to ping devices on the other vlans too.

SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Setting Up VLANs between Netgear and HP Procurve
    By colly72 in forum Wired Networks
    Replies: 4
    Last Post: 2nd October 2013, 12:22 PM
  2. Cut and paste issues between excel and word
    By 17thcpikeman in forum Windows
    Replies: 1
    Last Post: 30th November 2007, 01:42 PM
  3. whats the differance between EMF and PCL 5/6
    By timbo343 in forum Windows
    Replies: 11
    Last Post: 10th January 2007, 09:50 AM
  4. Replies: 20
    Last Post: 23rd December 2006, 09:36 PM
  5. Replies: 2
    Last Post: 22nd February 2006, 12:30 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •