+ Post New Thread
Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24
Wired Networks Thread, PVID 4204vl in Technical; Traffic is untagged on the main X9 interface to d23 for untagged traffic to be forwarded to VLAN47, and tagged ...
  1. #16

    Join Date
    Sep 2011
    Location
    Cambridgeshire
    Posts
    192
    Thank Post
    2
    Thanked 17 Times in 15 Posts
    Rep Power
    15
    Traffic is untagged on the main X9 interface to d23 for untagged traffic to be forwarded to VLAN47, and tagged for VLAN8 and VLAN10, which it is also tagged for on D23, so not that then

  2. #17
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,505
    Thank Post
    10
    Thanked 508 Times in 445 Posts
    Rep Power
    116
    Quote Originally Posted by CAWJames View Post
    OR should I be tagging 47 on the SW X9 port? Should I be matching the Untag of 47 on D23 with a Tag of 47 on X9?
    I suggest tagging 47 on the NSA and the Procurve on D23, that way it will always be tagged as expected at both ends of the link.

  3. #18

    Join Date
    Sep 2011
    Location
    Cambridgeshire
    Posts
    192
    Thank Post
    2
    Thanked 17 Times in 15 Posts
    Rep Power
    15
    I believe the connection from SonicWall to switch and SonicPoint to Switch both have to be untagged.

    In the morning I will connect a SonicPoint to another port on the ProCurve, and see what I can get working without the second hop to the Cisco, that will tell me what isn't working in the line, and also if it really has to be untagged at both ends!

    Thankyou so much for your help DMcCoy, hopefully with enough troubleshooting knowledge for the morning, I will find out what tick box hasn't been ticked!

    James

  4. #19
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,505
    Thank Post
    10
    Thanked 508 Times in 445 Posts
    Rep Power
    116
    One last idea, for the Sonic points, do you need

    switchport trunk native vlan 47
    switchport trunk allowed vlan 8,10


    to be:

    switchport trunk native vlan 47
    switchport trunk allowed vlan 8,10,47


    I'm trying to work out from the cisco docs, but it's not terribly explicit how the native vlan is passed if it's not 1

  5. #20

    Join Date
    Sep 2011
    Location
    Cambridgeshire
    Posts
    192
    Thank Post
    2
    Thanked 17 Times in 15 Posts
    Rep Power
    15
    I wasn't sure on that either, if you had to explicitly add 47 to the allowed lans, if it is the native VLAN already. Docs clear as mud. I will try both once I have got past the ProCurve in my testing(if the PC turns out to be fine, and it is the programming on the 3750)

    thanks

    James

  6. #21

    Join Date
    Sep 2011
    Location
    Cambridgeshire
    Posts
    192
    Thank Post
    2
    Thanked 17 Times in 15 Posts
    Rep Power
    15
    Ok done some testing, and it looks like the Procurve is off the hook, if I plug into one of its ports Untagged for VLAN47 and Tagged for VLAN8 and VLAN10, it provisions and works.

    If I then move it to the Cisco, I can get it to provision if I set Static-Access for a port to VLAN47, but being a Static-Access port, I cant then forward in tagged traffic.

    So it looks like it is a config on the Cisco ports then, as VLAN 47 is obviously forwarding over the switch connection port for the Static-Access to work. The ports are currently set as:

    interface FastEthernet1/0/x
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 47
    switchport trunk allowed vlan 8,10,47
    switchport trunk pruning vlan none
    switchport mode trunk
    speed 100
    duplex full
    spanning-tree portfast

    As far as I can work out from docs etc, this should be the working way, but must be missing something!

  7. #22

    Join Date
    Sep 2011
    Location
    Cambridgeshire
    Posts
    192
    Thank Post
    2
    Thanked 17 Times in 15 Posts
    Rep Power
    15
    Eureka! Looks like it is down to the global command "vlan dot1Q tag native"

    Which is obvious when you think about it, it is tagging ALL native VLANS.

    SP's began to provision when I did a "no vlan dot1Q tag native", but I lost VLAN1 acess to the switch!

    This is in use to connect the switch back up the line, so now got to work out how to do it without "vlan dot1Q tag native"!

    Thanks for all the help, hopefully on the final stretch now!

  8. #23

    Join Date
    Sep 2011
    Location
    Cambridgeshire
    Posts
    192
    Thank Post
    2
    Thanked 17 Times in 15 Posts
    Rep Power
    15
    All sorted and I am one happy bunny. All I had to do was issue the "no vlan dot1Q tag native" on the 3750 and then change the VLAN state on the ProCurve for VLAN1 from tagged on the uplink to untagged.

    Now I have 4 SP's happily provisioning and working on multiple SSID's, now for the other 4, then the other 32 around the centres!

    Thanks for all the help, and I now know my way around SonicPoints, so consider me a mind of information in getting these working with ProCurves, Cisco Catalysts and Cisco small business!!

    James

  9. #24
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,505
    Thank Post
    10
    Thanked 508 Times in 445 Posts
    Rep Power
    116
    Glad you got things sorted. I've actually always preferred the HP vlans, without a PVID, especially over switches that have untagged *and* a PVID.

  10. Thanks to DMcCoy from:

    CAWJames (16th June 2014)



SHARE:
+ Post New Thread
Page 2 of 2 FirstFirst 12

Similar Threads

  1. 4204Vl blocking all forms of remote management
    By CAWJames in forum Wired Networks
    Replies: 4
    Last Post: 26th April 2013, 09:46 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •