+ Post New Thread
Results 1 to 5 of 5
Wired Networks Thread, InterVLAN routing on HP Procurve 2920 in Technical; Hi guys I am trying to learn the HP Procurve product for a coming implementation, and have a test lab ...
  1. #1

    Join Date
    Apr 2014
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    InterVLAN routing on HP Procurve 2920

    Hi guys

    I am trying to learn the HP Procurve product for a coming implementation, and have a test lab comprising two Procurve 2920 24G switches to play with. I am trying to set up these two switches with vlan's, and am trying to test the intervlan routing on them. These two switches are not connected to any existing internal or external network, since I'm working on a customer site, I don't have that option. So therefore they are just two stand alone swithes to start with.

    I'm trying to see if I can create a few vlan's, with different ip adressing on each, and connect a labtop to the different vlan's, and then from one vlan ping the other vlan's , to test that routing between the vlan's are working. And would like to test the access list feature once I get the vlan routing to work.

    I found a guide of how to set up the routing for a Procurve 5300XL, which outline the following;

    CONFIGURATION COMMANDS: (created on software version E.06.01):

    HP ProCurve Switch 5304XL# enable
    HP ProCurve Switch 5304XL# config term
    HP ProCurve Switch 5304XL(config)# ip routing
    HP ProCurve Switch 5304XL(config)# router rip
    HP ProCurve Switch 5304XL(rip)# vlan 100
    HP ProCurve Switch 5304XL(vlan-100)# untag a1-a24
    HP ProCurve Switch 5304XL(vlan-100)# tag b1
    HP ProCurve Switch 5304XL(vlan-100)# ip address 10.10.100.1/24
    HP ProCurve Switch 5304XL(vlan-100)# ip rip v2-only
    HP ProCurve Switch 5304XL(vlan-100)# vlan 200
    HP ProCurve Switch 5304XL(vlan-200)# untag c1-c24
    HP ProCurve Switch 5304XL(vlan-200)# tag b1
    HP ProCurve Switch 5304XL(vlan-200)# ip address 10.10.200.1/24
    HP ProCurve Switch 5304XL(vlan-200)# ip rip v2-only
    HP ProCurve Switch 5304XL(vlan-200)# write mem



    I have used that guide as a framework to try and implement the intervlan routing on the 2920 24G switches, and below is the configuration I have on the switch right now.




    SwitchA(vlan-20)# sh run

    Running configuration:

    ; J9726A Configuration Editor; Created on release #WB.15.11.0007
    ; Ver #03:12.15.0d:09

    hostname "SwitchA"
    module 1 type j9726a
    trunk 23-24 trk1 lacp
    ip routing
    snmp-server community "public" unrestricted
    oobm
    ip address dhcp-bootp
    exit
    router rip
    redistribute connected
    exit
    vlan 1
    name "DEFAULT_VLAN"
    no untagged 1-14,Trk1
    untagged 15-22,A1-A2,B1-B2
    no ip address
    exit
    vlan 10
    name "MANAGEMENT"
    untagged 1-4
    tagged Trk1
    ip address 192.168.1.1 255.255.255.0
    ip rip 192.168.1.1
    exit
    vlan 20
    name "SERVERS"
    untagged 5-9
    tagged Trk1
    ip address 10.1.1.1 255.255.255.0
    ip rip 10.1.1.1
    exit
    vlan 30
    name "USERS"
    untagged 10-14
    tagged Trk1
    ip address 10.1.2.1 255.255.255.0
    ip rip 10.1.2.1
    exit
    vlan 40
    name "SWITCH-LINK"
    tagged Trk1
    ip address 172.16.1.1 255.255.255.0
    ip rip 172.16.1.1
    exit
    spanning-tree Trk1 priority 4
    no autorun
    no dhcp config-file-update
    no dhcp image-file-update
    password manager
    password operator



    If I connect to a vlan port let's say vlan 10, with my laptop, and give my labtop a static IP address of 192.168.1.5, I can only ping 192.168.1.1 but none of the other IP adresses like for example 10.1.1.1 on vlan 20. What am I doing wrong, and shouldn't I be able to ping the other vlan's when the routing has been set up.

    Any help would be appreciated.

    virt-net

  2. #2
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,421
    Thank Post
    508
    Thanked 282 Times in 258 Posts
    Rep Power
    81
    I think you'd have to set those other ranges up as static routes.. not sure on this one I'm afraid!

    Although I'm sure you'd have to set the port your plugged into as a tagged port with all VLANS attached.
    Last edited by cpjitservices; 24th April 2014 at 04:10 PM.

  3. #3
    ass17's Avatar
    Join Date
    Feb 2013
    Posts
    320
    Thank Post
    5
    Thanked 35 Times in 34 Posts
    Rep Power
    25
    Not sure which will apply but:

    Your switches don't seem to have a default gateway ip.

    And/or you may need to also add a static route using "ip route" command for example
    ip route 0.0.0.0 0.0.0.0 192.168.1.1

  4. #4

    Join Date
    Apr 2014
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi guys

    Thanks for you help, really appreciate it. I will try to have a go at your suggestions today, will let you know the outcome.

  5. #5
    IrritableTech's Avatar
    Join Date
    Nov 2007
    Location
    West Yorkshire
    Posts
    795
    Thank Post
    84
    Thanked 171 Times in 140 Posts
    Rep Power
    64
    After a quick glance, your config looks good.

    I can't see the fact you haven't a default route would make any difference. If I remember correctly though, when I set up our 5412 I had a similar issue. Although I'd written the config correctly, written it to memory etc. It took a restart of the switch before it was actually routing packets. Shouldn't have done - but it did.

SHARE:
+ Post New Thread

Similar Threads

  1. i need to add 2 vlan on hp procurve
    By guy18 in forum Wired Networks
    Replies: 4
    Last Post: 7th September 2013, 09:04 AM
  2. Rate Limit Specific IP's on HP ProCurve
    By bmittleider in forum Internet Related/Filtering/Firewall
    Replies: 0
    Last Post: 20th December 2012, 10:26 PM
  3. vlan design issue on HP procurve 5406zl
    By puliramesh in forum Wireless Networks
    Replies: 4
    Last Post: 10th August 2010, 06:23 AM
  4. Routing between VLANs on HP ProCurve 4108GL Switch
    By robknowles in forum Wireless Networks
    Replies: 12
    Last Post: 1st June 2010, 08:12 AM
  5. Adding vLAN not working on HP Procurve
    By mrforgetful in forum Wireless Networks
    Replies: 21
    Last Post: 2nd March 2007, 11:53 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •