+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 45
Wired Networks Thread, VLAN not getting IP from DHCP in Technical; Hi, We have 2 VLANs set up here: 1 (DEFAULT_VLAN) 2 (RUCKUS) I am using our HP ProCurve 2610-24 to ...
  1. #1
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    West Midlands
    Posts
    475
    Thank Post
    48
    Thanked 30 Times in 23 Posts
    Rep Power
    23

    Red face VLAN not getting IP from DHCP

    Hi,

    We have 2 VLANs set up here:

    1 (DEFAULT_VLAN)
    2 (RUCKUS)

    I am using our HP ProCurve 2610-24 to test it (which comes off our main switch, a HP ProCurve 4108GL), and have 'untagged' ports 2 and 17 on VLAN2 which are what x2 test computers are plugged into.

    I've set up a scope of 172.10.0.0/21 on our DHCP server, just for VLAN2 to use.

    I used these command to configure the switch:

    Code:
    #Config
    #VLAN 02
    #Name "RUCKUS"
    #ip address 172.10.0.1 255.255.248.0
    #ip helper-address 192.168.3.59
    But the clients still won't automatically get a 172.10.x.x address from DHCP. I'm sure I've missed something/set something wrong but can't figure out what!
    Any help welcome.

  2. #2

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,612
    Thank Post
    514
    Thanked 2,441 Times in 1,889 Posts
    Blog Entries
    24
    Rep Power
    831
    Do you have ip routing enabled? Only thing I can think of off the top of my head.

  3. #3

    Join Date
    May 2011
    Location
    Jus North of London, close but not too close
    Posts
    730
    Thank Post
    170
    Thanked 56 Times in 54 Posts
    Rep Power
    35
    I think there was a certain issue with HP 4104GL & 4108GL on certain firmware where ip routing/trunking was concerned. firmware version revision 51 I think rings a bell.

    We had a 4104GL at last place but I managed to get our firewall to provide DHCP for guest and BYOD vLANS only to overcome the issue.

  4. #4

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,917
    Thank Post
    860
    Thanked 1,429 Times in 982 Posts
    Blog Entries
    47
    Rep Power
    614
    Just to test, connect something to port 2 or 17 with a static address in the desired range and see if you can ping your DHCP server (or anything else on VLAN 1). If not, it may be your routing, as @localzuk says. If you can, the problem is probably with your DHCP server.

  5. #5
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    West Midlands
    Posts
    475
    Thank Post
    48
    Thanked 30 Times in 23 Posts
    Rep Power
    23
    ip routing is enabled
    Good point re the 4100s - will look at updating the firmware on it as I don't think it's been updated since day 1!
    Do i need to configure the 4108GL in any way? I've created VLAN2 on it, as well as enable GVRP mode (which HP says automatically tags the correct ports)..

  6. #6

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,612
    Thank Post
    514
    Thanked 2,441 Times in 1,889 Posts
    Blog Entries
    24
    Rep Power
    831
    Can you post your config for the 4108GL and the 2610? I don't use GVRP here, as I manually tag the trunk ports and define VLAN data on each switch instead.

  7. #7
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    West Midlands
    Posts
    475
    Thank Post
    48
    Thanked 30 Times in 23 Posts
    Rep Power
    23
    @sonofsanta - We can ping our DHCP (192.168.3.59), but only if we set our default gateway to 172.10.0.10 (Our squid server, using it as transparrant proxy for BYOD)
    If we set the default gateway as 192.168.3.200 which is our CISCO firewall then no reply to the ping.
    @localzuk - I will get them and post here

  8. #8

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,612
    Thank Post
    514
    Thanked 2,441 Times in 1,889 Posts
    Blog Entries
    24
    Rep Power
    831
    The gateway should be the IP address of the 4108GL on that particular VLAN.

    Then the 4108GL should have its default gateway set to your preferred default gateway.

  9. #9

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,917
    Thank Post
    860
    Thanked 1,429 Times in 982 Posts
    Blog Entries
    47
    Rep Power
    614
    Again, as @localzuk says, your default gateway for your VLAN has to be in that VLAN, because you go through your default gateway to get to other IP ranges, so if your gateway is on another IP range... chicken and egg

    When you set the VLAN up on the switch you assign it an IP, use that IP as the default gateway and then the switch will do the routing (assuming it's layer 3, not familiar with the ProCurve models).

  10. #10

    Join Date
    May 2011
    Location
    Jus North of London, close but not too close
    Posts
    730
    Thank Post
    170
    Thanked 56 Times in 54 Posts
    Rep Power
    35
    Quote Originally Posted by Lee91 View Post
    ip routing is enabled
    Good point re the 4100s - will look at updating the firmware on it as I don't think it's been updated since day 1!
    Do i need to configure the 4108GL in any way? I've created VLAN2 on it, as well as enable GVRP mode (which HP says automatically tags the correct ports)..
    I actually think after a certain Firmware they changed something regarding Trunking and IP Routing see the following HP release

    HP Support document - HP Support Center

  11. #11
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    West Midlands
    Posts
    475
    Thank Post
    48
    Thanked 30 Times in 23 Posts
    Rep Power
    23
    Ok, been playing around with it this morning..

    Main switch (4108GL) - The default gateway is set to 192.168.3.200 on here. The VLAN2 IP address is set to 172.10.0.20 255.255.248.0.
    Test switch (2626-24) - The default gateway on here is set to 172.10.0.20. The VLAN2 IP address is set to 172.10.0.9.

    On the test client, I've put 172.10.0.9 as the default gateway, but it still only gets a 169 address :/
    It works if I give it a static 172.10.x.x address, but still not getting it automatically

  12. #12

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,917
    Thank Post
    860
    Thanked 1,429 Times in 982 Posts
    Blog Entries
    47
    Rep Power
    614
    So with the static address, can you ping the DHCP server / can the DHCP server ping you?

    The only place you need to change the default gateway is on the device, and on the scope options for the VLAN address range on your DHCP server. This gateway should be the IP you gave the VLAN interface. The switches themselves should stay on whatever they were before.

    Another check: can you ping the VLAN interface IP (i.e. the address you want to use as the default gateway on this VLAN) from the DHCP server?

    Examples of what I'm talking about using made up addresses.
    Our internet router is IP 192.168.0.2.
    Our core switch is IP 192.168.0.10. Its default gateway is the internet router, i.e. 192.168.0.2.
    The cab switch in our office is IP 192.168.0.13. Its default gateway is the core switch, i.e. 192.168.0.10, as the core switch does all the routing between VLANs (not actually true, but we'll pretend it is for now).
    A server on VLAN1 would have the core switch as its default gateway.

    On the cab switch I've set up VLAN5, range 192.168.5.10-192.168.5.255. The IP for the VLAN interface is 192.168.5.1.
    Any device on this range, when given its IP address (e.g. 192.168.5.10) and its subnet (255.255.255.0) will have a default gateway of 192.168.5.1. This can be done statically, or set up as an option on the scope in the DHCP server.
    Last edited by sonofsanta; 21st January 2014 at 10:08 AM.

  13. #13
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    211
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    Your main switch has an IP address (for vlan2) of 172.10.0.20. This is the IP address which should be the default gateway for your PC's, not 172.10.0.9

  14. #14

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,612
    Thank Post
    514
    Thanked 2,441 Times in 1,889 Posts
    Blog Entries
    24
    Rep Power
    831
    The 2626-24 shouldn't have an IP for VLAN2 - it isn't doing any routing. It should just have the VLAN defined.

    So, it should be:

    Core Switch:

    Default IP - 192.168.3.200
    VLAN1 - Has its own IP
    VLAN2 - 172.10.0.20
    The 'trunk' port going to the 2626-24 should be tagged with both vlan 1 and 2

    Edge Switch:

    Default IP: VLAN1 IP of core switch
    Trunk port tagged with vlan 1 and 2
    VLAN 1 and 2 merely defined, no IP etc...
    Edge ports - untagged 1 or 2

    The clients should then send their request for an IP on their own VLAN, which the switch will broadcast across the trunk where the core will recognise the VLAN and direct it to the ip helper address, where the DHCP server (which should have a DHCP scope that matches the IP address defined for VLAN2 on the core) will reply with an IP. The DHCP scope should define the gateway address for VLAN2 as being 172.10.0.20, as this is the device doing the internal routing.

  15. #15
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    West Midlands
    Posts
    475
    Thank Post
    48
    Thanked 30 Times in 23 Posts
    Rep Power
    23
    So, now it's set up as:

    Core switch
    Default gateway: 192.168.3.200
    VLAN1 IP: 192.168.3.38
    VLAN2 IP: 172.10.0.20

    Edge switch
    Default gateway: 192.168.3.38
    VLAN1 IP: 192.168.3.54
    VLAN2 IP: <Disabled/No IP>

    Test computer
    Default gateway: 172.10.0.20

    DCHP Server
    172 range > Scope options > Router: 172.10.0.20

    Still, no automatic IP

    When on the test computer, I can ping 172.10.0.20 and get a reply. I try and ping the DHCP server on 192.168.3.59, request timed out. Also get request timed out if I try and ping 172.10.0.20 from the DHCP server.
    Which makes me thing it's a routing issue on our core switch!

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Laptops not getting DHCP from server but desktops are.
    By edutech4schools in forum Wireless Networks
    Replies: 10
    Last Post: 5th September 2011, 06:12 PM
  2. Laptop not getting IP from DHCP.
    By mrwobbly in forum Windows 7
    Replies: 12
    Last Post: 20th May 2011, 03:17 PM
  3. MAC OSX NOT GETTING IP FROM DHCP
    By thegrassisgreener in forum Mac
    Replies: 4
    Last Post: 18th January 2008, 08:50 AM
  4. Replies: 1
    Last Post: 22nd November 2007, 10:00 PM
  5. Replies: 0
    Last Post: 18th October 2007, 08:55 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •