+ Post New Thread
Page 3 of 3 FirstFirst 123
Results 31 to 45 of 45
Wired Networks Thread, VLAN not getting IP from DHCP in Technical; Originally Posted by localzuk Oh, also Trunk does have a meaning in HP but it isn't the one we're working ...
  1. #31
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    496
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    Quote Originally Posted by localzuk View Post
    Oh, also Trunk does have a meaning in HP but it isn't the one we're working with here (Trunking is joining ports together in the HP world).
    ahh, HP and their terminology! That makes a lot more sense now, I've been using the HP trunking features! So, I need to TAG (not untag) VLAN1 + VLAN2 on port 27 on the edge switch (which is a fiber connection back to the main) and then on the main TAG VLAN1 + VLAN2 on the port that the edge switch comes off.

    Yesterday when I tagged VLAN1 + VLAN2 on port 27 on the edge switch, all the clients on VLAN1 lost connection to the servers for some reason.
    @LukeTitmus our range is 172.10.0.xx/24 we're just testing at the minute, but it will all be logical when it goes live

  2. #32

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,156
    Thank Post
    522
    Thanked 2,551 Times in 1,980 Posts
    Blog Entries
    24
    Rep Power
    877
    Quote Originally Posted by Lee91 View Post
    ahh, HP and their terminology! That makes a lot more sense now, I've been using the HP trunking features! So, I need to TAG (not untag) VLAN1 + VLAN2 on port 27 on the edge switch (which is a fiber connection back to the main) and then on the main TAG VLAN1 + VLAN2 on the port that the edge switch comes off.
    Indeed.

    Yesterday when I tagged VLAN1 + VLAN2 on port 27 on the edge switch, all the clients on VLAN1 lost connection to the servers for some reason.
    If one end wasn't tagged, it'd do this.

  3. #33
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    496
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    Ok, thanks for the help so far, will do some more tinkering today and post results

  4. #34

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    5,125
    Thank Post
    916
    Thanked 1,512 Times in 1,033 Posts
    Blog Entries
    47
    Rep Power
    653
    Tagging and untagging is a weird and illogical naming convention that confuses easily (to the point I've just had to double check my own switches to make sure I'm not leading you astray), so for clarity:

    Every port must be untagged with at least one VLAN. This is the VLAN that the device belongs to, and a port can only be untagged with one VLAN. So for a wireless point that you want on VLAN 2, you have to untag the relevant port on the switch with VLAN 2. Ports that connect between switches should be untagged to VLAN1 (for the sake of simplicity). If you removed any untagging on your switch connections yesterday, that's why connections were dropped.

    Tagging is only used on the ports that switches use to connect to each other. It basically says "I'm not part of this VLAN, but I'll pass the traffic along". So if you have devices on VLAN2 on your edge switch, the port that connects upstream must also be tagged with VLAN2 (as well as the equivalent port on the other switch). You don't need to tag the port with the VLAN it's already untagged with, so if the switch port is untagged to VLAN1 you don't need to tag that port with VLAN1 as well. If you're setting up a new VLAN and traffic can't seem to get anywhere, odds are it's this bit you've forgotten (based on my experience of being me, anyway).

    In summary, for your current setup: the ports between your switches should be untagged with VLAN1 and tagged with VLAN2. The port you are using for your VLAN2 device should be untagged with VLAN2.

  5. Thanks to sonofsanta from:

    BassTech (29th January 2014)

  6. #35

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,156
    Thank Post
    522
    Thanked 2,551 Times in 1,980 Posts
    Blog Entries
    24
    Rep Power
    877
    The ports between switches should not be untagged between switches as far as I was told at uni. All 'switch to switch' links are tagged. Switch to end device links are untagged.

    So, as I said before port 27 on the edge should be tagged vlan 1 and vlan 2 and the other end should also be tagged vlan 1 and 2, with only the end device ports using the 'untagged' part.

    That is the setup I've used here, and was used in the school I was at previously (set up by Northgate IS), and pretty much every other network I've seen also.

    EDIT: This does seem like a personal choice though to be honest, but it has to be uniform between switches - you can't have vlan 1 tagged one end and untagged the other. It has to be matched.
    Last edited by localzuk; 24th January 2014 at 10:45 AM.

  7. #36

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    5,125
    Thank Post
    916
    Thanked 1,512 Times in 1,033 Posts
    Blog Entries
    47
    Rep Power
    653
    I wish I could remember enough from my CCNA course at Uni to say, but it was a long time ago and I struggled to remember it all back then in the first place

    Might be a difference between the ProCurve and Comware switches - my switch to switch connections are all untagged VLAN1, set to hybrid mode, though I know for a fact the latter is preference, and was the way the SwitchShop bloke preferred when he was setting/training us up. Works for me, anyway, might be worth a go if all else fails!

  8. #37
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,484
    Thank Post
    10
    Thanked 502 Times in 442 Posts
    Rep Power
    114
    Quote Originally Posted by sonofsanta View Post

    Every port must be untagged with at least one VLAN.

    Tagging is only used on the ports that switches use to connect to each other. It basically says "I'm not part of this VLAN, but I'll pass the traffic along". So if you have devices on VLAN2 on your edge switch, the port that connects upstream must also be tagged with VLAN2 (as well as the equivalent port on the other switch). [/B].
    You can have ports which are only tagged (I usually do vlan 1 between switches as tagged, remote end first!)
    You can have untagged and tagged (for lldp for phones as an example) and use untagged and multiple tagged vlans for a machine with a vlan aware card if you need to

    You will also have multiple tagged to things like VM hosts etc.

  9. #38
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    496
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    I've managed to tag port 27 on VLAN1 + VLAN2 on our test switch, and also tagged VLAN1 + VLAN2 on the main switch (port B2).
    On our test workstation (that comes off the test switch) I have untagged this port on VLAN2, and set the default gateway server as 172.10.0.20... But still no IP, and can't ping 172.10.0.20 - Now I'm really stumped as to why it can't get an IP.
    Last edited by BassTech; 29th January 2014 at 01:19 PM.

  10. #39

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,156
    Thank Post
    522
    Thanked 2,551 Times in 1,980 Posts
    Blog Entries
    24
    Rep Power
    877
    Post the configs again?

  11. #40
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    496
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    Quote Originally Posted by localzuk View Post
    Post the configs again?
    Yep

    Main (4108gl):

    ; J4865A Configuration Editor; Created on release #G.07.53

    hostname "HP ProCurve Switch 4108GL"
    cdp run
    mirror-port A1
    module 2 type J4864A
    module 1 type J4908A
    module 4 type J4893A
    ip default-gateway 192.168.3.200
    ip routing
    snmp-server community "public" Unrestricted
    snmp-server host 192.168.3.51 "public"
    snmp-server host 192.168.0.194 "public"
    vlan 1
    name "DEFAULT_VLAN"
    untagged A1-A22,B1,B3,D1-D6
    ip address 192.168.3.38 255.255.248.0
    tagged B2
    exit
    vlan 2
    name "RUCKUS"
    ip address 172.10.0.20 255.255.248.0
    ip helper-address 192.168.3.59
    tagged B2
    exit
    interface A7-A20
    monitor
    exit

    Test (2626):

    ; J9085A Configuration Editor; Created on release #R.11.07

    hostname "ProCurve Switch 2610-24"
    snmp-server location "Foden house middle foor"
    ip default-gateway 192.168.3.38
    ip routing
    snmp-server community "public" Unrestricted
    snmp-server host 192.168.0.194 "public"
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1,3-16,18-26,28
    ip address 192.168.3.54 255.255.248.0
    tagged 17,27
    no untagged 2
    exit
    vlan 2
    name "RUCKUS"
    untagged 2,17
    no ip address
    tagged 27
    exit

  12. #41

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,156
    Thank Post
    522
    Thanked 2,551 Times in 1,980 Posts
    Blog Entries
    24
    Rep Power
    877
    You have your DHCP server helper address set as 192.168.3.59 - is this your DHCP server address?

    You say you set the DHCP server as 172.10.0.20? This is the IP address of VLAN 2 on the core switch, so you can't use it again.

  13. Thanks to localzuk from:

    BassTech (29th January 2014)

  14. #42
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    496
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    Yes, 192.168.3.59 is our DHCP server.

    On the workstation, I set the default gateway to 172.10.0.20 (Sorry, I put DHCP instead of default gateway above - typo)

  15. #43
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,484
    Thank Post
    10
    Thanked 502 Times in 442 Posts
    Rep Power
    114
    You must *disable* routing on the 2626

    And the dhcp server has 192.168.3.38 as it's gateway?

  16. Thanks to DMcCoy from:

    BassTech (29th January 2014)

  17. #44
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    496
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    24
    Disabled routing on the 2626 now (thought I already did it), went to check the default gateway on DHCP server and it was set as 192.168.3.200 - changed that to 192.168.3.38 and it picked up an IP address immediately!
    [Borat voice]: Great Success!

    Thanks to all for the help - would've really struggled without edugeek Now to configure and connect squid ready for BYOD.....

    Lee

  18. Thanks to BassTech from:

    mac_shinobi (29th January 2014)

  19. #45

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,156
    Thank Post
    522
    Thanked 2,551 Times in 1,980 Posts
    Blog Entries
    24
    Rep Power
    877
    Hurray!!

SHARE:
+ Post New Thread
Page 3 of 3 FirstFirst 123

Similar Threads

  1. Laptops not getting DHCP from server but desktops are.
    By edutech4schools in forum Wireless Networks
    Replies: 10
    Last Post: 5th September 2011, 06:12 PM
  2. Laptop not getting IP from DHCP.
    By mrwobbly in forum Windows 7
    Replies: 12
    Last Post: 20th May 2011, 03:17 PM
  3. MAC OSX NOT GETTING IP FROM DHCP
    By thegrassisgreener in forum Mac
    Replies: 4
    Last Post: 18th January 2008, 08:50 AM
  4. Replies: 1
    Last Post: 22nd November 2007, 10:00 PM
  5. Replies: 0
    Last Post: 18th October 2007, 08:55 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •