+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 45
Wired Networks Thread, VLAN not getting IP from DHCP in Technical; That does sound like a routing issue now, yes. That config sounds right....
  1. #16

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,130
    Thank Post
    522
    Thanked 2,540 Times in 1,975 Posts
    Blog Entries
    24
    Rep Power
    875
    That does sound like a routing issue now, yes. That config sounds right.

  2. #17
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    495
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    23
    I'll have to double check the routing settings on our core switch, it should be:

    #config
    #vlan 02
    #name "RUCKUS"
    #ip address 172.10.0.1 255.255.248.0
    #ip helper-address 192.168.3.59
    #exit

    Which is what I did last week :S

  3. #18

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    5,112
    Thank Post
    909
    Thanked 1,507 Times in 1,029 Posts
    Blog Entries
    47
    Rep Power
    652
    Your VLAN IP address is set to 172.10.0.1 there - try using that as your default gateway instead.

  4. #19
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    495
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    23
    Ah, I see where I went wrong now!
    I want to go and try it, but have "misplaced" our serial cable, so had to order a new one in. We have every type of cable EXCEPT a female to female serial
    Last edited by BassTech; 22nd January 2014 at 07:52 AM.

  5. #20
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    495
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    23
    I ran this on the main switch today:

    #config
    #vlan 02
    #name "RUCKUS"
    #ip address 172.10.0.20 255.255.248.0
    #ip helper-address 192.168.3.59
    #exit

    But still no automatic IP address... When I did #ip address 172.10.0.20 255.255.248.0, the switch replied with "The IP address <or subnet> 172.10.0.20/21 already exists."

  6. #21

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,130
    Thank Post
    522
    Thanked 2,540 Times in 1,975 Posts
    Blog Entries
    24
    Rep Power
    875
    Ok, can you post the full config for the 2 switches?

  7. #22
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    495
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    23
    Sure:

    Main switch (4108gl)
    ; J4865A Configuration Editor; Created on release #G.07.53

    hostname "HP ProCurve Switch 4108GL"
    cdp run
    mirror-port A1
    module 2 type J4864A
    module 1 type J4908A
    module 4 type J4893A
    ip default-gateway 192.168.3.200
    snmp-server community "public" Unrestricted
    snmp-server host 192.168.3.51 "public"
    snmp-server host 192.168.0.194 "public"
    vlan 1
    name "DEFAULT_VLAN"
    untagged A1-A22,B1-B3,D1-D6
    ip address 192.168.3.38 255.255.248.0
    exit
    vlan 2
    name "RUCKUS"
    ip address 172.10.0.20 255.255.248.0
    ip helper-address 192.168.3.59
    exit
    interface A7-A20
    monitor
    exit
    gvrp

    Test switch (2626-24)
    ; J9085A Configuration Editor; Created on release #R.11.07

    hostname "ProCurve Switch 2610-24"
    snmp-server location "Foden house middle foor"
    ip default-gateway 192.168.3.38
    ip routing
    snmp-server community "public" Unrestricted
    snmp-server host 192.168.0.194 "public"
    vlan 1
    name "DEFAULT_VLAN"
    untagged 1,3-16,18-28
    ip address 192.168.3.54 255.255.248.0
    tagged 2,17
    exit
    vlan 2
    name "RUCKUS"
    untagged 2,17
    ip address 172.10.0.20 255.255.248.0
    ip helper-address 192.168.3.59
    exit
    gvrp

  8. #23
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,483
    Thank Post
    10
    Thanked 502 Times in 442 Posts
    Rep Power
    114
    turn off gvrp, turn off routing on the test switch, turn on routing on the core switch.

  9. #24

    Join Date
    Aug 2009
    Posts
    109
    Thank Post
    11
    Thanked 29 Times in 22 Posts
    Rep Power
    28
    My understanding is that your Main Switch (4108) should have the gateway address for each vlan listed, as you've done.

    Your edge switch just has the ip address of the switch itself, configured under the vlan the management will be done under (so if you have a management vlan, your switch ip should be configured under that vlan).
    You don't need routing on your edge switch.

  10. #25

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    5,112
    Thank Post
    909
    Thanked 1,507 Times in 1,029 Posts
    Blog Entries
    47
    Rep Power
    652
    That's why your main switch is whining about the IP being in use - your edge switch already has it.

    If you're routing at your core, i.e. this VLAN will span multiple switches, set the interface with IP up there. Your edge switch then needs to know nothing beyond the fact that the VLAN exists, so that you can tag/untag ports. I'm on COMWARE5 switches here, but as an example, this is my printer VLAN routed from core:
    Core switch
    Code:
    interface Vlan-interface192
     description Printers_VLAN
     ip address 192.168.192.1 255.255.255.0
     dhcp select relay
     dhcp relay server-select 1
    Edge switch
    Code:
    vlan 192
     description Printers_VLAN
    My routing is done statically (still older switches on the network that need it) so the edge switch has a default route set up to push any traffic it's not sure of up to the core. The 192 traffic meets that definition, so it's sent up to the core that routes it appropriately.
    Last edited by sonofsanta; 23rd January 2014 at 01:17 PM.

  11. #26

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,130
    Thank Post
    522
    Thanked 2,540 Times in 1,975 Posts
    Blog Entries
    24
    Rep Power
    875
    Quote Originally Posted by DMcCoy View Post
    turn off gvrp, turn off routing on the test switch, turn on routing on the core switch.
    Yup. That'd be my thought. Then on both switches, tag the ports used as trunks on both vlans.

    In the case of 2 switches, gvrp over complicates things. I don't use GVRP across our 15 or so switches, there's no need.

    This would be my config:

    Code:
    ip default-gateway 192.168.3.200 
    ip routing 
    vlan 1 
    name "DEFAULT_VLAN" 
    untagged A1-A22,B1-B3,D1-D6 
    tagged X1
    ip address 192.168.3.38 255.255.248.0 
    exit 
    vlan 2 
    name "RUCKUS" 
    tagged X1
    ip address 172.10.0.20 255.255.248.0 
    ip helper-address 192.168.3.59 
    exit
    Code:
    ip default-gateway 192.168.3.38 
    vlan 1 
    name "DEFAULT_VLAN" 
    untagged P,Qtagged A
    ip address 192.168.3.54 255.255.248.0
    exit 
    vlan 2 
    name "RUCKUS" 
    untagged Y,Z
    tagged A
    ip helper-address 192.168.3.59 
    exit 
    gvrp 
    
    With X1 being the trunk port, P,Q being ports on VLAN1, Y,Z on VLAN2 and A being the trunk port on the edge switch.

  12. #27
    BassTech's Avatar
    Join Date
    Nov 2008
    Location
    England
    Posts
    495
    Thank Post
    54
    Thanked 32 Times in 25 Posts
    Rep Power
    23
    I've now disabled routing on the edge switch completely, and re-configured the main switch for routing.
    On the edge switch, it's port 27 that connects back to the main, so I set that port as trunked (Trk1) and tagged it for VLAN1 & VLAN2, the problem is that as soon as I do that, all the clients coming off the edge switch lose connection, untill I untag VLAN1 on Trk1 again :/

  13. #28

    Join Date
    Dec 2013
    Location
    Luton
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    What is your full DCHP scope?

    Is your address range 172.10.0.xx/24 or whatever the subnet needs to be for the amount of address you need

    Personally I would have 172.10.0.1 as my Default gateway and then start the client addresses at 172.10.0.20, just seems logical and you have some space for extra things you may need on that range

  14. #29

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,130
    Thank Post
    522
    Thanked 2,540 Times in 1,975 Posts
    Blog Entries
    24
    Rep Power
    875
    What do you mean you set it as trunked? The term 'trunk' is just a general term for a link with HP switches (unlike with Cisco switches where it has a specific meaning in the config).

    By trunked, I merely mean you've tagged both vlan 1 and 2 on that port on both ends of the switch. So port 27 should be tagged vlan 1 and tagged vlan 2. Then whatever the port on the core switch should be tagged with both too.

  15. #30

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    18,130
    Thank Post
    522
    Thanked 2,540 Times in 1,975 Posts
    Blog Entries
    24
    Rep Power
    875
    Oh, also Trunk does have a meaning in HP but it isn't the one we're working with here (Trunking is joining ports together in the HP world).

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Laptops not getting DHCP from server but desktops are.
    By edutech4schools in forum Wireless Networks
    Replies: 10
    Last Post: 5th September 2011, 06:12 PM
  2. Laptop not getting IP from DHCP.
    By mrwobbly in forum Windows 7
    Replies: 12
    Last Post: 20th May 2011, 03:17 PM
  3. MAC OSX NOT GETTING IP FROM DHCP
    By thegrassisgreener in forum Mac
    Replies: 4
    Last Post: 18th January 2008, 08:50 AM
  4. Replies: 1
    Last Post: 22nd November 2007, 10:00 PM
  5. Replies: 0
    Last Post: 18th October 2007, 08:55 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •