+ Post New Thread
Results 1 to 8 of 8
Wired Networks Thread, tagged untagged in Technical; As I understand it untagged is simply the default vlan and tagging is adding extra vlans to a given port. ...
  1. #1
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,525
    Thank Post
    106
    Thanked 89 Times in 75 Posts
    Blog Entries
    46
    Rep Power
    40

    tagged untagged

    As I understand it untagged is simply the default vlan and tagging is adding extra vlans to a given port.

    In a 3Com Baseline Switch 2948 Plus switch the default vlan is 1. I have a port untagged to vlan 5 (x)

    when a test port (y) is also untagged to vlan 5. the laptop on (y) can ping a device on (x)

    when i make (y) untagged vlan 1, tagged vlan 5. I cannot ping.


    I thought that would work...?
    Last edited by browolf; 19th September 2013 at 02:27 PM.

  2. #2

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,952
    Thank Post
    862
    Thanked 1,443 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616
    Endpoint devices can only handle an untagged VLAN, therefore only one VLAN. Tagging is only for allowing upstream/downstream connections (i.e. to other switches) to carry the VLAN packets, but you can only deliver a packet on an untagged port.

    For a device on port Y, untagged on 1, to ping a device on X, untagged on 5, the switch would need to route the packet through the default interface for VLAN 1. In the case of VLAN 1 this is likely to be your core switch, in which case your connection upstream would need to be tagged with VLAN5 to allow it to carry the packet; if you were using VLANs 4 and 5 on a single L3 switch, the routing would be done on the local switch if that's where the default gateway for the VLAN was set up.

    Note that "endpoint devices" also includes switches - so any port where a switch connects to a switch is likely to be untagged VLAN1 and tagged with any other relevant VLANs to carry the traffic, keeping all your switches on the management VLAN where they're easy to access.

    EDIT: in short, to cross VLANs, you need routing. You don't need to tag endpoint ports with anything, only untag them with the relevant VLAN. In order to ping from VLAN 1 to VLAN 5 you don't need any tagging if it's all happening on one switch, you just need the VLAN interface setting up. I can give you the command line guff if you need.
    Last edited by sonofsanta; 19th September 2013 at 02:41 PM.

  3. Thanks to sonofsanta from:

    browolf (20th September 2013)

  4. #3
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,525
    Thank Post
    106
    Thanked 89 Times in 75 Posts
    Blog Entries
    46
    Rep Power
    40
    Quote Originally Posted by sonofsanta View Post
    Endpoint devices can only handle an untagged VLAN, therefore only one VLAN. Tagging is only for allowing upstream/downstream connections (i.e. to other switches) to carry the VLAN packets, but you can only deliver a packet on an untagged port.
    ok that explanation helps ty. however port 48 of the 2948 switch (untagged 1 tagged 5) and connects to port 8 (untagged 1 tagged 5) of the core 3com 4950 switch.


    does that mean there's something up with the vlan 5 on the core switch? (even though other vlans 2 and 4 seem to be operating fine).

  5. #4

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,952
    Thank Post
    862
    Thanked 1,443 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616
    If the above scenario works with VLANs 2 and 4 but not with 5, then it must be something with the set up of it... compare and contrast the settings for it on both switches, easier to do that on the CLI if you know how. It may be that you're missing settings for default gateway, or you've mistyped an IP, or any of a dozen things.

    Assuming the VLAN is all routed at your core, this is what you should be seeing (based on COMWARE 5)
    On your edge switch, not routing:
    Code:
    vlan 5
     description [any description you've added]
    interface Vlan-interface5
    interface GigabitEthernet1/0/48
     port link-type hybrid
     port hybrid vlan 2 4 5 tagged
     port hybrid vlan 1 untagged
    On your core switch, routing:
    Code:
    vlan 5
     description [any description you've added]
    interface Vlan-interface5
     description [any description you've added]
     ip address 192.168.5.1 255.255.255.0    # insert relevant IP and mask, ofc
     dhcp select relay
     dhcp relay server-select 1     # these two lines if you are doing DHCP on these VLANs
    interface GigabitEthernet1/0/8
     port link-type hybrid
     port hybrid vlan 2 4 5 tagged
     port hybrid vlan 1 untagged
    If you do need DHCP, you need
    Code:
     dhcp relay server-group 1 ip 192.168.0.1
     dhcp relay server-group 1 ip 192.168.0.2
    with relevant IPs, repeated for as many DHCP servers as you have

    How are you routing? If you're routing statically (and you may well be, as not all 3COM switches support the relevant routing protocols) it might be that you've not added/made a mistake when adding the route for VLAN5 to the edge switch.

    EDIT: saying that, routing's only important when you're doing layer 3 routing at the edge switch... when it's all at the core, the switch should already shunt packets it doesn't recognise up to the core, and the core would add the relevant entries to the routing table itself.
    Last edited by sonofsanta; 19th September 2013 at 04:17 PM.

  6. Thanks to sonofsanta from:

    browolf (20th September 2013)

  7. #5
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,525
    Thank Post
    106
    Thanked 89 Times in 75 Posts
    Blog Entries
    46
    Rep Power
    40
    something occurs to me. Around the time vlan 5 stopped working, I had changed the default gateway on the dhcp on vlan 1. I'm not sure how that would affect vlan 5 as the switches have static addresses and dont use dhcp... is that possible?

  8. #6

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,952
    Thank Post
    862
    Thanked 1,443 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616
    How do you mean changed the default gateway on the DHCP on VLAN1? Changed it on the DHCP server? Or changed the default gateway of VLAN1?

    When you're testing, are you using static addresses on the devices or dynamic?

  9. Thanks to sonofsanta from:

    browolf (20th September 2013)

  10. #7
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,525
    Thank Post
    106
    Thanked 89 Times in 75 Posts
    Blog Entries
    46
    Rep Power
    40
    ah it doesn't matter now. I've figured out there's nothing wrong with the vlan , something to do with the wireless controller on vlan 5 makes it so secure, nothing appears to work. doh. I only figured that out by wire-sharking the wireless on a laptop. I very much appreciate the opportunity to have bounced ideas off you. I feel I might not have got where I did without you.

  11. #8

    sonofsanta's Avatar
    Join Date
    Dec 2009
    Location
    Lincolnshire, UK
    Posts
    4,952
    Thank Post
    862
    Thanked 1,443 Times in 991 Posts
    Blog Entries
    47
    Rep Power
    616
    Ah, the eventual root of all our problems: a computer, somewhere, trying to be helpful of its own accord.

    Glad you got it sorted and that some of my waffle finally proved useful to someone somewhere. 'tis all just the circle of tech support.

SHARE:
+ Post New Thread

Similar Threads

  1. IMG Tag Signature
    By Jackd in forum Comments and Suggestions
    Replies: 6
    Last Post: 11th January 2008, 06:59 PM
  2. Tags?
    By Geoff in forum General Chat
    Replies: 5
    Last Post: 8th January 2008, 01:00 PM
  3. [CLOSED] Bug/Error: Tagging disabled in the Site Polls forum
    By Geoff in forum EduGeek.net Site Problems
    Replies: 1
    Last Post: 7th January 2008, 09:06 PM
  4. Frog + Meta tagging
    By jonathan.lees in forum Virtual Learning Platforms
    Replies: 0
    Last Post: 1st December 2007, 09:45 PM
  5. Popup or Alt Tag title
    By Scotmk in forum Web Development
    Replies: 3
    Last Post: 12th September 2007, 05:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •