+ Post New Thread
Results 1 to 15 of 15
Wired Networks Thread, HP switch in Cisco network not pingable in Technical; Having some trouble pinging our new HP J9540A switch. From factory defaults, it has been setup as follows: Main setup ...
  1. #1

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0

    HP switch in Cisco network not pingable

    Having some trouble pinging our new HP J9540A switch. From factory defaults, it has been setup as follows:

    Main setup
    IP of switch: 172.16.254.20/24, gateway 172.16.254.254
    Spanning tree enabled

    VLANs
    VLAN ID: 113
    Name: vlan 113
    Ports: untagged A1-D24
    Set as primary VLAN

    We have a fibre connected to port B21 which is a fibre port. Link light is on, port status is UP.

    I can't ping the switch (172.16.254.20) from my workstation from over the network. I'd like to manage it remotely so I know it's communicating.
    I've tried disabling spanning tree, same issue. I've tried having port B21 as tagged and untagged, no difference.

    The rest of the network are Cisco switches and routers. Any ideas most appreciated.

  2. #2

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,684
    Thank Post
    516
    Thanked 2,453 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833
    If B21 is a 'trunk' port, then it should be tagged at the HP end. How have you got the other end set up on the Cisco switch?

    There's some clues here which explain what's what between the 2 makes - http://2and2is5.wordpress.com/2011/0...d-hp-switches/

  3. #3

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    The Cisco side of the fibre is not trunked, so I've set B21 on the HP (where the fibre goes into) as untagged. Saved and rebooted, double-checked the config, it is untagged on VLAN 113. Port light is still on, link status up. Still can't ping it

    If I plug a laptop into any port, it won't get a DHCP IP either, although the link light comes on.

  4. #4

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,684
    Thank Post
    516
    Thanked 2,453 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833
    So the other side has the port set to whatever the equivalent of 'untagged' on VLAN 113 too?

  5. #5

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    That's correct, not trunked on the Cisco side.

    I may have found the problem. Reading a HP user guide for the switch, it says:

    "In the factory-default configuration, the switch has one, permanent default VLAN (named
    DEFAULT_VLAN) that includes all ports on the switch. Thus, when only the default VLAN exists in
    the switch, if you assign an IP address and subnet mask to the switch, you are actually assigning
    the IP addressing to the DEFAULT_VLAN.

    If multiple VLANs are configured, then each VLAN can have its own IP address.
    "

    The only place I set the IP was the setup screen, which means it's applied it to the default VLAN only. I'm going to try show vlan command, and it should say:

    DEFAULT_VLAN | Manual <IP ADDRESS>
    VLAN113 | Disabled


    I'll then set the global IP to DHCP again like factory defaults, and manually set the IP for the VLAN using:
    vlan <vlan-id>
    ip address <ip-address/mask-length>


    Hopefully that will work, will try and update here soon.

    Thanks
    Last edited by nLinked; 18th April 2013 at 12:28 PM.

  6. #6

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Unfortunately putting the IP on the VLAN didn't work either. Either way I can't ping the gateway 172.16.254.254 from the HP switch itself, times out. I can ping it from any workstation though which are connected to other Cisco switches (no machines connected to the HP yet as they won't pick up IPs from it).

    EDIT: "can"
    Last edited by nLinked; 18th April 2013 at 02:05 PM.

  7. #7

    localzuk's Avatar
    Join Date
    Dec 2006
    Location
    Minehead
    Posts
    17,684
    Thank Post
    516
    Thanked 2,453 Times in 1,899 Posts
    Blog Entries
    24
    Rep Power
    833
    Thing is - it shouldn't matter if the switch has an IP or not for machines plugged in to the switch - this is handled at lower layers than level 3.

    So, you have an issue with the connectivity between the HP and Cisco switch - which is why I'm talking about the trunk.

  8. #8
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,478
    Thank Post
    515
    Thanked 287 Times in 263 Posts
    Rep Power
    81
    you need to trunk the ports between the Cisco and the HP, and make sure you add the VLANS to the trunk. Also check the encapsulation on the switch for the trunk ports, cisco has a proprietary protocol , make sure it is 802.1q not ISL. Trunk the ports which connect both switches together.

  9. #9

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    150
    what is the configuration of the port on the cisco

    it should be mode "access"
    and have the access vlan that is on the 172.16.254.20/24 network.

    Rob

  10. #10

    Join Date
    Oct 2007
    Location
    Newcastle Upon Tyne
    Posts
    452
    Thank Post
    147
    Thanked 66 Times in 57 Posts
    Rep Power
    43
    Unless I have missed something have we confimed that a computer plugged into the HP switch can ping something on the cisco switch, because all that has been said so far is about talking to the "switch" and by this I assume he means the management part of the switch.

  11. #11

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by cpjitservices View Post
    you need to trunk the ports between the Cisco and the HP, and make sure you add the VLANS to the trunk. Also check the encapsulation on the switch for the trunk ports, cisco has a proprietary protocol , make sure it is 802.1q not ISL. Trunk the ports which connect both switches together.
    Can confirm everything is 802.1q. I think trunking the ports is where I'm unclear. I've tried the following on the HP:

    The fibre from the Cisco switch, is going into fibre port B21 on the HP switch.

    So I did this on the HP:
    vlan 1 | untagged a1-d24 (so default vlan is all untagged, I think it's like this by default anyway)
    vlan 113 | tagged b21

    I'm not sure how else to add B21 to a trunk. I also tried:

    Menu > Switch Configuration > Port/Trunk Settings > Mode=Auto; FlowCTRL=Disable; Group=Trk1; Type=LACP for port b21

    No joy.

    I've only set the switch's IP and and subnet mask on the default setup screen. So when I view the IP config in the menu interface, I see:

    Default VLAN: IP: 172.16.254.20/24
    VLAN 113: IP: DISABLED

    Although I did try removing the IP from the default VLAN and placing it on VLAN 113, no joy.

    Quote Originally Posted by twin--turbo View Post
    what is the configuration of the port on the cisco

    it should be mode "access"
    and have the access vlan that is on the 172.16.254.20/24 network.

    Rob
    The port connected to the same fibre on the Cisco side gives me this:

    #show interfaces switchport
    Name: Gi10/6
    Switchport: Enabled
    Administrative Mode: trunk
    Operational Mode: trunk (member of bundle Po1)
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: dot1q
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Voice VLAN: none
    Administrative private-vlan host-association: none
    Administrative private-vlan mapping: none
    Administrative private-vlan trunk native VLAN: none
    Administrative private-vlan trunk encapsulation: dot1q
    Administrative private-vlan trunk normal VLANs: none
    Administrative private-vlan trunk private VLANs: none
    Operational private-vlan: none
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL

    Quote Originally Posted by TronXP View Post
    Unless I have missed something have we confimed that a computer plugged into the HP switch can ping something on the cisco switch, because all that has been said so far is about talking to the "switch" and by this I assume he means the management part of the switch.
    No, if I plug a laptop into any port on the HP switch, the laptop won't get an IP via DHCP, so I can't ping anything from the laptop. The HP switch can't even ping its gateway (172.16.254.254). Error is: The destination address is unreachable

  12. #12

    Join Date
    Oct 2007
    Location
    Newcastle Upon Tyne
    Posts
    452
    Thank Post
    147
    Thanked 66 Times in 57 Posts
    Rep Power
    43
    Have a look at this document, It may be able to point you in the right direction:

    http://networktest.com/hpiop/hpiopcookbook.pdf

  13. #13

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    150
    "Pruning VLANs Enabled: 2-1001 ??"

    Please do , on the cisco

    #sh run int g0/6

    Cheers

    Rob

  14. #14

    Join Date
    Sep 2011
    Posts
    162
    Thank Post
    5
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quote Originally Posted by twin--turbo View Post
    "Pruning VLANs Enabled: 2-1001 ??"

    Please do , on the cisco

    #sh run int g0/6

    Cheers

    Rob
    Ah ha, you might be onto something.

    #show run interface gi 10/6
    Building configuration...

    Current configuration : 197 bytes
    !
    interface GigabitEthernet10/6
    description CRITICAL PORT***BLOCK A UPLINK***
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    no ip address
    channel-group 1 mode on
    end

  15. #15

    Join Date
    Jan 2009
    Posts
    109
    Thank Post
    3
    Thanked 21 Times in 16 Posts
    Rep Power
    15
    Untagged in the HP world means "native" or access in the Cisco world.

    So, on the Cisco side your port is access vlan 1 and native vlan 1, while on the HP side you are using vlan 113. This is why they aren't talking.

    You either need to make both sides access ports for the same vlan or trunk both sides and ensure they are using the same native vlan (recommended for interswitch links).

    (although it is best practice from a security perspective to use a native vlan that does not exist on any access port)

    Example:

    (Cisco)
    interface GigabitEthernet10/6
    switchport
    switchport trunk encapsulation dot1q
    switchport mode trunk
    switchport trunk native vlan 113
    spanning-tree mode point-to-point
    end

    (HP)
    vlan 113
    untagged b21
    (any other vlans that need to be carried across this trunk should be "tagged")
    vlan xxx
    tagged b21
    vlan yyy
    tagged b21

    Also, you need to ensure the Cisco switch is aware of the layer 2 vlan (113). 'Show vlan' will confirm this.

    The longer explanation here is that in the Cisco world creating a trunk port automatically carries all tagged (802.1Q) vlan traffic and will forward any untagged traffic to ports on the native vlan (1 by default).

    In the HP world you have to assign the native vlan (untagged, also 1 by default) and specify which vlans are to be carried across the trunk by "tagging" each.
    Last edited by Destinova; 21st April 2013 at 04:07 AM.

SHARE:
+ Post New Thread

Similar Threads

  1. Monitoring HP Switches in Nagios
    By Lee_K_81 in forum *nix
    Replies: 16
    Last Post: 15th July 2011, 08:13 AM
  2. Port trunking on HP Switches not helping transfer speeds
    By chriscubed in forum Wireless Networks
    Replies: 9
    Last Post: 9th August 2010, 04:07 PM
  3. HP Gbics in 3Com switches
    By d-taylor in forum Wireless Networks
    Replies: 1
    Last Post: 9th June 2010, 07:17 AM
  4. HP Switches + WiFi in a new 6th form block?
    By Geoff in forum Wireless Networks
    Replies: 94
    Last Post: 28th July 2009, 03:48 PM
  5. Cisco Network Assistant and 2950/3550 Switches
    By monsterplastic in forum Wireless Networks
    Replies: 1
    Last Post: 23rd January 2007, 03:19 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •