+ Post New Thread
Results 1 to 5 of 5
Wired Networks Thread, PXE clients cannot obtain IP address when on different VLAN in Technical; I've setup a VLAN for client PC's, with my L3 switch as the default gateway and an IP helper setup. ...
  1. #1

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    159
    Thanked 152 Times in 116 Posts
    Rep Power
    49

    PXE clients cannot obtain IP address when on different VLAN

    I've setup a VLAN for client PC's, with my L3 switch as the default gateway and an IP helper setup. PC's work fine with this, they obtain an IP address from the correct scope, and all is well.

    But I'm trying to PXE boot a PC in order to get into MDT and it just won't get an IP address. If I move it to the original VLAN it works fine.

    I was expecting a few problems booting into MDT but I at least expected to be able to obtain an IP address first! It just waits and waits and eventually times out. I don't understand why Windows can, but PXE boot can't. Any ideas?

  2. #2
    old_n07's Avatar
    Join Date
    Jun 2012
    Location
    North Staffordshire
    Posts
    98
    Thank Post
    10
    Thanked 16 Times in 14 Posts
    Rep Power
    7
    Have you set scope option 66 Boot server host name on the DHCP scope for your new Vlan \ global option?

    If not put the IP address of the server in the string value

  3. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,942
    Thank Post
    886
    Thanked 1,694 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    You need to put an IP Helper on the vlan pointing to the WDS PXE server as well as the DHCP server. This is what we needed to do for SCCM.

    Option 66 isnt officially supported by Microsoft.

  4. #4
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,201
    Thank Post
    212
    Thanked 222 Times in 191 Posts
    Rep Power
    72
    I set option 66 to the IP of the MDT server and option 67 to boot\x86\wdsnbp.com

    Seems to work fine

  5. #5

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,942
    Thank Post
    886
    Thanked 1,694 Times in 1,472 Posts
    Blog Entries
    12
    Rep Power
    447
    Quote Originally Posted by themightymrp View Post
    I set option 66 to the IP of the MDT server and option 67 to boot\x86\wdsnbp.com

    Seems to work fine
    again this isnt officially supported by Microsoft. An IP helper is supported so this is the way forward.

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 13
    Last Post: 20th May 2010, 01:19 PM
  2. IP Address on Windows Vista
    By marvin in forum Windows
    Replies: 28
    Last Post: 2nd March 2010, 04:29 PM
  3. Replies: 0
    Last Post: 24th November 2009, 12:19 PM
  4. Map terminal session printers dependent on IP address
    By Andi in forum Thin Client and Virtual Machines
    Replies: 1
    Last Post: 3rd September 2008, 10:19 AM
  5. Replies: 3
    Last Post: 21st February 2008, 08:50 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •