+ Post New Thread
Results 1 to 8 of 8
Wired Networks Thread, Two Procurve 4108GLs, ip routing and packet loss in Technical; First post but this appears to be a great forum so I hope to participate more... Here is my problem: ...
  1. #1

    Join Date
    Mar 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Two Procurve 4108GLs, ip routing and packet loss

    First post but this appears to be a great forum so I hope to participate more...

    Here is my problem: I have two procurve 4108GLs that are connected by fiber. They both have the latest firmware. One of them (A) has 2 vlans. Vlan1 is the default with a subnet of 192.168.2.0/24. Vlan2 has a subnet of 192.168.1.0/24. The switch is routing between the vlans successfully. Switch B has the default vlan1 with a subnet of 192.168.2.0/24. The switches are connected via the fiber on subnet 192.168.1.0/24. There is no other configuration. Everything appears to work fine. However, under high load I start loosing packets going from vlan1 on switch B (192.168.1.0/24) to vlan1 on switch A (192.168.2.0/24). I do not loose packest on swtich A going from vlan1 to vlan2. I do not loose packets going from vlan1 switch B to vlan2 switch A.

    The vlans shouldn't matter since switch B is basically an expensive unmanaged switch. Can the routing on switch A just be overloaded? I see ~40% cpu average. But why does switch A vlan1 to vlan2 have no issues then? Do the vlans matter even if I am not passing any info?

    Any insight would be greatly appreciated.

  2. #2
    Marshall_IT's Avatar
    Join Date
    Jul 2011
    Location
    Leeds
    Posts
    488
    Thank Post
    76
    Thanked 61 Times in 52 Posts
    Blog Entries
    1
    Rep Power
    18
    I take it the first switch is the default gateway for both vlans.

    Also is vlan1 on both switches tagged with the same number?

    The link between switch 1 and 2 is set to untagged on vlan1?

  3. #3

    Join Date
    Nov 2010
    Location
    California
    Posts
    137
    Thank Post
    0
    Thanked 24 Times in 22 Posts
    Rep Power
    12
    Can you show us running config of both switches?

  4. #4


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339
    my top tips for debugging network loops:

    on core switch:
    ping offending device
    “display arp” to determine mac address
    “display mac-address xxxxxxxx” to determine port or aggregation group
    ping offending device when it goes offline
    “display mac-address xxxxxxxx” to determine port or aggregation group
    note change of port.
    repeat on the other switches to determine loop.
    fix loop or shutdown port
    Last edited by CyberNerd; 31st March 2013 at 09:47 AM.

  5. #5

    Join Date
    Mar 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Disclaimer: This isn't my configuration. I inherited this. I personally would change a number of things including taking the routing off the switches but I have to prove that will fix it.... also I changed these ips so if I missed something, apologies.

    I just noticed that switch A has "ip default-gateway 192.168.1.7" which is wrong but "sh ip route" and the ip routing configuration have the proper gateway of ip default-gateway 192.168.2.4. Switch A won't let me take out "ip default-gateway" without disabling ip routing first and I can/t do that right now. I am not sure that would cause an issue because the routing table appears correct but it will be my next step just to see if it helps.

    Today I am not seeing much loss (1 dropped in 1000) but still do see some lag spikes. It is only from some on switch A going to some device on switch B and it is only from 192.168.2.0/24 to 192.168.1.0/24.

    Swtich B is basically un-configured. Switch A is semi-configured. The client has switch A vlan2 192.168.1.7 as the main router for their 192.168.1.0/24 network. There are some servers on 192.168.2.0/24. The main internet router/firewall is at 192.168.1.4


    @Marshall_IT
    A1 on both switches is the link. They are not tagged.
    @CyberNerd
    I am pretty confident there isn't any looping. Switch B is all servers with short patch cables directly to the servers. I suppose something could be looped on A but I would think I would be seeing other issues on A.


    Switch A

    ; J4865A Configuration Editor; Created on release #G.07.117

    hostname "HP ProCurve Switch 4108GL"
    cdp run
    qos-passthrough-mode
    module 5 type J4863A
    module 2 type J4862B
    module 3 type J4862B
    module 4 type J4862B
    module 1 type J4864A
    module 8 type J4862B
    module 6 type J4863A
    interface E1
    no lacp
    exit
    interface E2
    no lacp
    exit
    interface E3
    no lacp
    exit
    interface E4
    no lacp
    exit
    interface E5
    no lacp
    exit
    interface E6
    no lacp
    exit
    interface B1
    no lacp
    exit
    interface B2
    no lacp
    exit
    interface B3
    no lacp
    exit
    interface B4
    no lacp
    exit
    interface B5
    no lacp
    exit
    interface B6
    no lacp
    exit
    interface B7
    no lacp
    exit
    interface B8
    no lacp
    exit
    interface B9
    no lacp
    exit
    interface B10
    no lacp
    exit
    interface B11
    no lacp
    exit
    interface B12
    no lacp
    exit
    interface B13
    no lacp
    exit
    interface B14
    no lacp
    exit
    interface B15
    no lacp
    exit
    interface B16
    no lacp
    exit
    interface B17
    no lacp
    exit
    interface B18
    no lacp
    exit
    interface B19
    no lacp
    exit
    interface B20
    no lacp
    exit
    interface B21
    no lacp
    exit
    interface B22
    no lacp
    exit
    interface B23
    no lacp
    exit
    interface B24
    no lacp
    exit
    interface C1
    no lacp
    exit
    interface C2
    no lacp
    exit
    interface C3
    no lacp
    exit
    interface C4
    no lacp
    exit
    interface C5
    no lacp
    exit
    interface C6
    no lacp
    exit
    interface C7
    no lacp
    exit
    interface C8
    no lacp
    exit
    interface C9
    no lacp
    exit
    interface C10
    no lacp
    exit
    interface C11
    no lacp
    exit
    interface C12
    no lacp
    exit
    interface C13
    no lacp
    exit
    interface C14
    no lacp
    exit
    interface C15
    no lacp
    exit
    interface C16
    no lacp
    exit
    interface C17
    no lacp
    exit
    interface C18
    no lacp
    exit
    interface C19
    no lacp
    exit
    interface C20
    no lacp
    exit
    interface C21
    no lacp
    exit
    interface C22
    no lacp
    exit
    interface C23
    no lacp
    exit
    interface C24
    no lacp
    exit
    interface D1
    no lacp
    exit
    interface D2
    no lacp
    exit
    interface D3
    no lacp
    exit
    interface D4
    no lacp
    exit
    interface D5
    no lacp
    exit
    interface D6
    no lacp
    exit
    interface D7
    no lacp
    exit
    interface D8
    no lacp
    exit
    interface D9
    no lacp
    exit
    interface D10
    no lacp
    exit
    interface D11
    no lacp
    exit
    interface D12
    no lacp
    exit
    interface D13
    no lacp
    exit
    interface D14
    no lacp
    exit
    interface D15
    no lacp
    exit
    interface D16
    no lacp
    exit
    interface D17
    no lacp
    exit
    interface D18
    no lacp
    exit
    interface D19
    no lacp
    exit
    interface D20
    no lacp
    exit
    interface D21
    no lacp
    exit
    interface D22
    no lacp
    exit
    interface D23
    no lacp
    exit
    interface D24
    no lacp
    exit
    interface A1
    speed-duplex 1000-full
    no lacp
    exit
    interface A2
    no lacp
    exit
    interface A3
    no lacp
    exit
    interface H1
    no lacp
    exit
    interface H2
    no lacp
    exit
    interface H3
    no lacp
    exit
    interface H4
    no lacp
    exit
    interface H5
    no lacp
    exit
    interface H6
    no lacp
    exit
    interface H7
    no lacp
    exit
    interface H8
    no lacp
    exit
    interface H9
    no lacp
    exit
    interface H10
    no lacp
    exit
    interface H11
    no lacp
    exit
    interface H12
    no lacp
    exit
    interface H13
    no lacp
    exit
    interface H14
    no lacp
    exit
    interface H15
    no lacp
    exit
    interface H16
    no lacp
    exit
    interface H17
    no lacp
    exit
    interface H18
    no lacp
    exit
    interface H19
    no lacp
    exit
    interface H20
    no lacp
    exit
    interface H21
    no lacp
    exit
    interface H22
    no lacp
    exit
    interface H23
    no lacp
    exit
    interface H24
    no lacp
    exit
    interface F1
    no lacp
    exit
    interface F2
    no lacp
    exit
    interface F3
    no lacp
    exit
    interface F4
    no lacp
    exit
    interface F5
    no lacp
    exit
    interface F6
    no lacp
    exit
    ip default-gateway 192.168.1.7
    ip routing
    vlan 1
    name "DEFAULT_VLAN"
    untagged A2-A3,C1-C24,H1-H24
    ip address 192.168.2.2 255.255.255.0
    no untagged A1,B1-B24,D1-D24,E1-E6,F1-F6
    ip igmp
    exit
    vlan 2
    name "VLAN2"
    untagged A1,B1-B24,D1-D24,E1-E6,F1-F6
    ip address 192.168.1.7 255.255.255.0
    exit
    ip route 0.0.0.0 0.0.0.0 192.168.2.4
    ip route 10.0.2.0 0.0.0.0 192.168.1.5
    no stack
    password manager
    Switch B
    Running configuration:

    ; J4865A Configuration Editor; Created on release #G.07.117

    hostname "HP ProCurve Switch 4108GL"
    cdp run
    qos-passthrough-mode
    module 1 type J4864A
    module 5 type J4863A
    module 2 type J4862B
    module 3 type J4862B
    module 4 type J4863A
    module 7 type J4863A
    module 8 type J4863A
    module 6 type J4863A
    interface A1
    speed-duplex 1000-full
    no lacp
    exit
    interface A2
    no lacp
    exit
    interface A3
    no lacp
    exit
    interface E1
    no lacp
    exit
    interface E2
    no lacp
    exit
    interface E3
    no lacp
    exit
    interface E4
    no lacp
    exit
    interface E5
    no lacp
    exit
    interface E6
    no lacp
    exit
    interface B1
    no lacp
    exit
    interface B2
    no lacp
    exit
    interface B3
    no lacp
    exit
    interface B4
    no lacp
    exit
    interface B5
    no lacp
    exit
    interface B6
    no lacp
    exit
    interface B7
    no lacp
    exit
    interface B8
    no lacp
    exit
    interface B9
    no lacp
    exit
    interface B10
    no lacp
    exit
    interface B11
    no lacp
    exit
    interface B12
    no lacp
    exit
    interface B13
    no lacp
    exit
    interface B14
    no lacp
    exit
    interface B15
    no lacp
    exit
    interface B16
    no lacp
    exit
    interface B17
    no lacp
    exit
    interface B18
    no lacp
    exit
    interface B19
    no lacp
    exit
    interface B20
    no lacp
    exit
    interface B21
    no lacp
    exit
    interface B22
    no lacp
    exit
    interface B23
    no lacp
    exit
    interface B24
    no lacp
    exit
    interface C1
    no lacp
    exit
    interface C2
    no lacp
    exit
    interface C3
    no lacp
    exit
    interface C4
    no lacp
    exit
    interface C5
    no lacp
    exit
    interface C6
    no lacp
    exit
    interface C7
    no lacp
    exit
    interface C8
    no lacp
    exit
    interface C9
    no lacp
    exit
    interface C10
    no lacp
    exit
    interface C11
    no lacp
    exit
    interface C12
    no lacp
    exit
    interface C13
    no lacp
    exit
    interface C14
    no lacp
    exit
    interface C15
    no lacp
    exit
    interface C16
    no lacp
    exit
    interface C17
    no lacp
    exit
    interface C18
    no lacp
    exit
    interface C19
    no lacp
    exit
    interface C20
    no lacp
    exit
    interface C21
    no lacp
    exit
    interface C22
    no lacp
    exit
    interface C23
    no lacp
    exit
    interface C24
    no lacp
    exit
    interface D1
    no lacp
    exit
    interface D2
    no lacp
    exit
    interface D3
    no lacp
    exit
    interface D4
    no lacp
    exit
    interface D5
    no lacp
    exit
    interface D6
    no lacp
    exit
    interface G1
    no lacp
    exit
    interface G2
    no lacp
    exit
    interface G3
    no lacp
    exit
    interface G4
    no lacp
    exit
    interface G5
    no lacp
    exit
    interface G6
    no lacp
    exit
    interface H1
    no lacp
    exit
    interface H2
    no lacp
    exit
    interface H3
    no lacp
    exit
    interface H4
    no lacp
    exit
    interface H5
    no lacp
    exit
    interface H6
    no lacp
    exit
    interface F1
    no lacp
    exit
    interface F2
    no lacp
    exit
    interface F3
    no lacp
    exit
    interface F4
    no lacp
    exit
    interface F5
    no lacp
    exit
    interface F6
    no lacp
    exit
    ip default-gateway 192.168.2.7
    vlan 1
    name "DEFAULT_VLAN"
    untagged A1-A3,B1-B24,C1-C24,D1-D6,E1-E6,F1-F6,G1-G6,H1-H6
    ip address 192.168.2.242 255.255.255.0
    exit

  6. #6
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,456
    Thank Post
    10
    Thanked 494 Times in 434 Posts
    Rep Power
    112
    Could it not be because you are trying to pass a lot of traffic over a single 1Gb link? Which would not be surprising under load.

  7. #7

    Join Date
    Mar 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by DMcCoy View Post
    Could it not be because you are trying to pass a lot of traffic over a single 1Gb link? Which would not be surprising under load.
    I don't think bandwidth is the issue. The link mostly handles low bandwidth traffic like rdp and ssh but it does handle a good deal of that traffic. It could be a packet per second issue but think the HP 4018GL is rated 72 million pps. If that was the issue, I think I would see the issues going from switch A to switch B w/o routing and I only see it from switch A to B when it is first routed. Could the routing be handled differently if the traffic doesn't originate from the switch? That seems like a long shot but I plan to do some testing to try and verify that but have not had the time yet. I also plan to test a secondary router when they let me.

    More pieces to the puzzle...
    a1.jpg



    switch A port A1 counters - Up 9 days.
    Status and Counters - Port Counters for port A1

    Name :


    Link Status : Up


    Bytes Rx : 1,402,845,252 Bytes Tx : 2,159,397,686
    Unicast Rx : 3,078,544,823 Unicast Tx : 3,479,354,851
    Bcast/Mcast Rx : 4,054,308 Bcast/Mcast Tx : 2,317,403


    FCS Rx : 0 Drops Rx : 3351
    Alignment Rx : 0 Collisions Tx : 0
    Runts Rx : 0 Late Colln Tx : 0
    Giants Rx : 0 Excessive Colln : 0
    Total Rx Errors : 0 Deferred Tx : 0

    switch B port A1 counters
    Status and Counters - Port Counters for port A1

    Name :


    Link Status : Up


    Bytes Rx : 2,324,658,228 Bytes Tx : 1,558,440,133
    Unicast Rx : 3,479,984,773 Unicast Tx : 3,079,287,731
    Bcast/Mcast Rx : 2,319,631 Bcast/Mcast Tx : 4,058,700


    FCS Rx : 0 Drops Rx : 0
    Alignment Rx : 0 Collisions Tx : 0
    Runts Rx : 0 Late Colln Tx : 0
    Giants Rx : 0 Excessive Colln : 0
    Total Rx Errors : 0 Deferred Tx : 0


  8. #8

    Join Date
    Mar 2010
    Location
    Adelaide
    Posts
    133
    Thank Post
    2
    Thanked 19 Times in 17 Posts
    Rep Power
    13
    Your explanation of the setup is full of inconsistencies, however based on your post #7 I would either suggest using another patch lead or set the interfaces back to auto as a test and see what they negotiate themselves to, which could show an issue if it's not 1000/full. Although your config could be better (not your fault as you say) nothing in it should cause the drops.

SHARE:
+ Post New Thread

Similar Threads

  1. ProCurve 2910al vs 5406zl for InterVLAN/IP Routing
    By Davit2005 in forum Wired Networks
    Replies: 8
    Last Post: 26th June 2012, 07:57 AM
  2. Routing between VLANs on HP ProCurve 4108GL Switch
    By robknowles in forum Wireless Networks
    Replies: 12
    Last Post: 1st June 2010, 08:12 AM
  3. Replies: 2
    Last Post: 7th May 2010, 12:13 PM
  4. HP Procurve 4108GL
    By wesleyw in forum Hardware
    Replies: 16
    Last Post: 5th July 2006, 01:58 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •