+ Post New Thread
Results 1 to 11 of 11
Wired Networks Thread, Cisco 877w/ PC's can't browse the web. in Technical; Hello. I am very much a cisco newbie. I'm in the process of setting up my home cisco 877w router. ...
  1. #1

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4

    Cisco 877w/ PC's can't browse the web.

    Hello. I am very much a cisco newbie. I'm in the process of setting up my home cisco 877w router. So far I haven't managed to fully configure this. Please can someone take a look at my config and let me know where I am going wrong.
    I have managed to get dhcp working. From the router I can ping google.com but the pc's don't get an internet connection.
    Thanks.

    Code:
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 51200 warnings
    enable secret 5 $1$Q6ck$VimtWwbkx.NOQihHjydCN1
    !
    no aaa new-model
    !
    crypto pki trustpoint TP-self-signed-1502800113
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1502800113
     revocation-check none
     rsakeypair TP-self-signed-1502800113
    !
    !
    crypto pki certificate chain TP-self-signed-1502800113
     certificate self-signed 01
      3082023E 308201A7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
      31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
      69666963 6174652D 31353032 38303031 3133301E 170D3130 30393232 32303136
      32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
      4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 35303238
      30303131 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
      8100E0B3 585D57CF 726343E5 E084A728 B8D387F2 392CC5C9 D935F52B 29CF3EBE
      4D8A6F9A 3C669CF5 C1A793CA E0DB8DAE 7AF20AE7 B3F2FFDB FB4E9CC0 BE094936
      B9052880 37314517 39CA7F13 6B36F142 C1CD0706 D2298E6F 9DE26E87 CDE7A7EC
      3DADDCB5 57072E86 7B52B4C0 4151DD67 B25FE5D3 78B1757A 61E56770 8672F7D2
      57090203 010001A3 66306430 0F060355 1D130101 FF040530 030101FF 30110603
      551D1104 0A300882 06526F75 74657230 1F060355 1D230418 30168014 C0D68F30
      FE18D347 56E463D8 1C584145 4DCCA09F 301D0603 551D0E04 160414C0 D68F30FE
      18D34756 E463D81C 5841454D CCA09F30 0D06092A 864886F7 0D010104 05000381
      8100149A 056346AD A208D3B2 613665F6 6CBACC37 DC5D01BC 0B395358 A37B0994
      B9034966 06418BE8 15955190 0B25F57D 6707FF8D 9175D7DA AE190E2D 99F284E4
      EC8356FD 6F9A2979 5A9EEE98 10294D98 D0243F0C CD71DCCB 93292EA2 55837BDD
      062750DA 02F17747 4B0CA514 D72F7FFC 7588A50C 67AF6B4D 55F400CD 0FF469F9 DC06
            quit
    dot11 syslog
    ip source-route
    !
    !
    ip dhcp excluded-address 192.168.0.1 192.168.0.100
    !
    ip dhcp pool lan_addresses
       import all
       network 192.168.0.0 255.255.255.0
       domain-name skynet.com
       dns-server 192.168.0.1
       default-router 192.168.0.1
       lease 3
    !
    !
    ip cef
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    vtp mode transparent
    username username privilege 15 secret 5 $1$Yd64$VsdmxcqtDosRGC.ArWV9B.
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    vlan 2
     name LAN
    !
    !
    bridge irb
    !
    !
    interface ATM0
     no ip address
     no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
     pvc 0/38
      pppoe-client dial-pool-number 1
     !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
     no ip address
     shutdown
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
     station-role root
    !
    interface Vlan1
     no ip address
     bridge-group 1
    !
    interface Dialer0
     ip address negotiated
     ip mtu 1452
     ip nat outside
     ip virtual-reassembly
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname *******@talktalk.net
     ppp chap password 0 *******
     ppp ipcp dns request
    !
    interface BVI1
     description Inside Local LAN
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     ip tcp adjust-mss 1412
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    !
    !
    !
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     privilege level 15
     login local
     transport input telnet ssh
    !
    scheduler max-task-time 5000
    Last edited by techsup1983; 11th March 2013 at 09:52 PM.

  2. #2

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Anyone?

  3. #3
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,493
    Thank Post
    519
    Thanked 290 Times in 266 Posts
    Rep Power
    82
    Do the PC's get an IP ?

    If not could ou try and set one static see if you get a connection that way... which port on the router have you got your PC's plugged into ?

  4. #4
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,493
    Thank Post
    519
    Thanked 290 Times in 266 Posts
    Rep Power
    82
    Looks like you've got DHCP on, but none of your LAN or WIFE interfaces have an Ip Address - set one statically on your interface which your PC is connected, and assign one on your PC if DHCP doesnt give you one.

  5. #5

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Hello. My pc's get an Ip address but can't access the internet. I suspect it has something to do with

    Code:
    dns-server 192.168.0.1
    So the computers on my network get the IP address of the router for dns but im lost from there.

  6. #6
    cpjitservices's Avatar
    Join Date
    Jul 2010
    Location
    Hessle
    Posts
    2,493
    Thank Post
    519
    Thanked 290 Times in 266 Posts
    Rep Power
    82
    ok try 8.8.8.8 as your DNS. And check your routers DNS on your internet connection side.

  7. Thanks to cpjitservices from:

    techsup1983 (18th March 2013)

  8. #7
    nicholab's Avatar
    Join Date
    Nov 2006
    Location
    Birmingham
    Posts
    1,508
    Thank Post
    4
    Thanked 98 Times in 94 Posts
    Blog Entries
    1
    Rep Power
    52
    I don't think you done the NAT quite right you need to check some examples.

  9. Thanks to nicholab from:

    techsup1983 (18th March 2013)

  10. #8

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    150
    Get SDM onto the router and do it through the GUI.

    Rob

  11. #9

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Hello. I have made some changes and now I have internet connectivity.
    I think it was changing dns-server 62.24.199.13 this is my isp's dns server.. When I do an ipconfig/all on my client it shows the isp's dns server. On my netgear i always had it show 192.168.0.1
    I have made some changes to the NAT also.

    I still have an issue with sdm 2.5 on windows 8 x64, when i click deliver, nothing happens. it just sits there, not sure if this is an issue with the OS or if something is broken.
    I do still need to enable wireless and enable some access lists to lock the router down a little more. Here is my config so far.
    Thanks for your help so far.

    Code:
    Current configuration : 3978 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Router
    !
    boot-start-marker
    boot-end-marker
    !
    logging message-counter syslog
    logging buffered 51200 warnings
    enable secret 5 $1$Q6ck$VimtWwbkx.NOQihHjydCN1
    !
    no aaa new-model
    !
    crypto pki trustpoint TP-self-signed-1502800113
     enrollment selfsigned
     subject-name cn=IOS-Self-Signed-Certificate-1502800113
     revocation-check none
     rsakeypair TP-self-signed-1502800113
    !
    !
    crypto pki certificate chain TP-self-signed-1502800113
     certificate self-signed 01
      3AEC3252 96E9DD3A 10BBD8D7 4411728C 9B9FC7F8 5744059B 8D67D217 5DBCC030 D095
            quit
    dot11 syslog
    ip source-route
    !
    !
    ip dhcp excluded-address 192.168.0.1 192.168.0.100
    !
    ip dhcp pool lan_addresses
       import all
       network 192.168.0.0 255.255.255.0
       domain-name skynet.com
       default-router 192.168.0.1
       dns-server 62.24.199.13
       lease 3
    !
    !
    ip cef
    ip name-server 62.24.199.13
    ip name-server 62.24.199.23
    no ipv6 cef
    !
    multilink bundle-name authenticated
    !
    !
    !
    vtp mode transparent
    username username privilege 15 secret 5 $1$Yd64$VsdmxcqtDosRGC.ArWV9B.
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    vlan 2
     name LAN
    !
    !
    bridge irb
    !
    !
    interface ATM0
     no ip address
     no atm ilmi-keepalive
    !
    interface ATM0.1 point-to-point
     pvc 0/38
      pppoe-client dial-pool-number 1
     !
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
     no ip address
     shutdown
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
     station-role root
    !
    interface Vlan1
     no ip address
     bridge-group 1
    !
    interface Dialer0
     ip address negotiated
     ip mtu 1452
     ip nat outside
     ip virtual-reassembly
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname *******@talktalk.net
     ppp chap password 0 ******
     ppp ipcp dns request
    !
    interface BVI1
     description Inside Local LAN
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
     ip tcp adjust-mss 1412
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    ip http server
    ip http authentication local
    ip http secure-server
    ip http timeout-policy idle 600 life 86400 requests 10000
    !
    !
    ip nat inside source list DSL_ACCESSLIST interface Dialer0 overload
    !
    ip access-list extended DSL_ACCESSLIST
     permit ip 192.168.0.0 0.0.0.255 any
    !
    dialer-list 1 protocol ip permit
    !
    !
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     privilege level 15
     login local
     transport input telnet ssh
    !
    scheduler max-task-time 5000
    Last edited by techsup1983; 14th March 2013 at 12:50 AM.

  12. #10

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    150
    Quote Originally Posted by techsup1983 View Post
    I still have an issue with sdm 2.5 on windows 8 x64, when i click deliver, nothing happens. it just sits there, not sure if this is an issue with the OS or if something is broken.
    I do still need to enable wireless and enable some access lists to lock the router down a little more. Here is my config so far.
    Thanks for your help so far.
    So you can get into SDM? but it crashes? There is an option to preview the commands so you could just cut and past from the preview.

    Or try using sdm-light by just going to teh IP of the router in your browser.

    Rob

  13. #11

    Join Date
    Nov 2012
    Location
    Lancashire
    Posts
    40
    Thank Post
    2
    Thanked 4 Times in 4 Posts
    Rep Power
    4
    Hello. I have found that sdm does not work properly with java 1.7 to make it work i had to use 1.6
    I do have another question about my ipconfig/all on the client showing my public dns server.
    On my old netgear this used to show as 192.168.0.1 My home internet talktalk gives out the current dns servers automatically to the router.
    On the cisco they are set static so if they changed my internet wouldn't work.
    Can this be changed to how it was on my netgear?
    Thanks.

    Ethernet adapter Ethernet:

    cisco config.
    ip dhcp pool lan_addresses
    import all
    network 192.168.0.0 255.255.255.0
    domain-name skynet.com
    default-router 192.168.0.1
    dns-server 62.24.199.13
    lease 3
    !

    Computers ipconfig/all
    Connection-specific DNS Suffix . : skynet.com
    Description . . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
    Physical Address. . . . . . . . . : 8C-89-A5-C1-31-B9
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IPv4 Address. . . . . . . . . . . : 192.168.0.200(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Lease Obtained. . . . . . . . . . : 17 March 2013 20:31:07
    Lease Expires . . . . . . . . . . : 20 March 2013 20:31:07
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : 62.24.199.13
    NetBIOS over Tcpip. . . . . . . . : Enabled

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 12
    Last Post: 23rd February 2010, 10:46 AM
  2. Can you run the KS3 Test server stuff on an XP machine?
    By RoyG in forum ICT KS3 SATS Tests
    Replies: 6
    Last Post: 19th April 2007, 12:44 AM
  3. Replies: 15
    Last Post: 1st April 2006, 04:13 PM
  4. Can never find the damn RSS links!
    By ajbritton in forum Comments and Suggestions
    Replies: 0
    Last Post: 19th January 2006, 10:24 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •