+ Post New Thread
Page 4 of 6 FirstFirst 123456 LastLast
Results 46 to 60 of 90
Wired Networks Thread, Using Smoothwall Express With a Cisco Layer 3 Switch? in Technical; Originally Posted by Arthur Probably too late, but there are drivers available for Hyper-V's synthetic NIC and IDE/SCSI controllers in ...
  1. #46

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,271
    Thank Post
    884
    Thanked 2,749 Times in 2,322 Posts
    Blog Entries
    11
    Rep Power
    785
    Quote Originally Posted by Arthur View Post
    Probably too late, but there are drivers available for Hyper-V's synthetic NIC and IDE/SCSI controllers in FreeBSD-based OSs.

    Freebsdonhyper-v.github.com
    https://github.com/FreeBSDonHyper-V/...HyperV-drivers
    Thanks, I'll give that a go if I get time, I have been stuffing about with this for a couple of days now though and may just stick with the only one that runs without recompiling the whole thing from the ground up.

  2. #47

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,601
    Thank Post
    110
    Thanked 771 Times in 599 Posts
    Rep Power
    183
    @FN_GM Would you still like to know how to add a route on your switch?

  3. #48

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Please Ric

    Is it this? - ip route 172.20.2.0 255.255.255.0 <ip of destination>

    Thanks

  4. #49

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,601
    Thank Post
    110
    Thanked 771 Times in 599 Posts
    Rep Power
    183
    @FN-GM To help, we need to know the subnets of each VLAN (including the subnet that the smoothie is on). IP addresses might help too.

  5. #50

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Have you seen the attached image on post 1?

  6. #51

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,601
    Thank Post
    110
    Thanked 771 Times in 599 Posts
    Rep Power
    183
    Quote Originally Posted by FN-GM View Post
    Have you seen the attached image on post 1?
    You mean the one that doesn't say whether the two IPs are for the clients or the switch and it has no subnet/IPs for the network the Smoothie is on?

  7. #52

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Oh so it doesnt. Smoothie is on 192.168.0.1 255.255.255.0 the siwtch itself doesnt have an IP yet.

  8. #53

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    151
    The switch will need to be on a vlan with an ip in the 192.168.0.0/24 subnet.

    and

    ip route 0.0.0.0 0.0.0.0 192.168.0.1

  9. #54

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    151
    The smoothwall will need routes for the other vlans with a GW set as the IP of the switch.

  10. #55

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by twin--turbo View Post
    The switch will need to be on a vlan with an ip in the 192.168.0.0/24 subnet.

    and

    ip route 0.0.0.0 0.0.0.0 192.168.0.1
    Yes but that does every VLAN. I only need it on certain ones

  11. #56

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,601
    Thank Post
    110
    Thanked 771 Times in 599 Posts
    Rep Power
    183
    I think it is worth pointing out that nobody has given you the full config... we all seem to be giving you enough information to have a bash (maybe we are evil or maybe we are trying to help you learn).

    The thinking is...
    You need a route to VLAN A on the switch
    You need a route to VLAN B on the switch
    You need a default route on the switch

    You then set the switch as your gateway on the clients and maybe add static routes on your Smoothie.

  12. #57

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    But you set the default gateway on the clients as the vlan interface? According to Cisco anyway.

    If i do this and add the below static routes it should work?

    ip route 172.20.1.0 255.255.255.0 192.168.0.1
    ip route 172.20.2.0 255.255.255.0 192.168.0.1

  13. #58

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    151
    You only need one explicit route on the cisco and that is the default one.

    Each client has a DG which is the IP of the VLAN interface IP for it's subnet.

    Rob

  14. #59

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    I know you only need one but i dont want that. I am going to have another VLAN pointing to a different firewall. I want to specify the firewall for each vlan.

    So will what i posted above work with that?

  15. #60

    twin--turbo's Avatar
    Join Date
    Jun 2012
    Location
    Carlisle
    Posts
    2,334
    Thank Post
    1
    Thanked 381 Times in 340 Posts
    Rep Power
    151
    Quote Originally Posted by FN-GM View Post
    ip route 172.20.1.0 255.255.255.0 192.168.0.1
    ip route 172.20.2.0 255.255.255.0 192.168.0.1
    To do what?

    That would tell the cisco that those two networks are routed by the smoothie to somewhere else.



    in brief.....

    Cisco
    ------

    vlan 1
    name smoothwall_network

    vlan 2
    name twenty_one_network

    vlan3
    name twenty_two_network

    interface vlan 1
    description connection-to-smoothwall
    ip address 192.168.0.2 255.255.255.0
    ip helper-address (ip of dhcp server (must be on one of the vlans)
    no shut

    interface vlan 2
    description twenty-one-network
    ip address 172.20.1.1 255.255.255.0
    ip helper-address (ip of dhcp server (must be on one of the vlans)
    no shut

    interface vlan 3
    description twenty-two-network
    ip address 172.20.2.1 255.255.255.0
    ip helper-address (ip of dhcp server (must be on one of the vlans)
    no shut

    int range g0/1-10
    description smoothwall vlan
    switchport mode access
    switchport access vlan 1
    no shut


    int range g0/11-20
    description 20-1 vlan
    switchport mode access
    switchport access vlan 2
    no shut

    int range g0/11-30
    description 20-2 vlan
    switchport mode access
    switchport access vlan 3
    no shut

    ip routing
    ip route 0.0.0.0 0.0.0.0 192.168.0.1




    point each client's dhcp default GW to the respective vlan interface IP.

    Point smoothwall routing for 172.20.2.0/24 to 192.168.0.2
    Point smoothwall routing for 172.20.1.0/24 to 192.168.0.2

    Smoothwall should already be aware of 192.168.0.1


    Rob



SHARE:
+ Post New Thread
Page 4 of 6 FirstFirst 123456 LastLast

Similar Threads

  1. Smoothwall Express Error
    By netadmin in forum *nix
    Replies: 8
    Last Post: 9th October 2007, 08:44 AM
  2. Replies: 3
    Last Post: 19th January 2007, 12:06 PM
  3. Anyone recommend Smoothwall Express?
    By OverWorked in forum *nix
    Replies: 15
    Last Post: 26th January 2006, 12:37 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •