+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
Windows Thread, SYSVOL Replication in Technical; Hi, Am Edugeek virgin so hope some kind soul can rescue me! Active directory on WIN2003 servers replicates ok. However ...
  1. #1

    Join Date
    May 2007
    Location
    Bishopshalt School
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    SYSVOL Replication

    Hi,
    Am Edugeek virgin so hope some kind soul can rescue me!
    Active directory on WIN2003 servers replicates ok. However SYSVOL folder does not replicate at all. NTFRS is running on domain controllers and reports errors of morph directories (can't see them) and shared violations (can't see them either).
    Can anyone suggest solution or recommend appropriate software to address this problem? Have spent ages looking at this but getting nowhere.

    Thanks

    Badger

  2. #2

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    12,968
    Thank Post
    587
    Thanked 1,495 Times in 1,341 Posts
    Rep Power
    398

    Re: SYSVOL Replication

    You say that it replicates ok but it obviously doesn't

    What did you do to test it?

    DCDiag etc..?

    Ben

  3. #3

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    12,968
    Thank Post
    587
    Thanked 1,495 Times in 1,341 Posts
    Rep Power
    398

    Re: SYSVOL Replication

    I also use NetIQ's ADCheck.

    Ben

  4. #4

    Join Date
    May 2007
    Location
    Bishopshalt School
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: SYSVOL Replication

    AD is replicating ok. However SYSVOL is not replicating (scripts, group policies etc) Passes DCDIAG & NETDIAG ok.

    Badger

  5. #5

    m25man's Avatar
    Join Date
    Oct 2005
    Location
    Romford, Essex
    Posts
    1,608
    Thank Post
    49
    Thanked 444 Times in 330 Posts
    Rep Power
    136

    Re: SYSVOL Replication

    99% of these issues are DNS related

    THIS MOST LIKELY WILL BE A DNS ISSUE.

    Check your DNS settings, check the network adaptor settings, check the bindings.
    If you are using Static IP's (of course you are they are DC's) make sure that the internal DNS table contains the correct information. Only use 1 NIC unless you are trunking them. DC's do not like multiple NIC's.

    DNS DNS DNS..... #1 rule of AD troubleshooting.

  6. #6

    mattx's Avatar
    Join Date
    Jan 2007
    Posts
    9,229
    Thank Post
    1,056
    Thanked 1,066 Times in 623 Posts
    Rep Power
    739

    Re: SYSVOL Replication

    Badger - is that Bishopshalt School In Hillingdon ?
    If so - I went there many years ago...........

    Have to agree with M25man - DNS, DNS & DNS.

  7. #7

    Join Date
    Sep 2006
    Location
    Essex
    Posts
    777
    Thank Post
    1
    Thanked 31 Times in 29 Posts
    Rep Power
    23

    Re: SYSVOL Replication

    A couple of thoughts:

    Make sure the time on both servers is sync'd
    Corrupt permissions on the SYSVOL share can cause this
    Run net share on the DC and check that the SYSVOL share does actually exist

  8. #8

    Join Date
    May 2007
    Location
    Bishopshalt School
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: SYSVOL Replication

    Thanks everyone for all your help - much appreciated. However still having problem.
    Time is sync’d and DNS settings ok (can resolve names, ping etc).
    Don’t use multiple nics on DC.
    Server attempts to send policy and script files to staging folders in SYSVOL folder but unable to move files out into final location. Agree could be permission settings on SYSVOL folders, if so what should they be?
    If delete connection objects for replication, servers do in fact recreate correctly suggesting AD working ok.
    Yes, Matt, I am from sunny Hillingdon.

    Badger

  9. #9
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    33

    Re: SYSVOL Replication

    A couple of suggestions if you have not already tried..

    DCDIAG /TESTNS
    REPLMON
    REPADMIN /SYNCALL

    If all that fails, you could un-DCPROMO then re-DCPROMO but don't forget to move any FSMO roles and make sure you still have a GC.

    when I have replication probs I often find it helps to point all the DCs to a single DNS server, restart NETLOGONS, restart DNS SERVER.

  10. #10

    Join Date
    Sep 2006
    Location
    Essex
    Posts
    777
    Thank Post
    1
    Thanked 31 Times in 29 Posts
    Rep Power
    23

    Re: SYSVOL Replication

    Are there any FRS errors in the event log?

    Also, it might be worth checking this article. http://support.microsoft.com/kb/257338

  11. #11

    Join Date
    Nov 2006
    Posts
    547
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: SYSVOL Replication

    How many days has your server been running?

  12. #12

    mattx's Avatar
    Join Date
    Jan 2007
    Posts
    9,229
    Thank Post
    1,056
    Thanked 1,066 Times in 623 Posts
    Rep Power
    739

    Re: SYSVOL Replication

    Yes, Matt, I am from sunny Hillingdon.
    If you get really stuck, I'm only round the corner [ when at home ] - if you want to check me out then I am quite friendly with one of your Govs Mark Haley [ who is the head gov of my kids school where I am a gov.... ]

    Just out of interest, have you checked your 'replication from' settings in sites and services ?
    Also there must be some event logs like djm stated.

  13. #13
    RobD's Avatar
    Join Date
    Mar 2007
    Posts
    85
    Thank Post
    0
    Thanked 7 Times in 7 Posts
    Rep Power
    16

    Re: SYSVOL Replication

    Tought it only replicates twice a day?? Although i may be talking rubbish!!

  14. #14

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,467
    Thank Post
    524
    Thanked 1,993 Times in 932 Posts
    Blog Entries
    23
    Rep Power
    575

    Re: SYSVOL Replication

    Quote Originally Posted by RobD
    Tought it only replicates twice a day?? Although i may be talking rubbish!!
    No. AD syncs at random intervals, but I've heard that every 20-40 mins is the average.

  15. #15
    randle's Avatar
    Join Date
    Dec 2006
    Location
    Chelmsford, Essex
    Posts
    561
    Thank Post
    59
    Thanked 16 Times in 15 Posts
    Rep Power
    18

    Re: SYSVOL Replication

    I have had a very similar problem recently but this was just after a full server restore so it was just down to the AD account passwords being out of sync. I doubt this is the case if you haven't done a restore but they may have got out of sync some other way!!

    For me, even when it looked like replication was working on all other levels, the sysvol folder was still not replicating and this fixed the issue.

    Just a thought

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Site Replication
    By wesleyw in forum Windows
    Replies: 9
    Last Post: 7th December 2007, 09:46 AM
  2. .vbs .bat error in sysvol
    By alonebfg in forum Windows
    Replies: 7
    Last Post: 16th July 2007, 07:57 PM
  3. AD Replication Error
    By kerrymoralee9280 in forum Wireless Networks
    Replies: 3
    Last Post: 12th July 2007, 09:39 AM
  4. SYSVOL Replication
    By Norphy in forum Windows
    Replies: 10
    Last Post: 26th April 2007, 08:43 AM
  5. Replies: 4
    Last Post: 24th January 2007, 11:39 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •