+ Post New Thread
Results 1 to 8 of 8
Windows Thread, Acer Iconia W501P Windows 7 Deployment in Technical; Hi All, I am a technical support officer for a school in Australia. My HOD has decided to go down ...
  1. #1
    rfonti's Avatar
    Join Date
    Aug 2011
    Location
    Sydney, Australia
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Cool Acer Iconia W501P Windows 7 Deployment

    Hi All,

    I am a technical support officer for a school in Australia. My HOD has decided to go down the path of Acer tablets both Android and Windows 7.

    I have managed to use PXE to boot in and ghost.

    See here for details - Acer Support - Answers, E-Mail, Chat - How do I perform a network PXE boot on the ICONIA Tab W500?


    I was wondering if anyone has had any experience deploying these devices and what methods they are using.

    Kind regards,
    Ryan

  2. #2

    Join Date
    Sep 2011
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Creating a Ghost Image

    How did you create the image? I have 30 Iconia Tab 500p's that I am trying to image and have been unsuccessful.

    Did you use a multicast session? Did you have to add any drivers to get them to connect to the network?

    Thanks for any info you can provide.

  3. #3

    Join Date
    Oct 2011
    Location
    Clyde
    Posts
    3
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    PXE imaging using FOG

    I too am having issues imaging these systems... and am looking for suggestions!

    We currently use FOG 0.29 with the latest kernel and it appears I'll have to roll my own kernel to get the ASIX network card to function as well as the display driver (all you get is a snowy display once FOG get past the initial kernel load... I've tried all the video modes available, too!)

    I've had lots of issues even getting PXE to boot... the ASIX PXE bootrom would take our pxelinux.0 bootfile name from DHCP option 67 but then request some malformed file from the TFTP server... Because I was using FOG and tftpd-hpa, I was able to use a mapfile in the /etc/default/tftpd-hpa config (the -m option) to force the malformed name request to be returned with pxelinux.0 to the client and boot the FOG menu... but all that work wasted a week of my time to figure out already! (NOTE: I am using the Acer bios version 1.08, I have not tried the newer bios releases to see if they fix something in the ASIX bootrom... but there is nothing I could find in their release notes to indicate that...)

    So now I am wondering how far down the rabbit hole I should keep going... now that I've got it booting, do I roll my own kernel and drivers for FOG? or look into WDS/MDT?

    If I switch to WDS, will PXE not work there either? and will it even have the tools to do the malformed name remapping in its TFTP server? And will it have the necessary drivers to even deploy over the W500's network card and video card? Also should I consider using FOG's TFTP menu to launch WDS (if that is even possible...)?

    My imaging concerns are 2 fold, too...

    1) We have a Microsoft ESS Agreement which allows us to install the latest OS (i.e. Win7 Professional) on any MS factory loaded system (such as WinXP or Win7 Home)... So we really don't want to have to purchase the more expensive W500 with Win7 Professional preloaded.

    2) We really NEED a reimaging solution so when a system gets a virus etc... we can image it back with all of our software and settings quickly... having to use the Acer recovery DVD to factory default it and manually loading Office, uninstalling/reinstalling our virus protection software, loading other required software, and adjusting settings would be kind of a support nightmare.

    Any suggestions are appreciated!!! I know these devices are pretty new, but should start getting a lot of exposure in the K12 space soon... hopefully others will find this post and have some ideas...

    In the mean time I will put in a support request to Acer to see how far that will get me... but as this is a pretty complicated request... they will likely tell me I'm on my own as they can't support an imaging solution outside of their standard support services and restore DVD... :-(

    Thanks in advance for any insight you all have with this issue!

  4. #4

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,687
    Thank Post
    824
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    WDS/MDT are great and adding a new driver is trivial and quick in comparison.

  5. #5

    Join Date
    Oct 2011
    Location
    Clyde
    Posts
    3
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Synack,

    Can you confirm if the W500 will PXE boot to WDS? and if I need to add drivers? If so... do you have any good articles you can point me to in order to get started?

    Thanks!

  6. #6

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,687
    Thank Post
    824
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    Quote Originally Posted by nealbarrett View Post
    Can you confirm if the W500 will PXE boot to WDS? and if I need to add drivers? If so... do you have any good articles you can point me to in order to get started?

    Thanks!
    We don't have such pretty toys but if it PXE boots to FOG then it will PXE boot to MDT, if it uses any really weird/new network hardware then you will need to add drivers but that is as trivial as downloading them and pointing the import driver wizzard at the folder.

    You can look at these:
    Deploy Windows 7 with MDT 2010 + WDS + WAIK | I am legend

    Deploying Windows 7 - Part 1: Windows AIK 2.0 Enhancements
    and
    Gnawgnu&#39s*Realm: Getting started with MDT 2010 and windows 7

    http://www.youtube.com/watch?v=aV_BgBXp47k

    for some overview

    you can even do this: ZeroTouch for MDT 2010 without SCCM! | IThastobecool.com if you want to automate further.
    Last edited by SYNACK; 30th October 2011 at 07:13 PM.

  7. Thanks to SYNACK from:

    nealbarrett (30th October 2011)

  8. #7

    Join Date
    Oct 2011
    Location
    Clyde
    Posts
    3
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Quote Originally Posted by SYNACK View Post
    We don't have such pretty toys but if it PXE boots to FOG then it will PXE boot to MDT, if it uses any really weird/new network hardware then you will need to add drivers but that is as trivial as downloading them and pointing the import driver wizzard at the folder.

    You can look at these:
    Deploy Windows 7 with MDT 2010 + WDS + WAIK | I am legend

    Deploying Windows 7 - Part 1: Windows AIK 2.0 Enhancements
    and
    Gnawgnu&#39s*Realm: Getting started with MDT 2010 and windows 7

    MDT 2010 Lite Touch - Unleashed, part 1 of 27 - YouTube

    for some overview

    you can even do this: ZeroTouch for MDT 2010 without SCCM! | IThastobecool.com if you want to automate further.
    Thanks for getting me started! I really appreciate the help!

    One issue I may have is PXE wouldn't work for FOG without using tftpd-hpa's mapfile feature. I had to use this feature in order to ignore a malformed filename request (RRQ) from the machine's bootrom and send the proper boot file (in FOG's case... pxelinux.0) If this same malformed filename request happens in WDS, is there a way to fix that up? Not sure if you've ever ran into any weird issues with PXE roms like this with WDS... but I thought I'd check... Thanks in advance for any thing you can throw my way!

  9. #8

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,687
    Thank Post
    824
    Thanked 2,570 Times in 2,187 Posts
    Blog Entries
    9
    Rep Power
    731
    Quote Originally Posted by nealbarrett View Post
    Thanks for getting me started! I really appreciate the help!

    One issue I may have is PXE wouldn't work for FOG without using tftpd-hpa's mapfile feature. I had to use this feature in order to ignore a malformed filename request (RRQ) from the machine's bootrom and send the proper boot file (in FOG's case... pxelinux.0) If this same malformed filename request happens in WDS, is there a way to fix that up? Not sure if you've ever ran into any weird issues with PXE roms like this with WDS... but I thought I'd check... Thanks in advance for any thing you can throw my way!
    Not sure, there are ways to make bootable USB key/sticks that load up the initial WinPE environment and connect to the distribution share to grab an image anyway, it even makes an ISO for easy CD booting if PXE is not working so you should be fine to actually get it connecting and grabbing an image file.

SHARE:
+ Post New Thread

Similar Threads

  1. Windows Deployment Services (WDS) Image Error
    By adamchapman in forum How do you do....it?
    Replies: 1
    Last Post: 3rd September 2009, 09:59 AM
  2. Acer Aspire One + Windows 7 Drivers
    By Dos_Box in forum How do you do....it?
    Replies: 0
    Last Post: 6th July 2009, 09:53 AM
  3. Windows Deployment Services
    By Burnsy2023 in forum Wireless Networks
    Replies: 1
    Last Post: 21st January 2008, 10:32 AM
  4. Windows Deployment Services Walkthrough
    By ctbjs in forum How do you do....it?
    Replies: 2
    Last Post: 1st June 2007, 09:58 AM
  5. Windows Deployment Services - the new RIS
    By steve in forum Windows
    Replies: 5
    Last Post: 14th October 2006, 05:09 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •