+ Post New Thread
Results 1 to 9 of 9
Windows Thread, Laptop keyboard and touchpad stop working when "Windows Starting" appears in Technical; Have a sony vaio laptop running windows 7 but when the laptop starts up the keyboard is working fine and ...
  1. #1
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22

    Laptop keyboard and touchpad stop working when "Windows Starting" appears

    Have a sony vaio laptop running windows 7 but when the laptop starts up the keyboard is working fine and the LED for Num lock comes on, pressing caps lock causes that LED to come on. But when the laptop gets to the "Windows Starting" part of the log in the LEDs switch off and the keyboard and touchpad is unuseable.

    Anyone had similar problems? Have tried taking the battery out holding power for 10 seconds, running only on AC power. Restoring back to a previous time when it was working.

  2. #2


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,506
    Thank Post
    227
    Thanked 848 Times in 727 Posts
    Rep Power
    287
    whats it do in safemode?

  3. #3
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    Same, no keyboard or touchpad

  4. #4

    Join Date
    Jul 2005
    Location
    Worthing, West Sussex
    Posts
    860
    Thank Post
    18
    Thanked 73 Times in 68 Posts
    Rep Power
    34
    Just had a similar problem with some XP machines when imaging went a bit wrong - the USB drivers managed to become 'unsigned' so would not install without user confirmation so keyboards and mice didn't work before logon.

    Solution on XP was to delete the Catroot2 folder then restart - not sure if that'll apply to Win7 though.

  5. #5
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    No effect im afraid.

  6. #6

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,680
    Thank Post
    3,210
    Thanked 1,030 Times in 955 Posts
    Rep Power
    361
    attach an external usb keyboard and mouse and see if those work ?

    I presume all usb related items in the bios are enabled ?

    If you can get an external usb keyboard and mouse attached and working you can then use those to mess around with settings etc to see if anything will fix it

    ie re installation of drivers for at least the touchpad , not sure about the keyboard

    Removing them from device manager and allow them to re install ?

  7. #7
    HMCTech's Avatar
    Join Date
    Apr 2008
    Posts
    618
    Thank Post
    37
    Thanked 48 Times in 35 Posts
    Rep Power
    22
    USB keyboard and mouse work thats how I was able to try and delete the folder, so its something that happens when windows loads. Unfortuately its a sony so the drivers on website are basic and just say use "sony Care" which of course is no use at all.

  8. #8

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,680
    Thank Post
    3,210
    Thanked 1,030 Times in 955 Posts
    Rep Power
    361
    Quote Originally Posted by AlexPilot View Post
    USB keyboard and mouse work thats how I was able to try and delete the folder, so its something that happens when windows loads. Unfortuately its a sony so the drivers on website are basic and just say use "sony Care" which of course is no use at all.
    Boot into safe mode with networking , device manager --> expand the usb section --> delete all the USB Root Hub items --> Install the latest chipset drivers which should hopefully re do the USB items, install the touchpad driver

    Whilst in safe mode under the keyboard section ( am going from xp so win 7 may be different ) remove the HID Keyboard device and you can either scan for hardware changes by right clicking on the computer at the top and scan for hardware changes or reboot to see if that fixes the USB side of things.

    Most likely require a reboot

    Also is there a physical slider switch to disable wireless / bluetooth etc and does this make any difference when on or off ?

    Found this

    http://doube.org/sztp.html

    From this forum :

    http://www.hardwareanalysis.com/content/topic/58009/

    obviously not sure what model of sony you have so not sure if its applicable or relevant
    Last edited by mac_shinobi; 6th June 2011 at 04:24 PM.

  9. #9

    Join Date
    Jan 2013
    Location
    Canada
    Posts
    1
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Unhappy

    Quote Originally Posted by AlexPilot View Post
    Have a sony vaio laptop running windows 7 but when the laptop starts up the keyboard is working fine and the LED for Num lock comes on, pressing caps lock causes that LED to come on. But when the laptop gets to the "Windows Starting" part of the log in the LEDs switch off and the keyboard and touchpad is unuseable.

    Anyone had similar problems? Have tried taking the battery out holding power for 10 seconds, running only on AC power. Restoring back to a previous time when it was working.
    Been searching around google to best describe what was happening with my VAIO laptop and this was exactly it. Have you ever found a way to fix this? I cant use my laptop at all have to use a usb keyboard n mouse instead.

    Just happened today and I need to fix it asap before I go back to school.

SHARE:
+ Post New Thread

Similar Threads

  1. ACS to stop chasing "pirates"
    By MK-2 in forum General Chat
    Replies: 0
    Last Post: 25th January 2011, 10:30 AM
  2. Replies: 3
    Last Post: 12th August 2010, 02:57 AM
  3. Laptop touchpad not working when power plugged in
    By UnknownStuntman in forum Hardware
    Replies: 8
    Last Post: 5th March 2010, 07:32 AM
  4. Starting a new job as a "Network Manager"
    By Little-Miss in forum General Chat
    Replies: 18
    Last Post: 4th September 2008, 12:00 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •