+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 23
Windows Thread, Trust Tablet Driver - Installsheild Setup.exe - Best way to install? in Technical; Can anyone please suggest a way to install a driver on 93 computers without us visiting each computer and manually ...
  1. #1

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25

    Trust Tablet Driver - Installsheild Setup.exe - Best way to install?

    Can anyone please suggest a way to install a driver on 93 computers without us visiting each computer and manually installing the software?

    It is a "Trust Widescreen Mini Tablet" (model: 16485). The driver is installed with "setup.exe" which is an installshield installer.
    I cannot find an MSI and have failed trying to get it to install with a startup script using "setup -s" and a "setup.iss" file for a silent install.

    Can anyone please help?

  2. #2

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    12,978
    Thank Post
    587
    Thanked 1,496 Times in 1,342 Posts
    Rep Power
    398
    Have you tried extracting it with universal extractor?

    Ben

  3. Thanks to plexer from:

    burgemaster (22nd March 2011)

  4. #3

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25
    Quote Originally Posted by plexer View Post
    Have you tried extracting it with universal extractor?

    Ben
    Hi ben,
    I have tried to extract the "setup.exd" which fails on all options, but I can extract the data1.cab files.... Does this help me?

    Thanks Ben..

  5. #4
    Norphy's Avatar
    Join Date
    Jan 2006
    Location
    Harpenden
    Posts
    1,984
    Thank Post
    45
    Thanked 218 Times in 165 Posts
    Blog Entries
    6
    Rep Power
    93
    It might be worth trying AutoIt if you can't get it to install silently.

  6. #5

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25
    Quote Originally Posted by Norphy View Post
    It might be worth trying AutoIt if you can't get it to install silently.
    Hi mate,

    The silent install works when you run the setup with the -s command, but I cant get the computuers to install it when they are booted if you know what I mean.

  7. #6
    Norphy's Avatar
    Join Date
    Jan 2006
    Location
    Harpenden
    Posts
    1,984
    Thank Post
    45
    Thanked 218 Times in 165 Posts
    Blog Entries
    6
    Rep Power
    93
    Odd. Could be a permissions issue I guess? Where are you running the installer from?

  8. #7

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25
    Quote Originally Posted by Norphy View Post
    Odd. Could be a permissions issue I guess? Where are you running the installer from?
    I have the install files on a network share.
    I have given "Domain Computers" read access to the share and files.
    I have created a SETUP.ISS files and tested that "Setup -s" works.
    I created a group policy that calls a bat script:
    "\\server\share\Trust_Tablet_Driver\setup.exe /s" (the script works run manually)
    The group policy is a computer policy assigned to the room of computers. (see attached pic)

    Should this in theory work? I have only ever installed with MSI`s?

    Thanks in advance
    Attached Images Attached Images

  9. #8
    Norphy's Avatar
    Join Date
    Jan 2006
    Location
    Harpenden
    Posts
    1,984
    Thank Post
    45
    Thanked 218 Times in 165 Posts
    Blog Entries
    6
    Rep Power
    93
    Should work in theory, I've installed programs via startup scripts before. Are you getting any errors in your event logs which give a clue as to what's going wrong?

    Can you installed it by hand from that share? What happens if you try to do an administrative install (/a switch)?

  10. Thanks to Norphy from:

    burgemaster (22nd March 2011)

  11. #9

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,393
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    Quote Originally Posted by burgemaster View Post
    I have the install files on a network share.
    I have given "Domain Computers" read access to the share and files.
    I have created a SETUP.ISS files and tested that "Setup -s" works.
    I created a group policy that calls a bat script:
    "\\server\share\Trust_Tablet_Driver\setup.exe /s" (the script works run manually)
    The group policy is a computer policy assigned to the room of computers. (see attached pic)

    Should this in theory work? I have only ever installed with MSI`s?

    Thanks in advance
    Try enabling this in group policy (if it isnt alredy)

    Computer Configuration\Administrative Templates\System\Logon\ Always wait for the network at computer startup and logon

  12. Thanks to FN-GM from:

    burgemaster (22nd March 2011)

  13. #10

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25
    Installed !!!

    "Always wait for the network at computer startup and logon" did it. Many thanks!!!

    Could I please ask if you know of a way that I can stop the software installing each and everytime the computer reboots?

    I found someone using something like below but it doesnt seem to work?

    if C:\DeleteUsed4Install exist then goto ok
    md C:\DeleteUsed4Install
    \\server\share\Trust_Tablet_Driver\setup.exe /s


    But it doesnt get past the first line?

    Can anyone please help?

  14. #11

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,393
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    adapt this:

    if exist "C:\Program Files\location of software" goto :eof ELSE
    @echo off
    \\server\share\Trust_Tablet_Driver\setup.exe /s



    This will see if the files for the program are in the program files. If the files are already, it must be isntalled so the script quits right away without installing it again.

    I use this code allot for deploying stuff.

    Obviously you need to change the locatin it uses in program files.

  15. #12

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25
    What an idiot.....lol, just been over to the classroom to test with the tablet plugged in.

    I was still remotely browsing the C$ of the previous computer that I manually installed it on.... DOH

    k, still not installing.. do you have any other suggestions please?
    I have the "domain computers" read permissions on the share. I know the script is getting executed.
    Do I maybe need any other permissions?

    Thanks in advance!

  16. #13

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,393
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    I know the script is getting executed.

    how do you know? Does it say running startup scripts before you get to the logon screen?

  17. #14

    Join Date
    Aug 2007
    Posts
    802
    Thank Post
    95
    Thanked 60 Times in 45 Posts
    Rep Power
    25
    I added "MD C:\delete_test" to the script. This "does" get created on the C drive

    Yes it does hang around at "running startup scripts" for a while.

  18. #15

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,393
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    try putting quotations in the path like this

    "\\server\share\Trust_Tablet_Driver\setup.exe" /s

    remember to delete the directory its creates or it will not run


    If that doesnt work do this:

    try running /p or /passive instead of silent

    This may bring up the installer box and show any errors that maybe happening

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Install media for Windows XP Tablet Edition
    By dhicks in forum Windows
    Replies: 5
    Last Post: 13th September 2012, 10:05 PM
  2. Ghosting Toshiba M750 Tablet PC-ICH Driver
    By MGSTech in forum O/S Deployment
    Replies: 0
    Last Post: 4th February 2009, 04:25 PM
  3. XP install woes in an old Toshiba tablet notebook
    By Trapper in forum O/S Deployment
    Replies: 4
    Last Post: 10th October 2008, 10:22 PM
  4. Win98 - nusb33e.exe driver
    By contink in forum Hardware
    Replies: 2
    Last Post: 29th November 2007, 11:34 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •