+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 18
Windows Thread, sync iphone with exchange 2003 in Technical; hi i have an iphone which i would like to syncronise to exchange server 2003 sp2. I have put my ...
  1. #1
    bart21's Avatar
    Join Date
    Aug 2009
    Location
    peterborough
    Posts
    405
    Thank Post
    79
    Thanked 54 Times in 52 Posts
    Rep Power
    20

    sync iphone with exchange 2003

    hi i have an iphone which i would like to syncronise to exchange server 2003 sp2.

    I have put my details etc into iphone click refresh and connection to the server failed, please help.

  2. #2
    gibbo_ap's Avatar
    Join Date
    Nov 2007
    Location
    Staffs, UK
    Posts
    937
    Thank Post
    233
    Thanked 81 Times in 64 Posts
    Rep Power
    36
    errr same was just trying to do this again

  3. Thanks to gibbo_ap from:

    bart21 (5th November 2010)

  4. #3

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    Is it your own Exchange box?
    Do you have an external web-mail (Outlook Web Access) link?

  5. Thanks to pantscat from:

    bart21 (5th November 2010)

  6. #4
    bart21's Avatar
    Join Date
    Aug 2009
    Location
    peterborough
    Posts
    405
    Thank Post
    79
    Thanked 54 Times in 52 Posts
    Rep Power
    20
    yes we have external, i am trying this from inside network though.

    I think i may be able to give more details, This in the event log:

    The mailbox server [Galadriel.peele.lincs.sch.uk] does not allow "Negotiate" authentication to its [exchange] virtual directory. Exchange ActiveSync can only access the server using this authentication scheme. For information about how to configure Exchange virtual directory settings, see Microsoft Knowledge Base article 817379, "Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003" (Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003). For information about how to properly configure IIS to support Kerberos and NTLM authentication, see Microsoft Knowledge Base article 215383, "How To Configure IIS to Support Both Kerberos and NTLM Authentication" (How to configure IIS to support both the Kerberos protocol and the NTLM protocol for network authentication). This issue may occur after installing Windows SharePoint Services on a server running Exchange Server 2003. For information
    Anyone any idea how to solve this?

  7. #5

    Join Date
    Oct 2005
    Posts
    849
    Thank Post
    51
    Thanked 115 Times in 105 Posts
    Rep Power
    74
    Ah... ok - looks like you need to fiddle with IIS to get ActiveSync working happily - looks like Method 2 here (Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003) will do the trick.

  8. Thanks to pantscat from:

    bart21 (5th November 2010)

  9. #6
    mb2k01's Avatar
    Join Date
    Jan 2007
    Posts
    1,138
    Thank Post
    189
    Thanked 230 Times in 195 Posts
    Rep Power
    92
    Are you the Exchange Admin?
    If not, check that mobile messaging is enabled on your account.

    If you are confident you are putting in all urls/passwords correct, try going back in to the settings and turning off ssl - I've had really odd things with that at times on a previous install.

  10. Thanks to mb2k01 from:

    bart21 (5th November 2010)

  11. #7
    bart21's Avatar
    Join Date
    Aug 2009
    Location
    peterborough
    Posts
    405
    Thank Post
    79
    Thanked 54 Times in 52 Posts
    Rep Power
    20
    thanks for the replys
    @mb2k01 - I am the ex admin mobile messaging is enabled. SSL is off.

    thanks again people

  12. #8
    mb2k01's Avatar
    Join Date
    Jan 2007
    Posts
    1,138
    Thank Post
    189
    Thanked 230 Times in 195 Posts
    Rep Power
    92
    It may be worth doing an Exchange ActiveSync test on https://www.testexchangeconnectivity.com and seeing what results come back?
    Are you the only mobile user using this type of device, or do others have this working?

  13. Thanks to mb2k01 from:

    Squiffy101 (7th February 2011)

  14. #9
    bart21's Avatar
    Join Date
    Aug 2009
    Location
    peterborough
    Posts
    405
    Thank Post
    79
    Thanked 54 Times in 52 Posts
    Rep Power
    20
    just to let you know, pantscats way worked.

    THANKS EVERYONE

    nick

  15. #10
    gibbo_ap's Avatar
    Join Date
    Nov 2007
    Location
    Staffs, UK
    Posts
    937
    Thank Post
    233
    Thanked 81 Times in 64 Posts
    Rep Power
    36
    Quote Originally Posted by bart21 View Post
    just to let you know, pantscats way worked.

    THANKS EVERYONE

    nick
    what was it you did bart? im having no joy

  16. #11
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,464
    Thank Post
    10
    Thanked 496 Times in 436 Posts
    Rep Power
    113
    You need to follow method 2 in the KB to create an additional virtual directory for active-sync, I had to do the same to get iphones etc working here.

  17. #12
    mrbios's Avatar
    Join Date
    Jun 2007
    Location
    Stroud, Gloucestershire
    Posts
    2,541
    Thank Post
    362
    Thanked 263 Times in 215 Posts
    Rep Power
    100
    Trying to get windows mobile 7 to connect to exchange 2010 and it's telling me that the server im trying to connect to doesn't support activesync. Active sync is definitly enabled onthe server, anyone know of a fix to this? (thought id post it here as it's a similar issue)

    EDIT: Nevermind ignore me, i've fixed my problem, was something completely different to what you guys are doing
    Last edited by mrbios; 10th November 2010 at 06:43 PM.

  18. #13
    gibbo_ap's Avatar
    Join Date
    Nov 2007
    Location
    Staffs, UK
    Posts
    937
    Thank Post
    233
    Thanked 81 Times in 64 Posts
    Rep Power
    36
    Quote Originally Posted by DMcCoy View Post
    You need to follow method 2 in the KB to create an additional virtual directory for active-sync, I had to do the same to get iphones etc working here.
    i followed that to the letter and no joy. i looked in event viewer and am getting a activesync related error (with my username, not sysadmin which im logged in on the server)saying cant access something to do with ssl, its referencing that article. too late in the day server updates to do now will look again tomorrow

  19. #14
    bart21's Avatar
    Join Date
    Aug 2009
    Location
    peterborough
    Posts
    405
    Thank Post
    79
    Thanked 54 Times in 52 Posts
    Rep Power
    20
    hi gibbo_ap

    I followed this
    Method 2


    Important Method 2 should be used only in an environment that has no Exchange Server 2003 front-end server. The registry changes should be made only on the server on which the mailboxes are located.

    Create a secondary virtual directory for Exchange that does not require SSL, and then add a registry value to point to the new virtual directory.

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
    322756 (How to back up and restore the registry in Windows XP ) How to back up and restore the registry in Windows

    Note These steps affect both Outlook Mobile Access connections and Exchange ActiveSync connections. After you follow these steps, both Outlook Mobile Access and Exchange ActiveSync connections use the new virtual directory that you create.
    Disable the forms-based authentication for the Exchange virtual directory
    To create a secondary virtual directory for Exchange that is based on steps 1 through 7 of the following procedure, make sure that forms-based authentication is disabled for the Exchange virtual directory before you make the copy. Before you follow these steps, disable forms-based authentication in Exchange System Manager. Then restart Internet Information Services (IIS). To do this, follow these steps:
    Open Exchange Manager.
    Expand Administrative Groups, expand the first administrative group, and then expand Servers.
    Expand the server container for the Exchange Server 2003 server that you will be configuring, expand Protocols, and then expand HTTP.
    Under the HTTP container, right-click the Exchange Virtual Server container, and then click Properties.
    Click the Settings tab, clear the Enable Forms Based Authentication check box, and then click OK.
    Close Exchange Manager.
    Click Start, click Run, type IISRESET/NOFORCE, and then press ENTER to restart Internet Information Services (IIS).
    Create a secondary virtual directory for Exchange server
    You must use Internet IIS Manager to create this virtual directory for Exchange ActiveSync and Outlook Mobile Access to work. If you are using Windows Server 2003, follow these steps:
    Start Internet Information Services (IIS) Manager.
    Locate the Exchange virtual directory. The default location is as follows:
    Web Sites\Default Web Site\Exchange
    Right-click the Exchange virtual directory, click All Tasks, and then click Save Configuration to a File.
    In the File name box, type a name. For example, type ExchangeVDir. Click OK.
    Right-click the root of this Web site. Typically, this is Default Web Site. Click New, and then click Virtual Directory (from file).
    In the Import Configuration dialog box, click Browse, locate the file that you created in step 4, click Open, and then click Read File.
    Under Select a configuration to import , click Exchange, and then click OK.

    A dialog box will appear that states that the "virtual directory already exists."
    Select the Create a new virtual directory option. In the Alias box, type a name for the new virtual directory that you want Exchange ActiveSync and Outlook Mobile Access to use. For example, type exchange-oma. Click OK.
    Right-click the new virtual directory. In this example, click exchange-oma. Click Properties.
    Click the Directory Security tab.
    Under Authentication and access control, click Edit.
    Make sure that only the following authentication methods are enabled, and then click OK:
    Integrated Windows authentication
    Basic authentication
    On the Directory Security tab, under IP address and domain name restrictions, click Edit.
    Click the option for Denied access, click Add, click Single computer and type the IP address of the server that you are configuring, and then click OK twice.
    Under Secure communications, click Edit. Make sure that Require secure channel (SSL) is not enabled, and then click OK.
    Click OK, and then close the IIS Manager.
    Click Start, click Run, type regedit, and then click OK.
    Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\MasSync\Parameters
    Right-click Parameters, click to New, and then click String Value.
    Type ExchangeVDir, and then press ENTER. Right-click ExchangeVDir, and then click Modify.

    NoteExchangeVDir is case-sensitive. If you do not type ExchangeVDir exactly as it appears in this article, ActiveSync does not find the key when it locates the exchange-oma folder.
    In the Value data box, type the name of the new virtual directory that you created in step 8. For example, type /exchange-oma. Click OK.
    Quit Registry Editor.
    Restart the IIS Admin service. To do this, follow these steps:
    Click Start, click Run, type services.msc, and then click OK.
    In the list of services, right-click IIS Admin service, and then click Restart.
    If you want to reuse Forms-based Authentication on the Exchange server, follow these steps to re-enable Forms-based Authentication on the /Exchange virtual directory in Exchange System Manager.
    Open Exchange Manager.
    Expand Administrative Groups, expand the first administrative group, and then expand Servers.
    Expand the server container for the Exchange Server 2003 server that you will be configuring, expand Protocols, and then expand HTTP.
    Under the HTTP container, right-click the Exchange Virtual Server container, and then click Properties.
    Click the Settings tab, click to select the Enable Forms Based Authentication check box, and then click OK.
    Close Exchange Manager.
    Click Start, click Run, type IISRESET/NOFORCE, and then press ENTER to restart Internet Information Services (IIS).
    and it worked, the only other thing i had to do was stop and restart SMTP service.

    Another important thing to note is the FBA must be switched off before the settings are saved to the file.

    any problems feel free to post and we will try and help.

    nick

  20. #15
    gibbo_ap's Avatar
    Join Date
    Nov 2007
    Location
    Staffs, UK
    Posts
    937
    Thank Post
    233
    Thanked 81 Times in 64 Posts
    Rep Power
    36
    Quote Originally Posted by bart21 View Post
    hi gibbo_ap

    I followed this


    and it worked, the only other thing i had to do was stop and restart SMTP service.

    Another important thing to note is the FBA must be switched off before the settings are saved to the file.

    any problems feel free to post and we will try and help.

    nick
    good morning, i am guessing that when this is followed that the owa login is different? we are now getting a popup with username and pw requested with no domain. (email from the head telling us its broke as you have to enter the domain).

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. sync iphone with exchange 2003
    By bart21 in forum Windows
    Replies: 6
    Last Post: 12th October 2010, 04:48 PM
  2. iPhone 3GS connectivity to SBS 2003 Exchange Server Problem
    By Number6 in forum Netbooks, PDA and Phones
    Replies: 0
    Last Post: 31st August 2010, 03:11 PM
  3. Sync SIMS Diary with my IPHONE
    By Latics4ever in forum Netbooks, PDA and Phones
    Replies: 4
    Last Post: 25th March 2009, 09:51 PM
  4. iPhone + Exchange Sync
    By tech-man in forum Hardware
    Replies: 3
    Last Post: 4th February 2009, 11:29 AM
  5. RM Exchange 2003 with Blackberry / iPhone email push integration
    By MattCrick in forum How do you do....it?
    Replies: 0
    Last Post: 7th July 2008, 03:30 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •