+ Post New Thread
Results 1 to 7 of 7
Windows Thread, Add printer script not workling in Technical; I'm having problems with my printer script. We migrated to W2003 server on a new box, leaving the demoted DC ...
  1. #1
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Add printer script not workling

    I'm having problems with my printer script. We migrated to W2003 server on a new box, leaving the demoted DC as the Print Server. Users can browse to all the printers no problem, and the script runs fine for all users [i've tested running it visibly and it steps through everything fine] but no printer gets attached.

    I have mostly XP clients and some 2000 clients.

    Anyone help?

  2. #2

    Join Date
    Jun 2005
    Location
    Elgin, Scotland
    Posts
    387
    Thank Post
    1
    Thanked 4 Times in 4 Posts
    Rep Power
    23

    Re: Add printer script not workling

    Can you post the script in full for us to check?

  3. #3

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,909
    Thank Post
    596
    Thanked 2,164 Times in 989 Posts
    Blog Entries
    23
    Rep Power
    628

    Re: Add printer script not workling

    I had to re-write some 2K scripts for XP as the syntax has changed on alot of commands. You might want to start looking there first.

  4. #4

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: Add printer script not workling

    Rics script (heavily modified by me) works fine for me in a number of schools running XP + W2k3 server.

    http://www.edugeek.net/index.php?nam...iewtopic&t=404

  5. #5
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: Add printer script not workling

    My script worked for my network perfectly before the migration - with no changes anywhere else - so there's no problem with the script.

    here's an excerpt anyway [kix32]:
    Code:
    DelPrinterConnection ("\\SERVER\printer")
    
    set computer="@wksta"
    $room=SubStr(@wksta,2,2)
    $client=SubStr(%clientname%,2,2)
    
    Select
      Case ($room="EC") 
         AddPrinterConnection ("\\SERVER\printer")
         SetDefaultPrinter ("SERVER\printer")
    EndSelectSelect
    Select
      Case ($room="19") 
         AddPrinterConnection ("\\SERVER\printer")
         SetDefaultPrinter ("\\SERVER\printer")
    EndSelect
    Select

  6. #6
    tarquel's Avatar
    Join Date
    Jun 2005
    Location
    Powys, Mid-Wales, UK
    Posts
    1,740
    Thank Post
    13
    Thanked 44 Times in 34 Posts
    Rep Power
    29

    Re: Add printer script not workling

    looks good to me mark

    the thought occurs - how is the script being executed? have you moved the script to the netlogon of the 2003 server then?

    mine is working fine - just for equal measure, i've added kix32.exe (with share path) to the firewall exceptions list but it was working before i did that

    One thought is - when installing Server 2003 - did it have sp1 slipstreamed into it i.e. server 2003 SP1 CD - or not because if so, the server's firewall will be on by default, as opposed to installing SP1 afterwards (in the later - you have to run a wizard to enable it and other stuff - not done it so dont know what process it is exactly)

    PS have you tried using the latest version of kix32.exe - it *may* help but wont do any harm as u dont have any complex things that might have changed

    Cheers
    Nath

  7. #7
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: Add printer script not workling

    the script has moved to the netlogon share of the new dc - I changed the call path to the DC. As I say - the script runs fine without errors - just doesn't give the desired result!

    Checked - firewall is off on server.

SHARE:
+ Post New Thread

Similar Threads

  1. A Printer Script
    By Ric_ in forum Scripts
    Replies: 164
    Last Post: 1st October 2010, 10:11 AM
  2. logon script for printer
    By ozzy in forum Scripts
    Replies: 6
    Last Post: 22nd November 2007, 03:03 PM
  3. Printer Script
    By faza in forum Scripts
    Replies: 9
    Last Post: 14th September 2007, 08:30 AM
  4. Logon script & Printer script question.
    By Galway in forum Windows
    Replies: 3
    Last Post: 29th August 2007, 11:00 AM
  5. Script to delete printer
    By tosca925 in forum Scripts
    Replies: 2
    Last Post: 31st August 2005, 07:45 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •