+ Post New Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 35
Windows Thread, Home folder shows as "Documents" instead of folder name in Technical; Home folder shows as "Documents" instead of folder name. This is a problem I recently noticed when I added Vista ...
  1. #1
    chazzy2501's Avatar
    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,781
    Thank Post
    213
    Thanked 263 Times in 213 Posts
    Rep Power
    67

    Home folder shows as "Documents" instead of folder name

    Home folder shows as "Documents" instead of folder name. This is a problem I recently noticed when I added Vista clients to my domain. Each pupil has a home folder mapped via active directory the a share folder on the file server.

    Example
    Code:
    \\server\09$\%username%
    What I'm noticing is that when I visit this share, instead of seeing a list of usernames all the folders have a special icon and their displayed as "Documents". This makes it hard for me to work with them.

    I thought this problem was limited to my 64bit Vista workstation but now my XP machines are doing the same.

    How do I turn this off?

    cheers

  2. #2
    TheLibrarian
    Guest
    This could be caused by the hidden file in each user directory called desktop.ini.

    Find one, kill it and then look at the direcory name again.

  3. 2 Thanks to TheLibrarian:

    chazzy2501 (14th January 2010), projector1 (25th June 2012)

  4. #3

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340
    I believe this is a 'feature' of Windows Vista. Not sure if there's a fix or not, but it is really annoying.

  5. #4
    chazzy2501's Avatar
    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,781
    Thank Post
    213
    Thanked 263 Times in 213 Posts
    Rep Power
    67
    Thanks, I'd never looked at that file, I noticed that all users have the desktop.ini file. Although all the desktop.ini files have an entry for "PersonalizedName=My Documents". The ini files with the additional [.ShellClassInfo] are the ones that louse up.

    Do you forsee any problems deleting this file?

  6. #5
    TheLibrarian
    Guest
    We don't have any Vista clients, I can say that none of the XP Pro clients have ever had a problem with missing Desktop.ini files that I have deleted.

  7. Thanks to TheLibrarian from:

    chazzy2501 (14th January 2010)

  8. #6

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,076
    Thank Post
    853
    Thanked 2,676 Times in 2,270 Posts
    Blog Entries
    9
    Rep Power
    769
    Quote Originally Posted by chazzy2501 View Post
    Thanks, I'd never looked at that file, I noticed that all users have the desktop.ini file. Although all the desktop.ini files have an entry for "PersonalizedName=My Documents". The ini files with the additional [.ShellClassInfo] are the ones that louse up.

    Do you forsee any problems deleting this file?
    No but it will just recreate it on the next user logon so it is a short term solution, I edited the custom names to be the same as the folder names but that was on a small site with a handful of users.

  9. Thanks to SYNACK from:

    chazzy2501 (14th January 2010)

  10. #7
    chazzy2501's Avatar
    Join Date
    Jan 2008
    Location
    South West
    Posts
    1,781
    Thank Post
    213
    Thanked 263 Times in 213 Posts
    Rep Power
    67
    Is there a way of getting my workstation to ignore the ini file?

  11. #8

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,076
    Thank Post
    853
    Thanked 2,676 Times in 2,270 Posts
    Blog Entries
    9
    Rep Power
    769
    Quote Originally Posted by chazzy2501 View Post
    Is there a way of getting my workstation to ignore the ini file?
    There are three ways I have thought of combating this problem, the MS solution which is rubbish is denying permission to the whole folder so that the ini is not accessed or nest the docs folder in another one.

    My solution ideas are:
    1. script setact to go through and deny your user account read permission to the desktop.ini in each user docs folder (can do manualy if there are only a few users)
    2. script a rewrite of all of the desktop.inis to change their custom names to the folder names
    3. this one I have not tried yet as I am not near a server but it is the most elegant: Use a machine GPO on the docs server to set the deny read ACL on all desktop.ini files one folder deep in the documents share.

  12. #9
    maark's Avatar
    Join Date
    Feb 2006
    Location
    leicester
    Posts
    470
    Thank Post
    90
    Thanked 73 Times in 65 Posts
    Rep Power
    38
    sorry to resurrect old thread - but searching on google led me to edugeek :-)
    noticed this problem with loads of documents folders appearing alongside home folders after introducing windows 7 machines on network.
    my current redirection settings are "advanced - specify settings for various user groups" - then have students security group set to "redirect to the users home directory" which worked fine on xp.
    Have found this on microsoft When you redirect the Documents folder on a Windows Vista-based or Windows 7-based computer to a network share, the folder name unexpectedly changes back to Documents
    but still not sure what best settings to put into group policy and also whether I need to modify the desktop.ini files.
    Can anyone help,
    cheers Mark

  13. #10
    kennysarmy's Avatar
    Join Date
    Oct 2005
    Location
    UK
    Posts
    1,286
    Thank Post
    80
    Thanked 45 Times in 31 Posts
    Rep Power
    30
    Having the same issue here.....

  14. #11

    Join Date
    Mar 2011
    Location
    Bournemouth
    Posts
    280
    Thank Post
    16
    Thanked 74 Times in 64 Posts
    Rep Power
    21
    This is the reason recommended practice and the default for folder redirection is for my documents to be redirected to a Documents folder inside the user's folder rather than the user folder directly. This will prevent the issue.

  15. #12

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,343
    Thank Post
    624
    Thanked 1,584 Times in 1,421 Posts
    Rep Power
    414
    If thats best practice why is there a gpo setting that is redirect to users home folder?

    Ben

  16. #13

    Join Date
    Mar 2011
    Location
    Bournemouth
    Posts
    280
    Thank Post
    16
    Thanked 74 Times in 64 Posts
    Rep Power
    21
    The redirect to users home folder setting causes the pictures/music/videos etc folders to be redirected to folder inside where the document folder is (ie the way XP did it) instead of them all being in seperate folders (like vista and windows 7 do it). This has absolutely no affect on how vista and windows 7 display the user's profile folder. The folder's listed in the user's profile folders are simply links to the redirected folder.

    It is still recommended to redirect to a folder inside the user's server folder to prevent the desktop.ini file from preventing you seeing the true folder names.

  17. #14
    kennysarmy's Avatar
    Join Date
    Oct 2005
    Location
    UK
    Posts
    1,286
    Thank Post
    80
    Thanked 45 Times in 31 Posts
    Rep Power
    30
    Well I've used File Server Resource Manager on the pupils server to stop it.
    That's not on the staff server so will either have to install it or run a batch script to delete if it becomes a problem.

    I agree with Plexer : if MS have a GPO setting you would think that would handle it correctly and create the "documents" folder under the users local drive automatically.....most users expect to save their work in the root of their H:\ drive though and not have to dig a level down....

  18. #15

    Join Date
    Mar 2009
    Location
    Rochdale
    Posts
    45
    Thank Post
    0
    Thanked 7 Times in 7 Posts
    Rep Power
    12
    Found a couple of simple ways to resolve this.

    One, create a new folder within the root and call it shortcuts, then highlight all folders in the folder where the home drive folders are kept and select all, then right click and send to desktop (you need to do this from the share as the teachers would see it, not C$ etc), then copy the newly created shortcuts into the inital folder (we called it student home drives) and hid all the other folders, now when staff go in they see the shortcuts to the student home drives and not the home drives, these do not contain the desktop.ini file and dont change.

    The way we resolved it after this ongoing was to use file resource manager to block desktop.ini files from being saved, then did a simple search per year and removed the files, they arent especially needed as they only save the configuration for viewing folders etc, we have specified a default layout by editing the hive file for the student default userprofiles and this works fine.

    This has worked fine ever since.

  19. Thanks to wardsidjame from:

    pdr (5th March 2012)

SHARE:
+ Post New Thread
Page 1 of 3 123 LastLast

Similar Threads

  1. Replies: 4
    Last Post: 18th November 2011, 03:36 PM
  2. Remove Access to "User Folder"
    By burgemaster in forum Windows Vista
    Replies: 1
    Last Post: 11th April 2009, 08:53 PM
  3. Replies: 5
    Last Post: 5th February 2009, 01:14 PM
  4. Windows XP-SP3 and "Folder redirection"
    By Polski in forum Windows
    Replies: 5
    Last Post: 30th May 2008, 05:07 PM
  5. Home Folder "Access Denied" Message
    By speckled in forum Wireless Networks
    Replies: 9
    Last Post: 23rd January 2008, 10:58 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •