+ Post New Thread
Results 1 to 1 of 1
Windows Thread, Problem: When using a static IP on an external connection, I have to /registerdns in Technical; Hey everyone, I hope your start to the school year has been good so far! I have a question for ...
  1. #1
    link470's Avatar
    Join Date
    Nov 2007
    Location
    Canada
    Posts
    250
    Thank Post
    85
    Thanked 8 Times in 6 Posts
    Rep Power
    15

    Exclamation Problem: When using a static IP on an external connection, I have to /registerdns

    Hey everyone, I hope your start to the school year has been good so far!

    I have a question for you guys that I've been trying to solve for awhile. Some of you may remember this post I made awhile back. I had a server at the district [still do] that's on our network, but, uses an external address of it's own. I needed a separate domain name pointed to that system for a different organization within our school but it had to be on that server and not our main web server. So what I ended up doing was having the first NIC on the internal network so I could still manage the system RDC style through the local network and also connect it to our domain etc. Then the second NIC had an external IP address I set manually from within our Class C range we get from our ISP. That connection there is the one that never wants to stay alive and accepting connections. The fix? I found that by right clicking on the external network connection and choosing repair, it fixed the issue and external clients were able to connect to the server again. That kept the server up and running for another 5, 10, 15, 20, 25, 30 etc. hours, whatever it felt like that day. But what exactly during the repair process fixed it? I looked up the exact commands "Repair" performed, and tried them individually and testing after each command, and found that ipconfig /registerdns was the command that fixed the connection. For the last year or so that server at the district has been kept alive by running ipconfig /registerdns as a scheduled task once every 15 minutes. Yes, it works, yes, it's a band aid fix and I don't like those.

    So now I have my ISA server here on my home network as I was talking about doing here. Finally getting some time to configure it, and I've got 2 IP addresses coming from my ISP. One going to my main home network, the other, hopefully going to an external interface on the ISA server. The ISA server works great so far in testing. It's sitting just standalone at the moment. To get the two IP's from the ISP both at once what I do is have the ISP's modem connected to a switch instead of my home router, then one cable from the switch goes to my home router, one cable from the switch goes to the ISA server external interface, and voila, two networks. The problem is that ISA server ALSO fails to accept connections unless I run ipconfig /registerdns. I've checked the connection properties, the connection is set to register itself with DNS, the DNS servers are the two DNS servers at my ISP, and the external address is one that I've been using for ages and decided to just set it as a static so I could hold onto it [I know there isn't a reservation at the ISP level for me but I figured I'd just take the address :P]. I didn't think it would be an issue though because the Class C subnet we have at the district is ours and only ours so we can create whatever we want within that range and I'm still having problems with THAT external connection.

    The situations are slightly different but the problem is identical, with an identical band aid solution. How can I properly run these systems without having to do ipconfig /registerdns? I've been searching google for around 8 hours now that I know the issue and what's happening, but I can't find a solution. The odd time though I'll find someone who has to do the same thing on google, type ipconfig /registerdns, but they haven't found a solution either. So I came to the best resource I know of. You guys. This only seems to happen when using a static IP it looks like.

    Thanks a ton!
    Last edited by link470; 7th October 2009 at 05:29 AM.

SHARE:
+ Post New Thread

Similar Threads

  1. Problem with MSTSC Connection and Zip Drive
    By DAckroyd in forum Thin Client and Virtual Machines
    Replies: 1
    Last Post: 4th March 2009, 04:36 PM
  2. Connection problem
    By Hightower in forum Windows
    Replies: 9
    Last Post: 2nd February 2009, 03:02 PM
  3. Problem with static site when using IE6
    By kearton in forum EduGeek Joomla 1.0 Package
    Replies: 1
    Last Post: 12th June 2008, 06:57 PM
  4. Remote Desktop Connection Problem
    By FN-GM in forum *nix
    Replies: 15
    Last Post: 21st October 2007, 03:11 PM
  5. Strange network connection problem
    By trekmad in forum Wireless Networks
    Replies: 7
    Last Post: 5th October 2007, 08:04 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •