+ Post New Thread
Results 1 to 5 of 5
Windows Thread, Deploying Adobe Creative suite 3 on CC3 in Technical; Hi All, Just wanted to pick everyone's brains regarding this. We want to deply adobe CS3 to our cC3 network ...
  1. #1

    Join Date
    Jan 2009
    Location
    Northampton
    Posts
    145
    Thank Post
    14
    Thanked 11 Times in 11 Posts
    Rep Power
    11

    Deploying Adobe Creative suite 3 on CC3

    Hi All,

    Just wanted to pick everyone's brains regarding this.

    We want to deply adobe CS3 to our cC3 network via the RM Management console. We have not purchased the RM Curriculum Choice package but the version we have does have an MSI package on the disc.

    Before I get started with deploying this I just wanted to hear from anyone else who has done the same and/or knows whether its possible to do or any problems I might face.

    When installing manually we use setup.exe on the disc however there is an MSI package called WinBootstrapper.msi which I assume would be used to deploy it on the network. We are running CC3 with Windows Server 2003.

    Thanks for any help!

  2. #2

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,724
    Thank Post
    696
    Thanked 1,206 Times in 759 Posts
    Rep Power
    393
    Adobe Creative Suite products are notoriously difficult to deploy. The setup.exe calls dozens of different MSIs, generally one or more for each product, with a lot of custom arguments passed. The WinBootStrapper.msi does not do the full job IIRC. I'm by no means an expert with the RM Application Wizard, but I suspect you'll need to make a deployment XML file using Adobe' instructions and call that somehow.

  3. #3


    Join Date
    Feb 2007
    Location
    51.405546, -0.510212
    Posts
    8,125
    Thank Post
    203
    Thanked 2,390 Times in 1,770 Posts
    Rep Power
    704
    As AngryTechnician mentioned above, the Adobe PDF should list everything you need to do to get it working. However, be careful when copying-and-pasting stuff from it since Adobe uses different double-quotes which won't work unless replaced with standard double-quotes (the sort you get in Notepad).

    The files shown below are the ones we use to get the Design Premium edition working on our CC3 network. You will need to create them in the locations listed at the bottom of this post (and amend where necessary) once you have copied the entire contents of the CS3 DVD to a folder on the Q:\ drive e.g. "\\YourServerName\RMPackages\Applications\Adob e Creative Suite 3 Design Premium\v1.0.0.0".

    Hopefully this all makes sense.

    Adobe Creative Suite 3 Design Premium.ini
    Code:
    [Package]
    Description=Adobe Creative Suite 3 Design Premium
    Version=1.0.0.0
    OS=5.WS
    ExeFile=setup.exe
    Addcommand= --mode=Silent --skipProcessCheck=1 --deploymentFile="\\YourServerName\RMPackages\Applications\Adobe Creative Suite 3 Design Premium\v1.0.0.0\deployment\install.xml"
    UninstallCommand= --mode=Silent --skipProcessCheck=1 --deploymentFile="\\YourServerName\RMPackages\Applications\Adobe Creative Suite 3 Design Premium\v1.0.0.0\deployment\uninstall.xml"
    InstallGroup=Early
    application.xml.override
    Code:
    <?xml version="1.0" encoding="utf-8"?>
    <Configuration>
    <Payload>
    <Data key="Serial" protected="0">123456789012345678901234</Data>
    <Data key="Registration">Suppress</Data>
    <Data key="EULADelay">-1</Data>
    <Data key="EULA">Suppress</Data>
    <Data key="Updates">Suppress</Data>
    </Payload>
    </Configuration>
    install.xml
    Code:
    <?xml version="1.0" encoding="UTF-8"?><Deployment>
    <Properties>
       <Property name="installLanguage">en_US</Property>
       <Property name="installSourcePath">Q:\Applications\Adobe Creative Suite 3 Design Premium\v1.0.0.0\</Property>
    </Properties>
    
    <Payloads>
       <!--Adobe Acrobat 8 Professional (At install, older versions get upgraded)-->
       <Payload adobeCode="{AC76BA86-1033-0000-7760-000000000003}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe Creative Suite 3 Design Premium-->
       <Payload adobeCode="{7005ECBC-F54B-42FD-81E4-934BC43FA329}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe Dreamweaver CS3-->
       <Payload adobeCode="{00E5C764-9525-44C3-8404-712AD06AE12A}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe Flash CS3-->
       <Payload adobeCode="{3BC8460B-085E-47F3-9C62-8FFCBAF11D78}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe Flash Video Encoder-->
       <Payload adobeCode="{7BB7F66A-D798-45A3-A383-0727FB1EBF8E}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe Illustrator CS3-->
       <Payload adobeCode="{C4519961-AC64-4565-B3AF-9050296B5D5A}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe InDesign CS3-->
       <Payload adobeCode="{24D77A7C-E10B-4057-9974-FAB8BFDAC853}">
          <Action>install</Action>
       </Payload>
    
       <!--Adobe Photoshop CS3-->
       <Payload adobeCode="{30C4B843-28DA-466F-AFCA-CB0ED153C826}">
          <Action>install</Action>
       </Payload>
    </Payloads>
    </Deployment>
    uninstall.xml
    Code:
    <?xml version="1.0" encoding="UTF-8"?><Deployment>
    <Properties>
       <Property name="installLanguage">en_US</Property>
    </Properties>
    
    <Payloads>
       <!--Adobe Acrobat 8 Professional (At install, older versions get upgraded)-->
       <Payload adobeCode="{AC76BA86-1033-0000-7760-000000000003}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe Creative Suite 3 Design Premium-->
       <Payload adobeCode="{7005ECBC-F54B-42FD-81E4-934BC43FA329}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe Dreamweaver CS3-->
       <Payload adobeCode="{00E5C764-9525-44C3-8404-712AD06AE12A}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe Flash CS3-->
       <Payload adobeCode="{3BC8460B-085E-47F3-9C62-8FFCBAF11D78}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe Flash Video Encoder-->
       <Payload adobeCode="{7BB7F66A-D798-45A3-A383-0727FB1EBF8E}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe Illustrator CS3-->
       <Payload adobeCode="{C4519961-AC64-4565-B3AF-9050296B5D5A}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe InDesign CS3-->
       <Payload adobeCode="{24D77A7C-E10B-4057-9974-FAB8BFDAC853}">
          <Action>remove</Action>
       </Payload>
    
       <!--Adobe Photoshop CS3-->
       <Payload adobeCode="{30C4B843-28DA-466F-AFCA-CB0ED153C826}">
          <Action>remove</Action>
       </Payload>
    </Payloads>
    </Deployment>
    File Locations

    Root Folder
    \\YourServerName\RMPackages\Applications\Adobe Creative Suite 3 Design Premium\v1.0.0.0
    Adobe Creative Suite 3 Design Premium.ini
    \Deployment
    install.xml
    uninstall.xml
    \Payloads\AdobeDesignSuitePremiumen_US_Volume
    application.xml.override
    \Shortcuts\Adobe Creative Suite 3 Design Premium
    Copy and paste the shortcuts from the start menu into this folder
    Last edited by Arthur; 18th August 2009 at 06:40 PM.

  4. Thanks to Arthur from:

    AngryTechnician (18th August 2009)

  5. #4

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,151
    Thank Post
    369
    Thanked 365 Times in 323 Posts
    Rep Power
    145
    Very good post from Arthur but if that doesn't work I would seriously consider the curriculum choice package as for whatever its costs its going to obviously save you that money in man hours for how ever long it takes to tweak.

  6. #5

    Join Date
    Feb 2010
    Posts
    6
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    If you go on the RM Community forum, some school bought the CC3 Curriculum Choice for CS3/4 and it still doesn't work. Still the same old prolem when allocate it to the network. Nothing will run except admin rights.

SHARE:
+ Post New Thread

Similar Threads

  1. Adobe Creative Suite 3
    By Norphy in forum Windows
    Replies: 24
    Last Post: 1st April 2013, 08:28 PM
  2. How do I sysprep and image Adobe Creative Suite 3?
    By link470 in forum O/S Deployment
    Replies: 5
    Last Post: 25th June 2009, 01:01 AM
  3. Adobe Creative suite + costs
    By Dos_Box in forum Educational Software
    Replies: 9
    Last Post: 11th May 2009, 06:19 PM
  4. Adobe Creative Suite 3 - Deployment
    By EduTech in forum Educational Software
    Replies: 9
    Last Post: 13th March 2009, 10:57 AM
  5. Adobe Creative Suite 3 Web Standard
    By marvin in forum Windows
    Replies: 5
    Last Post: 10th April 2008, 11:39 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •