+ Post New Thread
Results 1 to 13 of 13
Windows Thread, office 2007 user problem in Technical; hi guys i have a problem with office 2007 with users, after a reboot when a user logins office 2007 ...
  1. #1
    ful56_uk's Avatar
    Join Date
    Mar 2008
    Location
    Essex
    Posts
    534
    Thank Post
    104
    Thanked 23 Times in 21 Posts
    Rep Power
    17

    office 2007 user problem

    hi guys

    i have a problem with office 2007 with users, after a reboot when a user logins office 2007 always wants to run the windows installer to configure office. all users use man profiles, and i have done this in the man profile, i have open all the office programs then renamed the the ntuser to .man.

    when the user logs off and logs in its fine but a reboot losses that config and windows installer starts up again.

    what am i missing here? as i need to stop this from happening.


    mark

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,390
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    Did you use an old profile that was configured for Office 2003?

  3. Thanks to FN-GM from:

    ful56_uk (11th August 2009)

  4. #3
    ful56_uk's Avatar
    Join Date
    Mar 2008
    Location
    Essex
    Posts
    534
    Thank Post
    104
    Thanked 23 Times in 21 Posts
    Rep Power
    17
    Nope brand new profiles. Could be a permission on the local workstation? What does and were does the installer access were in the workstations do windows installer access that they might need full control. Or a user.

  5. #4

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,390
    Thank Post
    797
    Thanked 1,588 Times in 1,391 Posts
    Blog Entries
    10
    Rep Power
    427
    Im not sure, i haven't seen this before. Someone on here had this problem when he deployed office as an MSI and also upgrading from older versions of office compared to a clean install.

  6. Thanks to FN-GM from:

    ful56_uk (11th August 2009)

  7. #5
    ful56_uk's Avatar
    Join Date
    Mar 2008
    Location
    Essex
    Posts
    534
    Thank Post
    104
    Thanked 23 Times in 21 Posts
    Rep Power
    17
    A full install using gpo install. In general thow is there a part of the system were users need access in order for the windows installer to config a program

  8. #6
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    33
    Windows Installer will write to user portion of registry (HKEY_CURRENT_USER) and to files in AppData and Local App Data.

    Depending on how the mandatory profiles were created, writing to the user portion of the registry can go wrong. Occasionally people try to copy a profile by dragging/dropping and then changing file permissions on the profile folder so that any user can use. This will not work properly. Profiles MUST be copied using the 'copy profile' function in the System dialog box or registry permissions will be incorrect.

    Having said all that, I don't think that incorrect registry permissions would explain the problem you describe. If the Installer settings survive a logout but not a reboot, then something else must be going on. Perhaps a startup script deleting cached copies of roaming/mandatory profiles?

  9. Thanks to ajbritton from:

    ful56_uk (11th August 2009)

  10. #7

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    I suspect it's a combination of problems. Are you 100% sure the roaming profile is definitely being picked up and not a new locally cached profile? As an experiment, try re-naming the roaming profile with a "1" on the end to make it unique, then change the path accordingly in AD.

    If you've created a share called Profiles$ users should have Full Control to this share, otherwise it can create all kinds of weird and wonderful problems writing back to the profile.

  11. Thanks to Michael from:

    ful56_uk (11th August 2009)

  12. #8
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    33
    Quote Originally Posted by Michael
    If you've created a share called Profiles$ users should have Full Control to this share, otherwise it can create all kinds of weird and wonderful problems writing back to the profile.
    He's using mandatory profiles that aren't supposed to be written back to the server. Read/List is all that is required.

  13. Thanks to ajbritton from:

    ful56_uk (11th August 2009)

  14. #9

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    He's using mandatory profiles that aren't supposed to be written back to the server.
    Generally in my experience I setup one Profiles$ share for all whether it's for mandatory profiles or not. For example you wouldn't setup a domain administrator with a mandatory profile!

  15. Thanks to Michael from:

    ful56_uk (11th August 2009)

  16. #10
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    33
    Quote Originally Posted by Michael View Post
    Generally in my experience I setup one Profiles$ share for all whether it's for mandatory profiles or not. For example you wouldn't setup a domain administrator with a mandatory profile!
    I wouldn't set one up with a roaming profile either BTW. I take your point however.

    Your original post referred to 'writing back to the profile' which seemed to me not relevant in this case as mandatory profiles are in use and the permissions to these would surely be limited to list/read.

  17. Thanks to ajbritton from:

    ful56_uk (11th August 2009)

  18. #11
    ful56_uk's Avatar
    Join Date
    Mar 2008
    Location
    Essex
    Posts
    534
    Thank Post
    104
    Thanked 23 Times in 21 Posts
    Rep Power
    17
    all sorted, security permission on the profile folder, now working prefectly

    cheers guys for the input

  19. #12

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    8,941
    Thank Post
    232
    Thanked 1,510 Times in 1,206 Posts
    Rep Power
    328
    I wouldn't set one up with a roaming profile either BTW. I take your point however.
    Normally administrator accounts I use on servers I use a local profile only, however for a secondary administrator account I use for workstations I do specify a roaming profile path.

  20. #13
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    33
    Quote Originally Posted by ful56_uk View Post
    all sorted, security permission on the profile folder, now working prefectly

    cheers guys for the input
    Can you tell us what you had to change them to?

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 4
    Last Post: 14th August 2009, 01:58 AM
  2. [MS Office - 2007] Running MS Office 2003 and MS Office 2007 on the same network.
    By Richard_Finnigan in forum Office Software
    Replies: 2
    Last Post: 19th June 2009, 11:28 AM
  3. Office 2007 at home, Office 2003 at school
    By kennysarmy in forum Windows
    Replies: 25
    Last Post: 13th January 2009, 01:31 PM
  4. Replies: 1
    Last Post: 22nd May 2008, 11:36 AM
  5. Office 2007 Startup Problem
    By sqdge in forum Windows
    Replies: 7
    Last Post: 15th October 2007, 01:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •