+ Post New Thread
Results 1 to 6 of 6
Windows Thread, Wus Server Not updateing clients in Technical; HI I have a WUS server running Windows Server 2008. I am trying to apply a gpo to all clients ...
  1. #1

    Join Date
    Jul 2009
    Location
    Sutton Coldfield
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Wus Server Not updateing clients

    HI

    I have a WUS server running Windows Server 2008. I am trying to apply a gpo to all clients to automatically update from the server. The gpo is on a windows 2003 platform. I have been able to get the clients to download the updates and notify the user to install updates. When I chose the option "4 auto download and install at scheduled time" they do nothing. The client does not even download the updates or register on the WUS server.

    The gpo I have applied at the moment had the following enabled and set up - configure automatic updates, specify intranet Microsoft update service location, automatic updates detection frequency, allow non-administrators to receive update notifications.

    Any Ideas?

    Dean

  2. #2

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,297
    Thank Post
    242
    Thanked 1,586 Times in 1,263 Posts
    Rep Power
    344
    It sounds to me this is possibly a new setup? Are all the update files downloaded? When you load the WSUS 3.0 console it displays on the startup screen whether any updates are required under 'Download Status'.

    This is what settings I use to setup WSUS

  3. #3
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,476
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52
    Hi

    Have you also tried the

    proxycfg -u

    on the machines to update the windows update proxy. I have to apply this with a script at start up.

    Also have a look at Microsoft Windows Server Update Services Tools and Utilities and try the server and client diagnostic tools,


    Richard

  4. #4

    Join Date
    Jul 2009
    Location
    Sutton Coldfield
    Posts
    2
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi

    I have tried both with no luck. The Updates are downloaded and have been approved on the WUS server. Does anyone know of any gpo that may block automatic updates?

    Any other ideas would be great.

    Thanks

    Dean

  5. #5

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,297
    Thank Post
    242
    Thanked 1,586 Times in 1,263 Posts
    Rep Power
    344
    Paste this into Notepad and save as WSUSReset.bat:

    Code:
    @echo off
    TITLE Logistix WSUS Reset Authorisation
    Echo This batch file will do the following:
    Echo 1. Stops the wuauserv service
    Echo 2. Deletes the AccountDomainSid registry key (if it exists)
    Echo 3. Deletes the PingID registry key (if it exists)
    Echo 4. Deletes the SusClientId registry key (if it exists)
    Echo 5. Restarts the wuauserv service
    Echo 6. Resets the Authorization Cookie
    Echo 6. More information on http://msmvps.com/Athif
    Pause
    @echo on
    net stop wuauserv
    REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
    REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
    REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f
    net start wuauserv
    wuauclt /resetauthorization /detectnow
    Pause
    Reboot the machine and see if this makes any difference. You're not by chance running an RM network are you as the workstations are deliberately modified so it won't talk to a WSUS server by default. It deletes some vital registry entries.

  6. #6
    denon101's Avatar
    Join Date
    Jul 2008
    Location
    Stuck in the server room......
    Posts
    401
    Thank Post
    54
    Thanked 37 Times in 35 Posts
    Rep Power
    21
    Are you sending out office 2003 sp3 updates??

    I had a problem with WSUS 3.0 when I approved sp3. Nothing would download at all. I trawled google and found that if you approve sp1 then decline the update everything starts to work. I did that and then manually did wuauclt /detectnow and all the updates started working like magic.

    Turns out that microsoft did something to sp1 and it messed with the updates.

    You could try that



SHARE:
+ Post New Thread

Similar Threads

  1. clients can't find new exchnage server
    By goodhead in forum Office Software
    Replies: 6
    Last Post: 5th March 2009, 01:30 PM
  2. Replies: 5
    Last Post: 3rd November 2008, 03:11 PM
  3. Linux Server & XP Clients
    By rjsmith in forum *nix
    Replies: 3
    Last Post: 9th November 2007, 11:10 AM
  4. Replies: 14
    Last Post: 12th May 2006, 10:48 AM
  5. wus servers our lea have seen the light
    By russdev in forum Windows
    Replies: 11
    Last Post: 13th November 2005, 04:43 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •