+ Post New Thread
Results 1 to 13 of 13
Windows Thread, Small RIS issues in Technical; I have been using RIS for some months now and have just recently managed to achieve an image that works ...
  1. #1
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    42
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Small RIS issues

    I have been using RIS for some months now and have just recently managed to achieve an image that works for all of my PCs thanks to RougeSpear's AutoImage. I do still have a couple of minor problems and i was wondering if anyone could help me out.

    1. During the windows part of the install (installing devices) I get a message that tells me the install couldn't rename the local administrators account. If I click ok it carries on This message is the standard windows "ERROR" message the one with the white X on a red circle

    Code:
    Setup was unable to change the password for the user account Administrator. Please enter the desired password again.


    2. I want the default language to be UK English, I thought this was possible through the .sif file I have followed examples on other sites but I still end up with English US :x

    3. I want the monitor to turn off after 1 hour can i do this with a policy or can I do it during the RIS setup?

    I include my sif file just incase someone notices a real blooper

    Code:
    ;SetupMgrTag
    [Branding]
        BrandIEUsingUnattended=Yes
    
    [Components]
        AccessOpt=Off
        chat=off
        deskpaper=off
        freecell=off
        hearts=off
        hyperterm=off
        media_clips=off
        media_utopia=off
        minesweeper=off
        msnexplr=off
        msmsgs=off
        OEAccess=off
        pinball=off
        solitaire=off
        spider=off
        templates=off
        WMAccess=off
        WMPOCM=off
        zonegames=off
    
    [Data]
        AutoPartition=1
        DisableAdminAccountOnDomainJoin=0
        floppyless="1"
        LocalSourceOnCD=1
        MsDosInitiated="1"
        OriSrc="\\%SERVERNAME%\RemInst\%INSTALLPATH%"
        OriTyp="4"
        UnattendedInstall="Yes"
    
    [Display]
        BitsPerPel = 32
        XResolution = 1280
        YResolution = 1024
        
    [FavoritesEx]
    
    [GuiUnattended]
        AdminPassword=xxxxxxx
        DetachedProgram=
        EncryptedAdminPassword=Yes
        OEMSkipRegional=1
        OemSkipWelcome=1
        TimeZone=85
    
    [Identification]
        DoOldStyleDomainJoin=Yes
        JoinDomain=school-domain
    
    [Networking]
        InstallDefaultComponents=Yes
        ProcessPageSections=Yes
    
    [OSChooser]
        Description="WinXP SP2 - school custom sif file"
        Help="This will install Windows XP SP2."
        ImageType=Flat
        LaunchFile="%INSTALLPATH%\%MACHINETYPE%\templates\startrom.com"
    
    [RemoteInstall]
        Repartition=Yes
        UseWholeDisk=Yes
    
    [SetupData]
        OsLoadOptions="/noguiboot /fastdetect"
        SetupSourceDevice="\Device\LanmanRedirector\%SERVERNAME%\RemInst\%INSTALLPATH%"
    
    [Shell]
        CustomDefaultThemeFile="%WINDIR%\Resources\Themes\royale.theme"
    
    [TapiLocation]
        AreaCode=44
        CountryCode=01752
        Dialing=Tone
        LongDistanceAccess="9"
    
    [RegionalSettings]
       LanguageGroup=1
       Language=00000809
    
    [TerminalServices]
        AllowConnections=1
    
    [Unattended]
        AutoActivate=No
        CrashDumpSetting=0
        DriverSigningPolicy=Ignore
        FileSystem=LeaveAlone
        Hibernation=No
        NonDriverSigningPolicy=Ignore
        NtUpgrade=No
        OemSkipEula=Yes
        OemPnPDriversPath=
        OemPreinstall=Yes
        OverwriteOemFilesOnUpgrade=No
        TargetPath=\WINDOWS
        UnattendMode=FullUnattended
        WaitForReboot=No
    
    [UserData]
        ProductID=xxxxxxxxxxxxxxxxxxxx
        FullName = "xxxxxxxxxxxxxxx"
        OrgName = "xxxxxxxxxxxxxx"
        ComputerName ="%MACHINENAME%"
    
    [URL]
        Home_Page=www.school.lea.sch.uk
        Search_Page=www.google.co.uk
    
    [Proxy]
        Proxy_Enable=1
        Use_Same_Proxy=1
        HTTP_Proxy_Server=xxx.xxx.xxx.xxx:xxxx
        Proxy_Override=<local>
    
    
    [WindowsFirewall]
        Profiles = WindowsFirewall.TurnOffFirewall
    
    [WindowsFirewall.TurnOffFirewall]
        Mode = 0

  2. #2
    ChrisH's Avatar
    Join Date
    Jun 2005
    Location
    East Lancs
    Posts
    4,988
    Thank Post
    120
    Thanked 283 Times in 261 Posts
    Rep Power
    107

    Re: Small RIS issues

    for number 3 you can use this I think http://www.terranovum.com/projects/e...ar/ez_gpo.html

  3. #3
    eejit's Avatar
    Join Date
    Jun 2005
    Location
    Ireland
    Posts
    606
    Thank Post
    52
    Thanked 12 Times in 12 Posts
    Rep Power
    22

    Re: Small RIS issues

    Is the Admin password really only that long? If so, it's not encrpted so you should turn that option to "no"

  4. #4

    Join Date
    Mar 2006
    Posts
    537
    Thank Post
    2
    Thanked 3 Times in 2 Posts
    Rep Power
    19

    Re: Small RIS issues

    @edie209

    Did you use Setup Manager to enter the local administrator password?
    You can't enter the password directly in the .sif if you have the encrypt option enabled.

    As for the options have a look at the Ref.chm (or is it deploy.chm) in deploy.cab in C:\Support\Tools on The Windows XP CD.

  5. #5
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    42
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: Small RIS issues

    ChrisH
    That could be the perfect answer I will try that thanks

    eejit
    I will try that I really hope its something that simple ops:

    ITWombat
    I didn't use setup manager so that looks like it my problem there
    As for the options have a look at the Ref.chm (or is it deploy.chm) in deploy.cab in C:\Support\Tools on The Windows XP CD
    I've looked into this and got this
    Code:
    [RegionalSettings]
        LanguageGroup=1
        SystemLocale=00000809
        UserLocale=00000809
        InputLocale=0809:00000809
    so I will try this

  6. #6
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    42
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: Small RIS issues

    Error one still happens I edited the sif file and rerun the RIS install but I got the same error...... Would I have to stop and restart BINL if I edit the sif file?

  7. #7

    Join Date
    Oct 2005
    Location
    East Midlands
    Posts
    740
    Thank Post
    17
    Thanked 106 Times in 66 Posts
    Rep Power
    37

    Re: Small RIS issues

    Hi,

    Yes you need to restart the BINL servcies if you make changes to the sif file. Also i think you would need to reassociate the file as well, but not too sure about this.

    Ashok.

  8. #8
    ChrisH's Avatar
    Join Date
    Jun 2005
    Location
    East Lancs
    Posts
    4,988
    Thank Post
    120
    Thanked 283 Times in 261 Posts
    Rep Power
    107

    Re: Small RIS issues

    Just restarting BINL should do it.

  9. #9
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    42
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: Small RIS issues

    Ok I will try that..... sort of got ahead of myself though and I'm just rebuilding the image too, shoul know in a couple of hours

  10. #10
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    42
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: Small RIS issues

    That seems to have worked although I was up till 4 this morning playing around with the install. The only thing that is not as i want it is the Location under Regionaland Language options it still is US

  11. #11
    tarquel's Avatar
    Join Date
    Jun 2005
    Location
    Powys, Mid-Wales, UK
    Posts
    1,740
    Thank Post
    13
    Thanked 45 Times in 35 Posts
    Rep Power
    29

    Re: Small RIS issues

    You didnt read my MSFN posting then? :P

    BTW If you are using nlite in the process, strip out all the languages & keyboards etc you dont need... might help the regional problem, plus make the build considerably smaller

    Nath.

  12. #12
    edie209's Avatar
    Join Date
    Mar 2006
    Location
    Kernow
    Posts
    671
    Thank Post
    42
    Thanked 17 Times in 16 Posts
    Rep Power
    22

    Re: Small RIS issues

    No but thanks anyway, wierd we seem to have most answers right here among ourselves, but then I guess it figures because we are always in the firing line

    Edit

    I forgot to mention Nlite I have been playing with it but while I was having problems with AutoImage I went down to the basics and then built back up, I am happy (to a point ) with some of the scripts, need to play more though, the driver packs work for me, and the installers so far have worked. Nlite will be the next one, it just takes so much time though :x

    Once again thanks for your reply over at msfn

  13. #13
    tarquel's Avatar
    Join Date
    Jun 2005
    Location
    Powys, Mid-Wales, UK
    Posts
    1,740
    Thank Post
    13
    Thanked 45 Times in 35 Posts
    Rep Power
    29

    Re: Small RIS issues

    yep yep lol

    Code:
    [RegionalSettings]
        LanguageGroup=1
        SystemLocale=00000809
        UserLocale=00000809
        InputLocale=0809:00000809
    always gave me the location as US but i couldnt find how to change that, so I reverted back to:

    Code:
    [RegionalSettings]
        LanguageGroup=1
        Language=00000809
    I think [he wrote without even looking].


    Nath.

SHARE:
+ Post New Thread

Similar Threads

  1. Small Form factor PC's
    By tosca925 in forum Hardware
    Replies: 14
    Last Post: 15th June 2007, 11:35 AM
  2. Now that's small!
    By Ric_ in forum General Chat
    Replies: 1
    Last Post: 23rd April 2007, 05:12 PM
  3. Small form factor PC's
    By tosca925 in forum Hardware
    Replies: 11
    Last Post: 18th April 2007, 10:20 AM
  4. small email app
    By spc-rocket in forum Windows
    Replies: 3
    Last Post: 9th November 2005, 12:49 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •