+ Post New Thread
Results 1 to 5 of 5
Windows Thread, NTuser.dat corruption on logon in Technical; Hi I've got a problem with a laptop that is corrupting the ntuser.dat for a roaming profile user when logging ...
  1. #1
    karlb's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Posts
    4
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    NTuser.dat corruption on logon

    Hi

    I've got a problem with a laptop that is corrupting the ntuser.dat for a roaming profile user when logging on. It doesn't happen all the time, but still frequent enough to be a pain.

    What seems to be happening, is when the user logs on, the ntuser.dat is not copied properly to the local machine and either creates a fresh one or uses the partially copied file. The ntuser.dat goes from about 2.5mb to 256KB.

    The laptop is running win xp sp3.

    As anyone else had this problem?

    All the best

    Karlb

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    15,389
    Thank Post
    797
    Thanked 1,587 Times in 1,390 Posts
    Blog Entries
    10
    Rep Power
    427
    Is it pulling it from the default profile?

  3. #3
    karlb's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Posts
    4
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Possibly, but I'm not sure. There is no indication in event viewer of what's causing the problem or if the users ntuser is being replaced by the default user one.

    All the best
    Karlb

  4. #4

    Join Date
    Apr 2008
    Posts
    405
    Thank Post
    22
    Thanked 13 Times in 10 Posts
    Rep Power
    15
    This probably won't help as it works on logoff but it is useful to have it on your image so that profiles don't become corrupt and then get stored on the server.

    Download details: User Profile Hive Cleanup Service

  5. #5
    karlb's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Posts
    4
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi Reaper, thanks for the reply.

    All our machine already have the User Profile Hive Cleanup Service installed as default, but still have the problem with this machine.

    I think the problem may be caused by the Windows fast logon optimization setting, which is on by default. This setting will start the logging on process before the network is ready, which could mean that it's trying to load a deault profile, then realises that the network is available and then start loading the profile from the network, which then corrupts the ntuser.dat and copies it back to the network when logging off.

    The solution is to enable the following setting in the local group policy.

    Computer Configuration -> Administrative Template -> System -> Logon -> Always wait for the network at computer startup and logon. This setting needs setting to enabled, and it will take 2 logons for it to take effect.

    I don't if this solves my problem yet, but so far it seems to be working.

    All the best
    KarlB

SHARE:
+ Post New Thread

Similar Threads

  1. display corruption & smart board
    By Oops_my_bad in forum Windows
    Replies: 0
    Last Post: 15th October 2008, 10:54 AM
  2. SymantecAV and ntuser.dat 256kb
    By towen in forum Educational Software
    Replies: 0
    Last Post: 12th March 2008, 02:02 PM
  3. ntuser.dat,man files
    By TechSupp in forum Wireless Networks
    Replies: 1
    Last Post: 21st September 2007, 02:34 PM
  4. NTUSER dat file question
    By speckytecky in forum Wireless Networks
    Replies: 5
    Last Post: 19th June 2006, 02:00 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •