+ Post New Thread
Results 1 to 9 of 9
Windows Thread, Allow ASP .Net 2 in IIS Server 2003 R2 in Technical; Hi There I have just made a clean install of Server 2003 R2 and i am planning on using it ...
  1. #1

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468

    Allow ASP .Net 2 in IIS Server 2003 R2

    Hi There

    I have just made a clean install of Server 2003 R2 and i am planning on using it for SharePoint Services.

    When i install it informs me i need to allow ASP .Net 2 in IIS. When i go into Web Service Extensions all i can see is version 1.1.4322. I have installed .net framework 2 in add and remove components. I have done some googling but can't find a solution. Have i missed something here?

    Thanks

    Z

  2. #2

    EduTech's Avatar
    Join Date
    Aug 2007
    Location
    Reading
    Posts
    5,078
    Thank Post
    160
    Thanked 940 Times in 732 Posts
    Blog Entries
    3
    Rep Power
    275
    Try this... should do the trick (good job i kept notes from when i installed it)

    1. Open IIS Manager (open Run dialog from Start Menu and type 'inetmgr' in Start Edit Combo Box).
    2. In the IIS manager window, expand the Local Computer node.
    3. Click on Web Service Extensions node.
    4. Allow "Active Server Pages" and "ASP .net v2.0.xxxxx".

    James.

  3. #3

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    I know that but the problem is it is not showing in iis

  4. #4

    Join Date
    Oct 2005
    Posts
    62
    Thank Post
    7
    Thanked 20 Times in 17 Posts
    Rep Power
    22
    Try:

    c:\windows\microsoft.net\framework\v2.0.xxxxx\aspn et_regiis -i -enable

  5. #5

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by PeterH View Post
    Try:

    c:\windows\microsoft.net\framework\v2.0.xxxxx\aspn et_regiis -i -enable
    Hi

    thanks for the help but that .exe isn't there for some reason.

    Thanks

  6. #6

    Join Date
    Jan 2009
    Location
    East Anglia
    Posts
    5
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have found in the past that if you install .NET 2.0 before IIS you need to restart to get the ASP extensions to show up.

  7. #7

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Quote Originally Posted by Apollo View Post
    I have found in the past that if you install .NET 2.0 before IIS you need to restart to get the ASP extensions to show up.
    tried that, still no joy

  8. #8

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,374
    Thank Post
    906
    Thanked 1,811 Times in 1,559 Posts
    Blog Entries
    12
    Rep Power
    468
    Anyone else got any input please?

  9. #9


    Join Date
    Feb 2007
    Location
    Northamptonshire
    Posts
    4,706
    Thank Post
    354
    Thanked 807 Times in 722 Posts
    Rep Power
    348
    If that exe isn't there, it suggests you've got a duff .net2 installation.

    (Have just checked a 2003 server).



SHARE:
+ Post New Thread

Similar Threads

  1. ASP .Net rewritepath
    By apeo in forum Web Development
    Replies: 2
    Last Post: 17th October 2008, 09:35 AM
  2. asp / iis question
    By RabbieBurns in forum Web Development
    Replies: 14
    Last Post: 7th October 2008, 11:22 AM
  3. PHP or ASP.NET
    By plugged_in in forum Web Development
    Replies: 38
    Last Post: 8th March 2007, 12:08 PM
  4. SiteAtSchool / IIS / PHP / MySQL / Server 2003
    By OutToLunch in forum Windows
    Replies: 4
    Last Post: 5th February 2007, 03:19 PM
  5. Setting up IIS on Server 2003 SP1
    By tosca925 in forum Windows
    Replies: 4
    Last Post: 6th February 2006, 12:52 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •