+ Post New Thread
Results 1 to 3 of 3
Windows Thread, VBS startup scripts won't run in Technical; On our network we run several VBS scripts on machine startup.These clear old files, install Quicktime etc and have been ...
  1. #1

    Join Date
    Mar 2007
    Posts
    421
    Thank Post
    14
    Thanked 16 Times in 10 Posts
    Rep Power
    18

    VBS startup scripts won't run

    On our network we run several VBS scripts on machine startup.These clear old
    files, install Quicktime etc and have been working on over 500 PCs for
    several years.

    Occasionally, one PC will start to generate an error for each one of these
    vbs scripts:

    Event Type: Error
    Event Source: UserInit
    Event Category: None
    Event ID: 1000
    Date: 06/11/2008
    Time: 14:11:11
    User: N/A
    Computer: pc_name
    Description:
    Could not execute the following script delprofile.vbs. .

    I have tried everything to resolve this, and in the last 2 years have only
    found one resolution - reinstall windows! These scripts work fine when run
    directly on the failing PC, and work everywhere else! The scripts don't
    generate any errors, and even if I reduce the scripts down to just one it
    still generates the error. No matter whether I run 1 or all 3 I get the
    corresponding number of errors.

    The only thing I can see that is common is that they are all VBS scripts -
    other parts of the startup batch file are running (registry hacks etc)

    We do have Software Restriction Policies applied to users (never Machines) and I'm wondering if this is corrupting somehow for vbs scripts- other scripts (.bat etc) are still running OK.

    I'm at a loss now, any suggestions gratefully received?
    Last edited by GoldenWonder; 18th November 2008 at 04:28 PM.

  2. #2
    mjs_mjs's Avatar
    Join Date
    Jan 2009
    Location
    bexleyheath, london
    Posts
    1,018
    Thank Post
    37
    Thanked 111 Times in 95 Posts
    Rep Power
    37
    if i remember correctly there is a program that runs the VBS script. i think its windows scripting host on the clients. i dunno if it's possible to uninstall it then reinstall it? it's a shot in the dark.

  3. #3

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,154
    Thank Post
    114
    Thanked 527 Times in 450 Posts
    Blog Entries
    2
    Rep Power
    123
    Are you saying that if you type "delprofile.vbs" on a "faulty" machine that the script runs? If you type "cscript delprofile.vbs" does it run? What about "wscript delprofile.vbs"

    As Matt says, it's Windows scripting host which runs a .vbs file and there are two versions (I think of them as the console version and the Windows version) - I'm wondering if one is Ok but the other is faulty.

    You could try following this MS KB article - When I run a script in Windows Script, I receive an error message: "Library not registered" to see if that helps.

    If typing "delprofile.vbs" doesn't work but "cscript delprofile.vbs" does work then you could always change the batch file on the server so that it calls your script like that - it's actually not a bad idea anyway because you avoid problems where some machine might be using wscript as default and others using cscript

SHARE:
+ Post New Thread

Similar Threads

  1. Group Policies and startup scripts
    By Hedghog in forum Windows
    Replies: 1
    Last Post: 16th June 2008, 12:43 PM
  2. Startup scripts
    By djones in forum Windows
    Replies: 10
    Last Post: 27th February 2008, 12:18 AM
  3. Replies: 10
    Last Post: 16th February 2008, 07:47 PM
  4. Replies: 4
    Last Post: 7th March 2007, 03:37 PM
  5. Computer Startup Scripts
    By Spot in forum Windows
    Replies: 18
    Last Post: 16th November 2005, 11:06 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •