+ Post New Thread
Results 1 to 11 of 11
Windows Thread, external usb kit for sata and IDE devices ? in Technical; Hi All I have a SATA / IDE to USB kit and have attached a hard drive to the kit ...
  1. #1

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,673
    Thank Post
    3,205
    Thanked 1,029 Times in 954 Posts
    Rep Power
    361

    external usb kit for sata and IDE devices ?

    Hi All

    I have a SATA / IDE to USB kit and have attached a hard drive to the kit and then the usb cable to my Mac Pro ( using boot camp and windows xp ) windows xp detects 2 devices in device manager

    unknown device
    usb device

    but I can't seem to get it to detect that there is a hard drive or to get it to use it as a disk drive device and even going into device manager and disk management ( it does not show up in there )

    Any advice on what to do to get it to show up and working ?

  2. #2
    pscott's Avatar
    Join Date
    Oct 2007
    Location
    Tiverton
    Posts
    305
    Thank Post
    6
    Thanked 27 Times in 27 Posts
    Rep Power
    22
    Try another hard drive, I get this with some hard drive that are dead, a working drive and it picks up straight away as disk drive

  3. #3

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,673
    Thank Post
    3,205
    Thanked 1,029 Times in 954 Posts
    Rep Power
    361
    the hard drive I was using was a working one as I just attached it to one of my PC's IDE and it was detected fine.

  4. #4
    timbo343's Avatar
    Join Date
    Dec 2005
    Location
    Leeds/York area, North Yorkshire
    Posts
    2,936
    Thank Post
    266
    Thanked 261 Times in 188 Posts
    Rep Power
    114
    if you want to know if it is your USB adapter which is faulty, i can highly recommend this.. Plexus USB to IDE 2.5"/ 3.5" Transfer adapter With Power Adaptor - Ebuyer

  5. #5
    clarky2k3's Avatar
    Join Date
    Nov 2007
    Location
    Northumberland
    Posts
    318
    Thank Post
    35
    Thanked 47 Times in 39 Posts
    Rep Power
    24
    Quote Originally Posted by timbo343 View Post
    if you want to know if it is your USB adapter which is faulty, i can highly recommend this.. Plexus USB to IDE 2.5"/ 3.5" Transfer adapter With Power Adaptor - Ebuyer
    I second this product!

  6. #6

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    10,980
    Thank Post
    850
    Thanked 2,647 Times in 2,249 Posts
    Blog Entries
    9
    Rep Power
    763
    How old was the drive, I have had issues with older drives not being detected proberly by USB interface devices. These work fine on standard IDE but have issues with the newer/less feature complete controllers included in the USB bridge devices.

  7. #7

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,228
    Thank Post
    239
    Thanked 1,562 Times in 1,246 Posts
    Rep Power
    339
    The problem definitely looks driver related, hence the hard drive isn't displayed in Disk Management. If you try the external hard drive on another system, does it work ok?

  8. #8
    PeterW's Avatar
    Join Date
    Nov 2006
    Location
    Portsmouth
    Posts
    747
    Thank Post
    42
    Thanked 65 Times in 60 Posts
    Rep Power
    31
    I have a SATA / IDE to USB kit
    Does it have a power supply, if so is the drive spinning up? It sounds like the adaptor is being partially detected but is not getting enough power.

  9. #9

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,673
    Thank Post
    3,205
    Thanked 1,029 Times in 954 Posts
    Rep Power
    361
    the ide / sata kit I have has a mains power cable that converts it to the correct voltage for hard drives etc and then the ide / sata converts or goes to a usb cable which I plugged into the front of my mac pro and also tried it on a normal PC at the back ie the usb ports at the back both of which gave me 2 unknown devices as per the question

    unknown device
    usb device

    both of these had a yellow exclamation mark and did not locate the driver.

    I tried my kit with another old hard drive that I have and OS X 10.5.5 detected it and mounted the drive fine - I have not tried this with the other drive though as the data I needed retrieving was from another machine and I needed to alter the permissions and was not sure what it would do to the data as from what I understand the permissions that windows applies is different to os x 10.5.5 ( could be wrong ) but did not want to take any chances.

    yes the drive does spin up and then after a while it spins down or stops spinning or w/e as obviously ( both windows on bootcamp and windows on the PC does not have the relevant drivers to install for the hard drive ( lets call this hard drive one ) and my hard drive that mounted fine on os x hard drive two mounted.

  10. #10

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,228
    Thank Post
    239
    Thanked 1,562 Times in 1,246 Posts
    Rep Power
    339
    So from what you're saying, it does definitely appear to be driver related as the kit works with other systems. As a workaround, you could install it as a slave drive and copy data that way.

  11. #11

    mac_shinobi's Avatar
    Join Date
    Aug 2005
    Posts
    9,673
    Thank Post
    3,205
    Thanked 1,029 Times in 954 Posts
    Rep Power
    361
    I did that last night as gave up trying to get the kit to work and yes when attached as a slave drive to the PC ( not my mac pro ) the hard drive worked fine.

    Which is why I asked the question as I wanted to see if anyone could help me with the driver side of it.

SHARE:
+ Post New Thread

Similar Threads

  1. sata to ide adaptor ?
    By mac_shinobi in forum Hardware
    Replies: 0
    Last Post: 29th July 2008, 07:05 AM
  2. [Wanted] Sata/Ide drive cage
    By Deaks in forum Classified Adverts
    Replies: 10
    Last Post: 6th March 2008, 04:02 PM
  3. External sata hard drive problem.....
    By flashsnaps in forum Hardware
    Replies: 0
    Last Post: 7th February 2008, 11:27 PM
  4. External IEEE Hard Dive Caddy for a SATA Drive
    By richard in forum Hardware
    Replies: 11
    Last Post: 11th December 2006, 10:34 PM
  5. SATA External-Network Case Needed
    By Dos_Box in forum Hardware
    Replies: 10
    Last Post: 10th October 2006, 12:38 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •