+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 22
Windows Thread, service pack 3 worthwhile? in Technical; Read many of the posts on here about woes of SP3 but most seem to relate to networks etc now ...
  1. #1
    TechSupp's Avatar
    Join Date
    Mar 2007
    Location
    South Yorkshire
    Posts
    1,900
    Thank Post
    304
    Thanked 122 Times in 103 Posts
    Rep Power
    42

    service pack 3 worthwhile?

    Read many of the posts on here about woes of SP3 but most seem to relate to networks etc now its just appeared as an update on my home PC. Is it worth installing? and are there any perceivable benefits of putting it on?

  2. #2

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,212 Times in 761 Posts
    Rep Power
    394
    For the average home user there is little benefit to installing SP3 vs. the individual updates.

    As with any Service Pack, there is the potential for it to go wrong during the install and cause a lot of hassle.

    If you use 802.1x or NAP on your network, it's worth it if you want to manage that by Group Policy, which wasn't possible before.

    My preference at work is to install SP3 on new builds, but I'm in no rush to deploy it to existing XP machines.

  3. #3

    Join Date
    Aug 2005
    Location
    London
    Posts
    3,156
    Thank Post
    116
    Thanked 529 Times in 452 Posts
    Blog Entries
    2
    Rep Power
    124
    It's probably worth remembering that many posts on here (and across most of the web) are "I tried X and it doesn't work; how can I fix it" rather than "I installed Y and it worked fine"

    That means that if you look for stuff on SP3, you're going to find people having problems rather than the people who installed it without problem.

    A quick count here shows 8,5000 PCs with XP; of those, about 5,500 have SP3 and I'm not aware that we've had any significant problems with it.

  4. #4
    gshaw's Avatar
    Join Date
    Sep 2007
    Location
    Essex
    Posts
    2,662
    Thank Post
    166
    Thanked 220 Times in 203 Posts
    Rep Power
    67
    SP3 shaves quite a few seconds off the boot time as well, just for that it's worth having

    All our new build teaching machines are SP3 now and run quite a bit quicker with it on

    Also cuts down on the amount of updates required to install

  5. #5
    CheeseDog's Avatar
    Join Date
    Jan 2006
    Location
    West Midlands
    Posts
    217
    Thank Post
    5
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    I seem to be having the problem at home that windows updates have stopped downloading automatically.

    Manually going to the site works fine.

    Not really bothered looking into it much further.

  6. #6
    apoth0r's Avatar
    Join Date
    Apr 2007
    Location
    Northants
    Posts
    1,221
    Thank Post
    151
    Thanked 180 Times in 132 Posts
    Rep Power
    52
    On my home XP Pro machine I have SP3 and have had absolutely no problems with it.

  7. #7
    AyatollahPies's Avatar
    Join Date
    Jan 2008
    Location
    Earth
    Posts
    900
    Thank Post
    48
    Thanked 105 Times in 95 Posts
    Rep Power
    42
    I'd hang fire on installing it on sims workstations. Capita still haven't confirmed that it is compatible.

    Anyone using it on sims workstations with no issues? Mainly admin workstations?

  8. #8

    Sylv3r's Avatar
    Join Date
    Jul 2005
    Location
    Co. Durham
    Posts
    3,212
    Thank Post
    372
    Thanked 379 Times in 337 Posts
    Rep Power
    148
    Quote Originally Posted by Ayatollah Pies View Post
    I'd hang fire on installing it on sims workstations. Capita still haven't confirmed that it is compatible.

    Anyone using it on sims workstations with no issues? Mainly admin workstations?
    All of our admin machines are running SP3 with SIMS with no issues. Rolled it out and no problems from the start.

  9. Thanks to Sylv3r from:

    AyatollahPies (28th October 2008)

  10. #9
    browolf's Avatar
    Join Date
    Jun 2005
    Location
    Mars
    Posts
    1,525
    Thank Post
    106
    Thanked 89 Times in 75 Posts
    Blog Entries
    46
    Rep Power
    40
    my home pc definately seems a bit slower after sp3

  11. #10
    CheeseDog's Avatar
    Join Date
    Jan 2006
    Location
    West Midlands
    Posts
    217
    Thank Post
    5
    Thanked 2 Times in 2 Posts
    Rep Power
    18
    Quote Originally Posted by CheeseDog View Post
    I seem to be having the problem at home that windows updates have stopped downloading automatically.

    Manually going to the site works fine.

    Not really bothered looking into it much further.
    Seem to have fixed the issue by doing that manual install.

    Next update downloaded automatically today.

  12. #11


    Join Date
    Jul 2007
    Location
    Rural heck
    Posts
    2,662
    Thank Post
    120
    Thanked 434 Times in 353 Posts
    Rep Power
    126
    Didn't notice much difference on my home machine, still havn't taken the leap at work, mostly due to Sims not supporting it. Although I might sling it on the laptop, see if it dies (thought I've also got a copy of Vista Ultimate, which should kill it good).

  13. #12

    Join Date
    Nov 2007
    Location
    Manchester
    Posts
    206
    Thank Post
    2
    Thanked 13 Times in 7 Posts
    Rep Power
    16
    Has anybody else had the Folder Redirection problem with SP3? I've gone back to installing SP2 and pushing through the 114 updates as that way I can at least guarentee that users will be able to see their own redirected Desktop and My Documents when they first log on to a new PC.

  14. #13

    Join Date
    Feb 2008
    Location
    Portsmouth
    Posts
    163
    Thank Post
    16
    Thanked 18 Times in 13 Posts
    Rep Power
    17
    Quote Originally Posted by TheFopp View Post
    Has anybody else had the Folder Redirection problem with SP3? I've gone back to installing SP2 and pushing through the 114 updates as that way I can at least guarentee that users will be able to see their own redirected Desktop and My Documents when they first log on to a new PC.
    I haven't had a folder redirection problem with SP3 but I've experienced some weird issues with the spooler service which got fixed by using a different set of drivers...See here

    Make sure your server is fully updated before rolling SP3 across your network.

  15. #14
    tosh74's Avatar
    Join Date
    Dec 2006
    Location
    Scotland
    Posts
    136
    Thank Post
    27
    Thanked 43 Times in 27 Posts
    Rep Power
    23
    Quote Originally Posted by TheFopp View Post
    Has anybody else had the Folder Redirection problem with SP3? I've gone back to installing SP2 and pushing through the 114 updates as that way I can at least guarentee that users will be able to see their own redirected Desktop and My Documents when they first log on to a new PC.
    I find that My Docs redirect works on \\server\username$ but breaks on \\server\studenthome\username

  16. #15

    Join Date
    Oct 2008
    Posts
    30
    Thank Post
    3
    Thanked 2 Times in 2 Posts
    Rep Power
    12
    Pre-SP3 we were hit by this one:
    After you enable the Folder Redirection policy in Windows XP Service Pack 2, the Internet Explorer Maintenance policy may not apply

    I have also been affected by the folder redirection issue in SP3, this can be solved by using an older version of the file "fdeploy.dll"

    Copy the fdeploy.dll file from a SP2 install over the SP3 version of the file and things should start working again. It is located in \windows\system32

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. XP Service Pack 3 Problem
    By gshaikh in forum Windows
    Replies: 9
    Last Post: 23rd October 2008, 10:53 AM
  2. Unused service pack 3 files
    By andy_nic in forum Windows
    Replies: 8
    Last Post: 18th July 2008, 12:33 PM
  3. Speed up Service Pack 2 Logins
    By Nij.UK in forum Windows
    Replies: 4
    Last Post: 28th September 2006, 07:39 PM
  4. New Service Pack for Smartboard 9.5
    By deerwood in forum Educational Software
    Replies: 9
    Last Post: 20th July 2006, 02:52 PM
  5. Service Pack Integration
    By zippy in forum How do you do....it?
    Replies: 13
    Last Post: 13th December 2005, 10:08 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •