+ Post New Thread
Results 1 to 7 of 7
Windows Thread, WSUS with Equinet Cachepilot in Technical; Hi peeps. I'm having a problem with WSUS SP1 synchronizing with Microsoft Update. I have just recently installed it as ...
  1. #1
    Cragzman's Avatar
    Join Date
    Jan 2008
    Location
    In a cave - Somewhere in Naaaarrrfuk
    Posts
    38
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0

    WSUS with Equinet Cachepilot

    Hi peeps.

    I'm having a problem with WSUS SP1 synchronizing with Microsoft Update. I have just recently installed it as a clean install with no previous versions.

    Here is a few details of the setup we have:

    1. WSUS is installed on a domain controller.
    2. Our school goes through an E2BN Equiinet Cachepilot proxy (Release 3.2.5 (upgraded)).
    3. Proxy is using user login authentication (LDAP thingy) so we can see who has accessed what sites via Tail.

    In the WSUS proxy settings, I inputted the proxy name, port number, and login credentials with "Allow basic authentication (password is sent in cleartext)" enabled. With these settings, in therory, WSUS should work. But I get this error message:

    --------------------------------------------------------------------------
    WebException: The remote server returned an error: (407) Proxy Authentication Required.
    at System.Net.HttpWebRequest.GetRequestStream()
    at System.Web.Services.Protocols.SoapHttpClientProtoc ol.Invoke(String methodName, Object[] parameters)
    at Microsoft.UpdateServices.ServerSyncWebServices.Ser verSync.ServerSyncProxy.GetAuthConfig()
    at Microsoft.UpdateServices.ServerSync.ServerSyncLib. InternetGetServerAuthConfig(ServerSyncProxy proxy, WebServiceCommunicationHelper webServiceHelper)
    at Microsoft.UpdateServices.ServerSync.ServerSyncLib. Authenticate(AuthorizationManager authorizationManager, Boolean checkExpiration, ServerSyncProxy proxy, Cookie cookie, WebServiceCommunicationHelper webServiceHelper)
    at Microsoft.UpdateServices.ServerSync.CatalogSyncAge ntCore.SyncConfigUpdatesFromUSS()
    at Microsoft.UpdateServices.ServerSync.CatalogSyncAge ntCore.ExecuteSyncProtocol(Boolean allowRedirect)
    --------------------------------------------------------------------------

    Is this a known issue? Is there fix/workaround?

    Any ideas would rock.

    Cheers all

  2. #2

    Join Date
    Feb 2007
    Location
    Norfolk
    Posts
    137
    Thank Post
    2
    Thanked 9 Times in 9 Posts
    Rep Power
    16
    As a fellow Norfolk ICT Tech, i'll break it to you that ICT Solutions filter WSUS directly and always have. All is not lost however, as they now have an WSUS 3 SP1 upstream server. If you give them a call, they may provide the IP to you, else i can have a look at my settings tomorrow.

    Craig

  3. #3


    Join Date
    Oct 2006
    Posts
    3,411
    Thank Post
    184
    Thanked 356 Times in 285 Posts
    Rep Power
    148
    Dont know if its any help but whenever i manually go to the Windows Update site i get "Profile_Unknown"/Username=Anonymous error.

  4. #4
    Cragzman's Avatar
    Join Date
    Jan 2008
    Location
    In a cave - Somewhere in Naaaarrrfuk
    Posts
    38
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Had a go at calling ICT Solutions today but the internal phone system being a pain in the rear.

    If someone could give me the ICT Solutions WSUS 3 SP1 upstream IP with port number, I would be very grateful.

  5. #5

    Join Date
    Jun 2005
    Location
    London, UK
    Posts
    115
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    20
    ICT Solutions have not always filtered WSUS - it used to work quite happily! The 407 error is probably due to AD authentication on the cachepilot - there's a config option in WSUS to adjust the proxy authentication settings.

    The upstream WSUS server used to be 10.96.207.100 but could well have changed since I last looked.
    Last edited by Slartibartfast; 7th October 2008 at 03:33 PM.

  6. #6
    Cragzman's Avatar
    Join Date
    Jan 2008
    Location
    In a cave - Somewhere in Naaaarrrfuk
    Posts
    38
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    I'm using the Servers user account for proxy authentication and it belongs to the netinet group. It should work but it doesn't. Tried my own credentials but no joy. Nothing looks amiss in AD either.

  7. #7
    Cragzman's Avatar
    Join Date
    Jan 2008
    Location
    In a cave - Somewhere in Naaaarrrfuk
    Posts
    38
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    0
    Quick update.

    For a test I tweaked the Cachepilot so I don't have to input user proxy credentials in a 2 hour timespan. WSUS synchronizes with no problems. Hope it still askes for credentials outside the 2 hours eek.

    Bummer that it hates AD authentication.

SHARE:
+ Post New Thread

Similar Threads

  1. Cachepilot V4
    By tomscaper in forum Wireless Networks
    Replies: 3
    Last Post: 19th September 2008, 11:44 AM
  2. Replies: 3
    Last Post: 21st February 2008, 08:50 AM
  3. Cachepilot Problems
    By tomscaper in forum Windows
    Replies: 4
    Last Post: 7th November 2007, 09:30 PM
  4. WSUS & Cachepilot Proxy Servers
    By BaccyNet in forum Windows
    Replies: 10
    Last Post: 3rd September 2007, 11:27 AM
  5. Replies: 1
    Last Post: 8th November 2006, 09:57 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •