+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 21
Windows Thread, P[r]oxy problem in Technical; I was experimenting with censornet over the weekend, and changed the GPO proxy settings to point to the censornet box. ...
  1. #1
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    P[r]oxy problem

    I was experimenting with censornet over the weekend, and changed the GPO proxy settings to point to the censornet box. Took a little fiddling to get it going, finally blanking the local profile proxy settings did the trick.

    Changed it back, and no machines were picking up the correct proxy and getting out to the web! Setting a local proxy again has fixed it for the kids, but staff are still unable to get out.

    Staff are on a child domain and no settings were changed there!

  2. #2
    Quackers's Avatar
    Join Date
    Jan 2006
    Posts
    1,309
    Thank Post
    40
    Thanked 141 Times in 116 Posts
    Rep Power
    53

    Re: P[r]oxy problem

    Are they Windows XP Service Pack 2 clients? As Service Pack 2 broke the GPO for Proxy Settings and they do not get applied.

    Cannot find the support artical now, but i had this problem last year and found SP2 to be the cause.

  3. #3
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: P[r]oxy problem

    Not all SP2 - the vast majority, but I have one Win2K with the problem. I'll go play with that one and see if I can't get it going.

  4. #4
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: P[r]oxy problem

    On the XP SP2 PCs: Turned on the LAN settings page for staff users and they have auto detect settings checked and no proxy set [with the censornet address greyed out].

    Firewall is off on this PC as I read proxy settings maybe affected by that. Still no closer

  5. #5

    Join Date
    Feb 2006
    Posts
    1,187
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: P[r]oxy problem

    It might be something to do with the GPO caching. In order to speed up XP booot times I think MS have made it so that GPO changes to clients are only applied after a reboot.

    Anyway as a possible workaround have you tried setting the proxy value in the DHCP options?

  6. #6
    Quackers's Avatar
    Join Date
    Jan 2006
    Posts
    1,309
    Thank Post
    40
    Thanked 141 Times in 116 Posts
    Rep Power
    53

    Re: P[r]oxy problem

    Do you have folder redirection on the same policy as internet explorers maintence settings?

    I can find this artical which says in SP2 Computers with folder redirection and IE's settings in , the folder redirection fails.

    http://support.microsoft.com/default...b;en-us;888254

    Its not the fix your after, but i found my PC's did the reverse, IE's settings failed and folder redirection worked. Do you have any SP1 machines you can test this on just to confirm its somthing MS have messed so SP2 broke it? If its the problem i had you'll find no SP and SP1 machines do as you expect.


    This person has the same problem http://groups.google.co.uk/group/mic...cbdc02315ee225 it was Application Data redirection on the same group policy that was the problem.

  7. #7
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: P[r]oxy problem

    Thanks for those guys :goes off to investigate:

    @Networkgeezer: How do you set proxy values in DHCP?

    @Quackers: Yes - folder re-direction happens on the same policy [I also re-direct an applications' settings too on that GPO]

  8. #8
    Netman's Avatar
    Join Date
    Jul 2005
    Location
    56.343515, -2.804118
    Posts
    911
    Thank Post
    367
    Thanked 190 Times in 143 Posts
    Rep Power
    54

    Re: P[r]oxy problem

    Quote Originally Posted by mark
    Thanks for those guys :goes off to investigate:

    @Networkgeezer: How do you set proxy values in DHCP?
    You need to set up wpad (web proxy auto-detection protocol) if your proxy supports it... you can use either dns or dhcp to do this... further info for using ISA2004 and wpad is here http://www.microsoft.com/technet/pro...discovery.mspx

    In DHCP you need to add a 252 wpad option and insert the url of your proxy wpad file... eg. "http://cerberus:80/wpad.dat"

  9. #9

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,241
    Thank Post
    239
    Thanked 1,567 Times in 1,249 Posts
    Rep Power
    339

    Re: P[r]oxy problem

    To my knowledge Windows 2000 Server, Server 2003 and XP Pro update their policies every 90 minutes.

    I would recommend specifying the proxy settings from the MMC console (using XP). Start > Run > MMC and add the Group Policy Object Editor. Specify the Active Directory Group Policy Object, then specify your proxy settings.

    Now click Start, Run and type gpupdate A command prompt will appear and then disappear once complete. Now open up IE and check whether your proxy settings have been applied.

  10. #10
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: P[r]oxy problem

    OK. Win2K PC exactly the same - no joy.

    Tried moving proxy setting to a seperate OU. Also removed Appication Data re-direction.

    Results of policy wixard say that policies are bieng applied - but to same admin user actually logged into the machine at the same time the evidence shows the policies didn't apply.

    @Netman: Our proxy server is a slackware linux box - i'll ask if that'll support wpad. Looking into scripting proxy setting via kixtart.

  11. #11

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,802
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: P[r]oxy problem

    i'll ask if that'll support wpad
    Quite easy to do, I've played with it in the past. All you need is a webserver and the right DNS entries.

  12. #12

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,590
    Thank Post
    109
    Thanked 762 Times in 593 Posts
    Rep Power
    180

    Re: P[r]oxy problem

    I've had Windows XP boxes have wiered proxy problems before now, where the IE settings are right but the rest of Windows throws a wobbler and things like Windows Update don't work.

    There is a command called 'proxycfg' that allows you to reset the proxy settings - this generally works for me.

    http://support.microsoft.com/default...b;en-us;830605 has a few details. It states that it is available for Win2K SP4 too.

  13. #13
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: P[r]oxy problem

    Interesting Ric. Didn't seem to do anything!

    Sorted my problem anyway - found the GPO that was calling the shots - the Computer OU.

    Definately changing to an alternate method, either scripted or server out by DHCP.

    Thanks everyone for your help

  14. #14

    Join Date
    Feb 2006
    Posts
    1,187
    Thank Post
    0
    Thanked 1 Time in 1 Post
    Rep Power
    0

    Re: P[r]oxy problem

    @Ric_: I think ProxyCfg only sets the proxy value used by automatic updates

    @Mark: Glad it worked out. How did you find the culprit, cleitns side diagnostics or did you simply stare the problem into submission

  15. #15
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,958
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: P[r]oxy problem

    More of the staring type diagnostics Geezer! :P - though as usual - some overnight contemplation helped greatly.

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •