+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 17
Windows Thread, Offline files on reconnect to network in Technical; I have looked through a lot of the offline files thread but not managed to get my answer. I am ...
  1. #1
    Rozzer's Avatar
    Join Date
    Aug 2005
    Location
    South West
    Posts
    720
    Thank Post
    21
    Thanked 81 Times in 61 Posts
    Rep Power
    33

    Offline files on reconnect to network

    I have looked through a lot of the offline files thread but not managed to get my answer.

    I am having an issue with shares going offline and not coming online without manually setting of the synchronization.

    Because i have a shared area on the same server as the user areas it takes both offline. I have tried setting up a different DNS name for the shared area but still takes it offline.

    Does anyone have a solution because its starting to p*** me off.

    Appreciate your advice

    Ross

  2. #2

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,060
    Thank Post
    853
    Thanked 2,673 Times in 2,269 Posts
    Blog Entries
    9
    Rep Power
    768
    You should be able to configure the affected users accounts to prevent making the shared area an offline folder by using group policy. You can also configure the areas that you want made available offline in there to. This should also allow you to configure the other settings ie. the behavior of offline files when reconnected to the network as well which should solve your issues if I understood your post correctly.

    User Configuration -> Administrative Templates -> Network -> Offline Files

  3. #3

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    Quote Originally Posted by Ross2k5 View Post
    I have looked through a lot of the offline files thread but not managed to get my answer.

    I am having an issue with shares going offline and not coming online without manually setting of the synchronization.

    Because i have a shared area on the same server as the user areas it takes both offline. I have tried setting up a different DNS name for the shared area but still takes it offline.

    Does anyone have a solution because its starting to p*** me off.

    Appreciate your advice

    Ross
    I have the same issue with offline files, teachers laptops are set to use offline files for their home folders, as I want them to have these available off the network for obvious reasons. Quite often staff move around the building and the wireless signal drops out as they move, triggering the laptop into offline mode. It always requires a manual syncronisation to get the folder back online, even if the wireless has restored itself. I've played with group policy endlessly trying to get the folders to automatically come back online when the network is restored without much joy.

    If anyone does have any ideas on how to achieve this, I'd be really grateful too!

    For your shared area if you don't want this to be available offline at all, you can set this on the share properties. There's an option for never make these files available offline which might solve your problem. You can also use the GPO setting 'don't use offline files for these files or folders' and specify the relevant share.

    Mike.
    Last edited by maniac; 7th September 2008 at 03:29 PM.

  4. Thanks to maniac from:

    Rozzer (7th September 2008)

  5. #4
    Rozzer's Avatar
    Join Date
    Aug 2005
    Location
    South West
    Posts
    720
    Thank Post
    21
    Thanked 81 Times in 61 Posts
    Rep Power
    33
    Its almost a relief to hear that i am not the only one having this issue.

    I have added the shared folder into the do not go offline option in GPO.

    We also don't use wireless we use docking stations in every class room.

    Ross

  6. #5

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    I've been googling and turned up this.

    Forced silent auto reconnection:
    When a server has been unavailable (offline mode) and then becomes available again for connection, Offline Files Client Side Caching tries to transition that server to online mode if all the following conditions are true: #
    • There are no offline changes for that server on the local computer.
    • There are no open file handles for that server on the local computer.
    • The server is accessed over a “fast” link.

    You can adjust the definition of “slow” and “fast” by using the SlowLinkSpeed Offline Files policy. With this hotfix, you can configure Offline Files Client Side Caching to ignore these conditions and transition the server to online mode regardless of whether these conditions exist. To do this, follow these steps:

    1. Click Start, click Run, type REGEDIT, and then click OK.
    2. Locate and click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\NetCache
    3. Click Edit, point to New, and then click DWORD Value.
    4. Type SilentForcedAutoReconnect, and then press ENTER to name the value.
    5. Double-click SilentForcedAutoReconnect.
    6. In the Value data box, type 1, and then click OK.

    Source

    Going to try that tomorow.

    Mike.

  7. Thanks to maniac from:

    Rozzer (7th September 2008)

  8. #6
    Rozzer's Avatar
    Join Date
    Aug 2005
    Location
    South West
    Posts
    720
    Thank Post
    21
    Thanked 81 Times in 61 Posts
    Rep Power
    33
    Quote Originally Posted by maniac View Post
    I've been googling and turned up this.

    Forced silent auto reconnection:
    When a server has been unavailable (offline mode) and then becomes available again for connection, Offline Files Client Side Caching tries to transition that server to online mode if all the following conditions are true: #
    • There are no offline changes for that server on the local computer.
    • There are no open file handles for that server on the local computer.
    • The server is accessed over a “fast” link.

    You can adjust the definition of “slow” and “fast” by using the SlowLinkSpeed Offline Files policy. With this hotfix, you can configure Offline Files Client Side Caching to ignore these conditions and transition the server to online mode regardless of whether these conditions exist. To do this, follow these steps:

    1. Click Start, click Run, type REGEDIT, and then click OK.
    2. Locate and click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\NetCache
    3. Click Edit, point to New, and then click DWORD Value.
    4. Type SilentForcedAutoReconnect, and then press ENTER to name the value.
    5. Double-click SilentForcedAutoReconnect.
    6. In the Value data box, type 1, and then click OK.

    Source

    Going to try that tomorow.

    Mike.
    If this works i will be a very happy man Give me a update how you do

    Ross

  9. #7

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    Quote Originally Posted by Ross2k5 View Post
    If this works i will be a very happy man Give me a update how you do

    Ross
    Believe me if it works I'll also be very happy, as I've been looking for a solution to this problem for a while now. It's one of my most annoying problems at work, I had just accepted it as a flaw in the offlines files system and had previously googled for the solution with no results!

    I'll hopefully get the time to try it tomorrow, although the cashless catering system goes live tomorrow, so depends on how smoothly that goes!

    Mike.

  10. #8
    Rozzer's Avatar
    Join Date
    Aug 2005
    Location
    South West
    Posts
    720
    Thank Post
    21
    Thanked 81 Times in 61 Posts
    Rep Power
    33
    The hot fix would not work for me as i am on Service Pack 3

  11. #9

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    Quote Originally Posted by Ross2k5 View Post
    The hot fix would not work for me as i am on Service Pack 3
    Bugger, didn't realise SP3 stopped it working. Most of our staff machines are also on SP3, so that puts pay to that idea. I didn't get the chance to try it myself as cashless catering took over my life today!

    Mike.

  12. #10
    Rozzer's Avatar
    Join Date
    Aug 2005
    Location
    South West
    Posts
    720
    Thank Post
    21
    Thanked 81 Times in 61 Posts
    Rep Power
    33
    Quote Originally Posted by maniac View Post
    Bugger, didn't realise SP3 stopped it working. Most of our staff machines are also on SP3, so that puts pay to that idea. I didn't get the chance to try it myself as cashless catering took over my life today!

    Mike.
    Got any other ideas?

  13. #11

    maniac's Avatar
    Join Date
    Feb 2007
    Location
    Kent
    Posts
    3,037
    Thank Post
    209
    Thanked 425 Times in 306 Posts
    Rep Power
    144
    Nope, but this post on the MSDN contains as much information as I've been able to find on offline files for windows XP.

    Jonathan Hardwick : User comments about offline files

    There's a very long post about halfway down with lots of registry hacks and other useful information in.

    Incidently, how did you find out that SP3 stops that reg hack working, or did you just try it and get no change in what was happening?

    Mike.

  14. #12

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,060
    Thank Post
    853
    Thanked 2,673 Times in 2,269 Posts
    Blog Entries
    9
    Rep Power
    768
    Have you tried specifying the correct behaviors in the machine section of the policy that applies to your laptops to put the reconnect action in at system level?

    Computer Configuration -> Administrative Templates -> Network -> Offline Files

    This helped solve this kind of issue that occurred on a couple of laptops here. The other thing was to do a full policy refresh with "gpupdate /force" as they did not seem to apply the offline files policy properly without it.

    The other thing that I tried was a complete rebuild of the offline files cache which pointed everything back in the right direction when the data store became corrupted. This did help on one occasion Tips for Microsoft Windows XP

  15. #13

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,331
    Thank Post
    623
    Thanked 1,581 Times in 1,418 Posts
    Rep Power
    414
    To reset the offline files cache you can do this:

    1. Click Start, click Run, type REGEDIT, and then click OK.
    2. Locate and click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\NetCache
    3. Click Edit, point to New, and then click DWORD Value.
    4. Type FormatDatabase, and then press ENTER to name the value.
    5. Double-click SilentForcedAutoReconnect.
    6. In the Value data box, type 1, and then click OK.
    7. Reboot

    This was from a MS page.

    We have the issue where a laptop user lets someone else logon to their laptop then it tries to sync more than one users area.

    Ben

  16. #14

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,060
    Thank Post
    853
    Thanked 2,673 Times in 2,269 Posts
    Blog Entries
    9
    Rep Power
    768
    Quote Originally Posted by plexer View Post
    To reset the offline files cache you can do this:
    Or you can just do this:
    1.In Folder Options, on the Offline Files tab, press CTRL+SHIFT, and then click Delete Files. The following message appears: The Offline Files cache on the local computer will be re-initialized. Any changes that have not been synchronized with computers on the network will be lost. Any files or folders made available offline will no longer be available offline. A computer restart is required.
    Do you wish to re-initialize the cache?


    2.Click Yes two times to restart the computer.

  17. #15

    plexer's Avatar
    Join Date
    Dec 2005
    Location
    Norfolk
    Posts
    13,331
    Thank Post
    623
    Thanked 1,581 Times in 1,418 Posts
    Rep Power
    414
    That option doesn't appear on laptops who's settings are controlled by a Domain GPO.

    At least it doesn't on mine

    Ben

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. offline files
    By ICT_GUY in forum Wireless Networks
    Replies: 9
    Last Post: 18th March 2008, 09:11 AM
  2. offline files on but off.
    By Teth in forum Windows
    Replies: 3
    Last Post: 13th December 2007, 10:27 PM
  3. offline files
    By browolf in forum Windows
    Replies: 2
    Last Post: 25th July 2007, 10:44 AM
  4. Offline files problem
    By dezt in forum Wireless Networks
    Replies: 2
    Last Post: 24th November 2006, 12:52 PM
  5. Offline Files
    By woody in forum Windows
    Replies: 2
    Last Post: 9th December 2005, 10:52 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •