+ Post New Thread
Results 1 to 9 of 9
Windows Thread, MSTSC in Technical; Hey, I was wondering if anyone knows of anyway I can make mstsc not aquire the printers from the workstation ...
  1. #1

    Join Date
    Feb 2006
    Location
    Staffordshire
    Posts
    134
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    MSTSC

    Hey,

    I was wondering if anyone knows of anyway I can make mstsc not aquire the printers from the workstation i'm using to RD. Reason being: last time I terminal service'd into server 2 it BSOD! Only thing in the logs were the printer drivers etc being added :? I have checked /? and there doesn't seem to be a switch or anything, any thoughts?

    -Rob

  2. #2

    Join Date
    Nov 2005
    Location
    North
    Posts
    1,903
    Thank Post
    25
    Thanked 96 Times in 76 Posts
    Rep Power
    51

    Re: MSTSC

    Group policy can do it I believe.

    Windows Compnoents/Terminal Services/Client/Server data redirection in group policy has a setting Do not allow client printer redirect and Do not allow LPT port redirection.

    It works for me although the deny wallpaper redirection session setting never does.

  3. #3
    fooby's Avatar
    Join Date
    Dec 2005
    Posts
    351
    Thank Post
    0
    Thanked 5 Times in 4 Posts
    Rep Power
    20

    Re: MSTSC

    Untick the printers on the local resources tab of mstsc the client side. Tis should stop it. See attachment.

    fooby
    Attached Images Attached Images

  4. #4

    Join Date
    Feb 2006
    Location
    Staffordshire
    Posts
    134
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: MSTSC

    Quote Originally Posted by fooby
    Untick the printers on the local resources tab of mstsc the client side. Tis should stop it. See attachment.

    fooby
    Aha! Didn't see that! Is there a switch I can use when running it from the cmd?

    Rob

  5. #5
    fooby's Avatar
    Join Date
    Dec 2005
    Posts
    351
    Thank Post
    0
    Thanked 5 Times in 4 Posts
    Rep Power
    20

    Re: MSTSC

    Maybe,

    Another way is you could save the settings to an RDP file then run that.

  6. #6
    fooby's Avatar
    Join Date
    Dec 2005
    Posts
    351
    Thank Post
    0
    Thanked 5 Times in 4 Posts
    Rep Power
    20

    Re: MSTSC

    mstsc /? shows some settings.

    once you saved the rdp file you can "mstsc noprinters.rdp" (without quotes) and this should do it. Does mean you will need to precreate each RDP file for a server though.

    Also you could try software called Royal TS, this has many rdp connections in one user interface with independant settings saved. I use it all day, its great

  7. #7

    Join Date
    Feb 2006
    Location
    Staffordshire
    Posts
    134
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: MSTSC

    Quote Originally Posted by fooby
    Maybe,

    Another way is you could save the settings to an RDP file then run that.
    Ahh yeah, just done that. Works a treat, thanks

    Quote Originally Posted by fooby
    Also you could try software called Royal TS, this has many rdp connections in one user interface with independant settings saved. I use it all day, its great
    I just use the Remote Desktops MMC Snapin for switching between a lot of servers, does the job for me normally.

    -Rob

  8. #8

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    Boston, MA
    Posts
    7,601
    Thank Post
    110
    Thanked 771 Times in 599 Posts
    Rep Power
    183

    Re: MSTSC

    Go to Administrative Tools -> Terminal Services Configuration

    Click Connections and right-click RDP-Tcp and select Properties

    On the Client Settings tab click the check boxes to disable what you like

  9. #9

    Join Date
    Feb 2006
    Location
    Staffordshire
    Posts
    134
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: MSTSC

    Quote Originally Posted by Ric_
    Go to Administrative Tools -> Terminal Services Configuration

    Click Connections and right-click RDP-Tcp and select Properties

    On the Client Settings tab click the check boxes to disable what you like
    ahhhh even better! means I dont have to worry about running the right files!

    Cheers

    EDIT:
    ALSO! While I've got your attention, is there a way to allow control of the console session with a Windows 2000 server like there is with 2003?

    -Cheers
    Rob



SHARE:
+ Post New Thread

Similar Threads

  1. mstsc to home machines that are behind a router
    By mac_shinobi in forum Windows
    Replies: 7
    Last Post: 28th November 2007, 07:03 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •