+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 19
Windows Thread, Weird SMB Error in Technical; I've just had a problem with one of our laptops. I was asked to look at it yesturday as it ...
  1. #1

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Weird SMB Error

    I've just had a problem with one of our laptops. I was asked to look at it yesturday as it kept losing its connection to network shares - it'd tell you it was working offline, and all the mapped drives would appear to be empty. If you try to reconnect, it'll connect, syncronize, and then immediately disconnect again.

    I was getting the following errors appearing in the security log:

    Event Type: Warning
    Event Source: MRxSmb
    Event Category: None
    Event ID: 3019
    Date: 13/03/2006
    Time: 09:18:01
    User: N/A
    Computer: TEACHER-LT-AL
    Description:
    The redirector failed to determine the connection type.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 00 00 00 00 04 00 4e 00 ......N.
    0008: 00 00 00 00 cb 0b 00 80 ....Ë..€
    0010: 00 00 00 00 84 01 00 c0 ....„..À
    0018: 00 00 00 00 00 00 00 00 ........
    0020: 00 00 00 00 00 00 00 00 ........
    I found a reference to a windows update resolving this error, so I've applied the latest updates, and the message has now disappeared from the logs. The problem with the shares is still there, however.

    I can safely ping the server, and can browse the web fine, so TCP/IP is obviously working. Any ideas before I completely re-image the machine?

  2. #2

    Join Date
    Mar 2006
    Location
    Bradford
    Posts
    99
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    Have you looked through the suggestions on this page?

    http://www.eventid.net/display.asp?e...MRxSmb&phase=1

  3. #3
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,454
    Thank Post
    10
    Thanked 494 Times in 434 Posts
    Rep Power
    112

    Re: Weird SMB Error

    There is a fix for this, I'll see if I can find it

  4. #4
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,454
    Thank Post
    10
    Thanked 494 Times in 434 Posts
    Rep Power
    112

    Re: Weird SMB Error

    KB884020 File is WindowsXP-KB884020-x86-enu.exe

  5. #5

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    I already applied that fix. After doing so, the errors in the event log disappeared, but I still can't hold a connection open longer than around 10-20 seconds.

  6. #6
    DMcCoy's Avatar
    Join Date
    Oct 2005
    Location
    Isle of Wight
    Posts
    3,454
    Thank Post
    10
    Thanked 494 Times in 434 Posts
    Rep Power
    112

    Re: Weird SMB Error

    Have you tried turning offline folders off and removing all the mapped drives? Try creating a new profile for the user too.

  7. #7

    Ric_'s Avatar
    Join Date
    Jun 2005
    Location
    London
    Posts
    7,596
    Thank Post
    109
    Thanked 764 Times in 595 Posts
    Rep Power
    181

    Re: Weird SMB Error

    What kind of laptop is it?

    I take it you tried re-installing the NIC drivers? If it is a DELL with it's 'customised' Intel drivers, scoot off to Intel and get the ones that work properly!

    I take it you have also checked the wiring of the network patch and socket - a loose connection would cause it to connect and disconnect and would also confuse it as to the connection speed/type.

  8. #8

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    It's a Samsung V25 laptop. I've not done anything to the NIC drivers yet - I might try that tomorrow. For the most part, networking seems to be OK - it'll ping the servers, authenticate and browse the web without problems. It's only file sharing over SMB that seems to be causing problems.

  9. #9


    Join Date
    Jan 2006
    Posts
    8,202
    Thank Post
    442
    Thanked 1,032 Times in 812 Posts
    Rep Power
    339

    Re: Weird SMB Error

    can you telnet out to remote smb ports (139,445 IIRC) ?
    It might give a hint as to whether its the laptops SMB client or a tcp/ip error -

    I had an almost similar problem with a windows 2000 server a while back - it wouldn't make outbound connections to certain services for some reason - but it would ping ok, and web was ok. reapplied service packs and it was ok in the end.

  10. #10
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Weird SMB Error

    I get these weird MRXSMB 3019 errors as well. IIRC, it's something to do with using remote desktop.

  11. #11

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    I've tried re-installing network drivers, and have just tried doing a full repair on Windows XP. I've got one last trick to try with the network card drivers before I give up and completely re-install Windows.

    If you've got any more ideas, I'm still listening.

  12. #12

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    I just grabbed the original driver CD and reinstalled the network card drivers using the installer, rather than just removing the driver from device manager and allowing Windows to reinstall it automatically. It seems to be working now (touch wood).

    Thanks to everyone for your help. I'll let you know if there are any more problems.

  13. #13

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    OK, the problem is still there on that laptop (Samsung V-25), and one of the Dell Lattitude 110L machines has just started doing the same thing. No references to the MRXSMB errors this time.

    Erm... help?

  14. #14

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,804
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: Weird SMB Error

    This happens when the machine tries to connect to itself via localhost (127.0.0.1) using MS networking. It can't determine the speed of the connection and throws these SMB errors. You can safely ignore these.

  15. #15

    Join Date
    Jan 2006
    Posts
    22
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Re: Weird SMB Error

    Sorry, maybe I wasn't very clear. The Samsung laptop developed the MRXSMB errors in the log and kept disconnecting from shares on one of our servers. Since patching, I've still got the disconnects, but the MRXSMB errors in the event log are gone. I originally assumed they were related, as the problem only relates to file sharing, but they now appear to be separate problems.

    In any case, I've now got two laptops (one Dell, one Samsung) giving me problems. They connect, synchronise, then disconnect again. If you attempt to reconect, they'll synchronise again, and disconnect immediately afterwards. It's causing no end of problems as these laptops cannot access our shared common drives.

    Forget the MRXSMB errors for now - it's the disconnection's I'm concerned about. Anyone seen this before?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Weird RIS Issue
    By Richie1972 in forum How do you do....it?
    Replies: 17
    Last Post: 26th July 2007, 02:17 PM
  2. This is weird....
    By Gatt in forum Windows
    Replies: 6
    Last Post: 6th January 2007, 11:47 AM
  3. Weird error messages
    By _Bat_ in forum General Chat
    Replies: 5
    Last Post: 24th November 2006, 08:50 PM
  4. Weird/Annoying error
    By Gatt in forum Wireless Networks
    Replies: 2
    Last Post: 30th June 2006, 04:41 AM
  5. Weird AD problem
    By SpuffMonkey in forum Windows
    Replies: 3
    Last Post: 29th March 2006, 10:57 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •