+ Post New Thread
Results 1 to 5 of 5
Windows Thread, DNS Problem in Technical; Ok a quick one I'm sure, I've been voluenteering with a local charity group and helped them sort out there ...
  1. #1

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,399
    Thank Post
    1,516
    Thanked 1,056 Times in 925 Posts
    Rep Power
    303

    DNS Problem

    Ok a quick one I'm sure, I've been voluenteering with a local charity group and helped them sort out there computer system. They have a server 2003 DC which had no DNS, DHCP etc so I added all that in and turned the DHCP off on the ADSL router (small place 10 PCs etc).

    Now the job was over 1/2 done when I got involved (another edugeek (not a member of here I believe) had started it for them but got too busy and ran out of time) so didn't do it from scratch and the person who started it called the domain, there domain name (domain.co.uk) now I never do that myself, I'm always a one for domain.internal or something along that line.

    Now the server has got a local DNS Server installed on it which works fine internally as the machines see the server unlike before when the BT Router was doing it as the server happened to have a web server with the same name (server.domain.co.uk) so thats all good.

    But I got a call today saying they cannot access there website anymore :S now I was sure I had done so but as im not there I cannot argue with them, but when they go to Sedo - Buy and Sell Domain Names and Websites it just goes nope page cannot be displayed (this will be in Firefox if this make any difference).

    Has anyone any suggestions as to what I have failed to tick or missed as I've seen it working fine before when its been like this. I'm sure its just a tick box or a line I need to add in somewhere in DNS. I was thinking do I need to add an A record to the servers DNS and point that to the IP of the webserver and give it the host name of www. but then I thought hmm that may not be right.

    Probably worth me saying the website isn't hosted by them its a complete external firm nothing do to with there internet connection or local network.

    Any help greatly accepted

  2. #2
    box_l's Avatar
    Join Date
    May 2007
    Location
    Herefordshire
    Posts
    436
    Thank Post
    75
    Thanked 94 Times in 78 Posts
    Rep Power
    63
    Hi,

    a few questions..

    what is the name of the site they want to get to?

    and where is your DNS pointed for its forwarders, if any?

    if not do they have any other way of resolving addresses?

    BoX

  3. #3

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,399
    Thank Post
    1,516
    Thanked 1,056 Times in 925 Posts
    Rep Power
    303
    DNS Forwarders are set to the ISPs DNS Servers, ISP is BT Business Broadband. I expected the internal DNS to say no device by the name www on the network forward on and I was sure that had been working. As for the site, does it matter greatly, im just needing to protect the ID of the group in case the person that started the project is a member on here, if its such a major issue i will PM it but its in the following format:
    Domain: domainname.co.uk
    Server (also DC): server1.domainname.co.uk

    obviously ww.domainname.co.uk is what is not working so it something surely with its resolution of www. thats the problem in that its not getting the right answer to www. I will get them to try pinging EduGeek.net.... from a workstation and see what replys / or doesnt as well as a tracert to it see where its vanishing into the eather....
    Last edited by john; 25th April 2008 at 12:19 AM. Reason: ok the hyperlink title grabber is nice but a PITA when using fake domains as an example!

  4. #4

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,239
    Thank Post
    882
    Thanked 2,742 Times in 2,316 Posts
    Blog Entries
    11
    Rep Power
    784
    Quote Originally Posted by john View Post
    I was thinking do I need to add an A record to the servers DNS and point that to the IP of the webserver and give it the host name of www. but then I thought hmm that may not be right.
    That sounds exactly right, the problem is probably because of the internal domain name chosen. if your internal domain is domain.co.uk and the site is Sedo - Buy and Sell Domain Names and Websites the lookup will only go to the local DNS server as it considers itself authoritative for that domain and so if it does not know the answer it assumes it does not exist.

    If you add in the A record for WWW under your DNS domain and point it at the correct ip it should all work fine. You will also want to remember to add stuff like smtp to the list if they have their own hosted mail server that they need to access.

  5. Thanks to SYNACK from:

    john (25th April 2008)

  6. #5

    john's Avatar
    Join Date
    Sep 2005
    Location
    London
    Posts
    10,399
    Thank Post
    1,516
    Thanked 1,056 Times in 925 Posts
    Rep Power
    303
    Cheers for that Sysnack, I will email there person who is the on-site / more local IT person with full details of how to add the a record in and finers crossed that works. I will also ask them about SMTP, FTP etc. I know they do a webcam stream and I do believe that may have stopped working but that could go direct on the router and be manually setup to ignore all the internal stuff as thats all that PC does.

SHARE:
+ Post New Thread

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •