+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16
Windows Thread, Turn Off NumLock in Technical; I'm having some problems caused by the fact that NumLock is on by default - does anyone know of a ...
  1. #1
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,490
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76

    Turn Off NumLock

    I'm having some problems caused by the fact that NumLock is on by default - does anyone know of a way to change this globally?

  2. #2

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,266
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    342
    Take a look in the BIOS. There will probably be a setting in here somewhere.

  3. #3
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,490
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    Quote Originally Posted by Michael View Post
    Take a look in the BIOS. There will probably be a setting in here somewhere.
    I was hoping for a method that doesn't involve visiting every computer individually.

    Also, I think NumLock status also follows a user around in their profile, so people would probably undo my changes before I got round every computer.

  4. #4
    dgsmith's Avatar
    Join Date
    Nov 2007
    Location
    Merseyside, England
    Posts
    1,110
    Thank Post
    119
    Thanked 90 Times in 78 Posts
    Rep Power
    37
    Quote Originally Posted by Michael View Post
    Take a look in the BIOS. There will probably be a setting in here somewhere.
    Nick, we have this problem on our laptops (which then causes problems because letters/numers are on the same keys). If it's a CC3 problem, in "Global Workstation Settings" under "Logon Screen" there is an option to disable this at the logon screen (so it "should" fix any logon problems), though I don't know if this would help once logged in.

  5. #5
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,490
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    Exactly the problem I'm having, Dave. I've just found that RMMC setting, but it doesn't seem to be having any effect. I've set it to "disabled" and rebooted the PC a few times, but NumLock is still on.

  6. #6

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,266
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    342
    I'm pretty confident it isn't user or profile specific, but computer related.

    Edit: Take a look at this, but not tried it myself.
    Last edited by Michael; 26th March 2008 at 03:39 PM.

  7. #7
    Shwaa's Avatar
    Join Date
    Dec 2006
    Location
    Hampshire
    Posts
    14
    Thank Post
    1
    Thanked 4 Times in 3 Posts
    Rep Power
    16
    We use a startup script to apply a regkey that turns off the numlock on the logon screen. It doesn't affect the users own setting in their profile, ie the logon screen will always have the numlock turned off, but if the user logs in and the numlock is set to on in their profile, then it will turn on when they logon.

    Here is the key:

    Code:
    [HKEY_USERS\.DEFAULT\Control Panel\Keyboard]
    
    "InitialKeyboardIndicators"="0"

  8. Thanks to Shwaa from:

    enjay (26th March 2008)

  9. #8

    SYNACK's Avatar
    Join Date
    Oct 2007
    Posts
    11,245
    Thank Post
    882
    Thanked 2,744 Times in 2,318 Posts
    Blog Entries
    11
    Rep Power
    785
    @Michael

    Windows takes over control of the num lock off the bios when it starts up so the initial bios setting won't help as its only in effect before the windows HAL takes over.

  10. #9
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,490
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    Thanks Shwaa, that gets me part-way there. With your setting, I have managed to get it turned off on the logon screen, however it still comes back for users who have had it enabled previously.

    I tried the corresponding HKey_Current_User string, but that gets over-ridden by the setting in the users' roaming profiles.

  11. #10

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,266
    Thank Post
    242
    Thanked 1,575 Times in 1,254 Posts
    Rep Power
    342
    Thanks for that SYNACK. It's amazing how simple a function NumLock is that it's causing big problems NickJones is experiencing.

    If it's the case that profiles are overwriting your registry edit entry, then I suppose re-allocating new profiles to users is the only solution. However, if users re-enable NumLock, you're back to square one.

  12. #11
    Shwaa's Avatar
    Join Date
    Dec 2006
    Location
    Hampshire
    Posts
    14
    Thank Post
    1
    Thanked 4 Times in 3 Posts
    Rep Power
    16
    What happens if you apply the key to HKEY_CURRENT_USER in a logon script?

    If the logon scripts are run after the users profile is loaded, then it should work.

    They can still turn it back on, but at least then that is their own fault, as they started with it off.
    Last edited by Shwaa; 26th March 2008 at 04:26 PM.

  13. 2 Thanks to Shwaa:

    enjay (26th March 2008), leco (1st November 2008)

  14. #12
    enjay's Avatar
    Join Date
    Apr 2007
    Location
    Reading, Berkshire, UK
    Posts
    4,490
    Thank Post
    282
    Thanked 196 Times in 167 Posts
    Rep Power
    76
    Of course! Thanks Shwaa. I tried making that change to HKCU manually and then watching it get over-written, but of course setting it after the profile has loaded will un-do whatever is stored in the profile.

    Leaving people the ability to turn it back on is fine - our accountant would probably kill me if I took that away anyway!

  15. #13
    rocknrollstar's Avatar
    Join Date
    Jun 2008
    Location
    Hampshire
    Posts
    435
    Thank Post
    387
    Thanked 28 Times in 24 Posts
    Rep Power
    21
    How about using a program like KLOCKS Commandline Lock Keys Controller for NT4/W2K/XP to run at logon. We use it to make sure the caps lock is off.

  16. Thanks to rocknrollstar from:

    Griffo (13th January 2009)

  17. #14

    elsiegee40's Avatar
    Join Date
    Jan 2007
    Location
    Kent
    Posts
    10,047
    Thank Post
    1,860
    Thanked 2,320 Times in 1,711 Posts
    Rep Power
    824
    Turn off the NumLock on my desktop by default and you'd die! I use the number pad all the time!

    On laptops; it's a different matter!

  18. #15
    leco's Avatar
    Join Date
    Nov 2006
    Location
    West Yorkshire
    Posts
    2,026
    Thank Post
    595
    Thanked 125 Times in 119 Posts
    Rep Power
    42
    I have this issue with many of my laptop users, as they don't notice that NumLock is turned on, it would be very useful to know how to do it.

    As I haven't done anything like this before, could you give me an idea of how I write and run such a logon script, please? Where do I store and it and how do I implement it?



SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Why does Java turn the screen off
    By ITWombat in forum *nix
    Replies: 6
    Last Post: 22nd November 2010, 10:34 AM
  2. Monitor GPO turn Off
    By danIT in forum Windows
    Replies: 1
    Last Post: 16th November 2007, 10:38 AM
  3. Numlock on Laptops
    By Mintsoft in forum Windows
    Replies: 7
    Last Post: 16th March 2006, 02:06 PM
  4. !&$£ Numlock
    By Frazer in forum Windows
    Replies: 12
    Last Post: 11th November 2005, 10:49 AM
  5. Its now safe to turn your computer off
    By Furan in forum Windows
    Replies: 17
    Last Post: 18th October 2005, 09:07 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •