+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 20
Windows Thread, MS exchange webmail displayed as text. in Technical; After a slight PHP change, our webmail has started displaying as text only. When you log in the screen shows ...
  1. #1

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    MS exchange webmail displayed as text.

    After a slight PHP change, our webmail has started displaying as text only. When you log in the screen shows the root directory, with user as sub directories. If you click on your name, it takes you a text based version of you inbox.

    The blue blur at the side of the image is the list of the users.

    I believe it was from the php setting in iis. Any ideas?
    Attached Images Attached Images

  2. #2
    apearce's Avatar
    Join Date
    Feb 2008
    Location
    Birmingham
    Posts
    415
    Thank Post
    34
    Thanked 175 Times in 110 Posts
    Rep Power
    43
    You have't turned directory browsing on in IIS have you?

  3. #3

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,406
    Thank Post
    639
    Thanked 961 Times in 661 Posts
    Blog Entries
    2
    Rep Power
    324
    MSexChange doesn't run on PHP. What was the 'slight change' in PHP? Was it on the same IIS that serves MSexChange?

  4. #4

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    as far as i know i havent turned it on no. where would i find it if i had?

    Re-installed PHP, and did a couple of changes in IIS to run moodle, cant remember off the top of my head, will check.

  5. #5
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    So do you access exchange webmail from inside Moodle?
    Have you tried accessing Exchange directly to make sure it's OK? i.e. http://exchange-server/exchange/username

  6. #6

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    we dont use moodle for email, I was just looking into it. if i go directly, it just brings up a text version of my email, with inbox, sent and all my folders, which i can access. through outlook, email works fine too.

    directory browsing appears to be off.

  7. #7
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    Have a look at this link, it may help?
    http://www.mcse.ms/message1257955.html

  8. #8

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I tried

    "I just got over the same situation w/the help of Microsoft Tech support and
    one of the reasons our GUI wasn't displaying was because the ISAPI filter,
    "EXCHFILT.dll" wasn't loaded correctly for our default web site.
    Specifically, if you open "administrative tools/Internet Services Manager"
    and right-click on your default website, click on properties and then select
    the "ISAPI Filters" tab at the top of the "default web site properties" window
    you will see the filter called "EXCHFILT.dll" which can be ound in the
    Program Files\EXCHSRVR folder. Hope this helps to enlighten.

    The file wasnt there, got a copy and tried it but still nothing. and we allready have exchange sp1 installed.

  9. #9
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    Might be worth trying to restart IIS to see what happens?
    If nothing, then try rebooting the Exchange Server.
    Kinda primitive solution but well worth a try!

  10. #10

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Turn it off and on? First things i did.

  11. #11
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    Hmmm....OK.
    Maybe we should look at what changes you made to PHP.
    Can you describe what you did?

  12. #12

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    downloaded and extracted php to c:\php

    added C:\PHP to my path. in Environment Variables under system variables

    In iis: Added New Web Service Extension .PHP with C:\PHP\PHP5ISAPI.DLL to Required Files

    On Web Sites, added an Application Extension: C:\PHP\PHP5ISAPI.DLL as Executable and .PHP as Extension.

    In ISS the dll for .php was allready there, but in a different folder, which i forgot to make a note of before i replaced it with the new one in c:\php.

    then it stopped working.

  13. #13
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    Got this from the PHP site....

    "Make sure any user who needs to run a PHP script has the rights to run php.exe! IIS uses an anonymous user which is added at the time IIS is installed. This user needs rights to php.exe. Also, any authenticated user will also need rights to execute php.exe. And for IIS4 you need to tell it that PHP is a script engine."

    " You must set the cgi.force_redirect directive to 0. It defaults to 1 so be sure the directive isn't commented out (with ";") Like all directives, this is set in php.ini
    Because the default is 1, it's critical that you're 100% sure that the correct php.ini file is being read."

    " To be sure your php.ini is being read by PHP, make a call to phpinfo() and near the top will be a listing called Configuration File (php.ini). This will tell you where PHP is looking for php.ini and whether or not it's being read. If just a directory PATH exists than it's not being read and you should put your php.ini in that directory. If php.ini is included within the PATH than it is being read.

    If php.ini is being read and you're running PHP as a module, then be sure to restart your web server after making changes to php.ini"

    Check these settings and let me know what happens

  14. #14

    Join Date
    Sep 2006
    Posts
    36
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Still nothing. I'm 95% certain i was editing the correct php.ini

  15. #15
    GlennT's Avatar
    Join Date
    Sep 2006
    Location
    Zummmerzet!
    Posts
    249
    Thank Post
    19
    Thanked 17 Times in 16 Posts
    Rep Power
    20
    Have you double checked the permissions, especially "Anonymous User" in IIS?

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. Do you use SSL for Webmail?
    By pete in forum Wireless Networks
    Replies: 2
    Last Post: 31st July 2009, 04:14 PM
  2. Video not displayed through projector
    By roo20487 in forum Windows
    Replies: 11
    Last Post: 15th January 2008, 11:03 AM
  3. Vista Profile Displayed on 2k3 share
    By Scruff in forum Windows Vista
    Replies: 5
    Last Post: 18th June 2007, 12:02 AM
  4. Email Browser For Webmail Wanted.
    By tickmike in forum *nix
    Replies: 0
    Last Post: 15th February 2007, 08:49 PM
  5. Speed up LAN webmail access
    By mark in forum Windows
    Replies: 5
    Last Post: 4th January 2007, 04:52 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •