+ Post New Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 29
Windows Thread, HELP - I think I just screwed up! in Technical; Hi, I just thought I'd tidy up the AD and deleted some objects that I thought no longer existed - ...
  1. #1
    tazz's Avatar
    Join Date
    May 2007
    Location
    Notts
    Posts
    224
    Thank Post
    48
    Thanked 16 Times in 9 Posts
    Rep Power
    17

    HELP - I think I just screwed up!

    Hi, I just thought I'd tidy up the AD and deleted some objects that I thought no longer existed - I inherited this network two years ago.

    2 of these things were NTSRV1 and NTSERVER - we don't have any servers of that name so I deleted them. I was given a choice of demoting them as they were apparently DCs (but my 2 existing DCs still remain) but I chose an option along the lines of "this DC no longers exists and will never be used" or something.

    Since then it is taking eons for users to log on to workstations. It takes ages to get past "loading your personal settings...." Logging off is still dead quick though.

    Any tips will be most welcome!

  2. #2

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,843
    Thank Post
    583
    Thanked 2,162 Times in 987 Posts
    Blog Entries
    23
    Rep Power
    627

    Re: HELP - I think I just screwed up!

    Oh.
    Dear.
    Right what you need to do first is to ensure that none of the FSMO roles were assigned to the old servers and that AD is pointing to the current role holders.

    http://support.microsoft.com/kb/324801

    Clear DNS of any referances of them if you can and ensure that they are not still listed as forwarders etc. Then check that their computer accounts are removed. I have to be honest here, I've had AD die before and nothing ever brings it back. Even schema restores are never sucessful. Unfortuneately AD is not perfect and does break easily.

  3. #3
    tazz's Avatar
    Join Date
    May 2007
    Location
    Notts
    Posts
    224
    Thank Post
    48
    Thanked 16 Times in 9 Posts
    Rep Power
    17

    Re: HELP - I think I just screwed up!

    I love you Dos_Box!

    That worked - boy do I need to go on a course!!

  4. #4

    Join Date
    Sep 2006
    Location
    Essex
    Posts
    777
    Thank Post
    1
    Thanked 31 Times in 29 Posts
    Rep Power
    23

    Re: HELP - I think I just screwed up!

    Lucky Guy!

    I had to rebuild two DC's from a Syatem State Backup becuase someone did exactly what you did 3 days work!

    May I suggest that in future you consult edugoogle before you click OK in future.

    That click could have cost you your Job and the School money to fix it.

  5. #5
    tazz's Avatar
    Join Date
    May 2007
    Location
    Notts
    Posts
    224
    Thank Post
    48
    Thanked 16 Times in 9 Posts
    Rep Power
    17

    Re: HELP - I think I just screwed up!

    Thanks djm, 'nuff said.

  6. #6

    Join Date
    Sep 2006
    Location
    Essex
    Posts
    777
    Thank Post
    1
    Thanked 31 Times in 29 Posts
    Rep Power
    23

    Re: HELP - I think I just screwed up!

    Quote Originally Posted by tazz
    Thanks djm, 'nuff said.
    Sorry just read that back and it sounded very condescending… ops:

  7. #7
    Heebeejeebee's Avatar
    Join Date
    Nov 2006
    Location
    Intergalactic Cruise
    Posts
    1,050
    Thank Post
    68
    Thanked 75 Times in 59 Posts
    Rep Power
    34

    Re: HELP - I think I just screwed up!

    AD borked on us a few months ago and it took us 3 days to fix the servers and to go round all the machines and take them off the domain and put them back on again. (?) This was the only way we could get the machines to connect again after a System State restore.

    Still not found the reason why it dropped a server out of AD but apparently it does happen.

    HBJB

  8. #8

    Dos_Box's Avatar
    Join Date
    Jun 2005
    Location
    Preston, Lancashire
    Posts
    9,843
    Thank Post
    583
    Thanked 2,162 Times in 987 Posts
    Blog Entries
    23
    Rep Power
    627

    Re: HELP - I think I just screwed up!

    Quote Originally Posted by tazz
    I love you Dos_Box!

    That worked - boy do I need to go on a course!!
    I am glad, a borked AD is a heart stuttering affair at the best of times. Which bit fixed it BTW?

  9. #9
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,762
    Thank Post
    897
    Thanked 416 Times in 350 Posts
    Blog Entries
    12
    Rep Power
    86

    Re: HELP - I think I just screwed up!

    I've had an "Active directory is re-indexing" >> "re-indexing failed please reboot your server" on our main DC a while back. That was fun repairing

    Luckily you should always have 2 DC's in the school and I have learned to have them on simple workstations that can be easily fixed.

    There are lots of knowledge based articles on removing a DC from the schema and DNS, its not really a complicated process but can solve alot of problems.

  10. #10
    Heebeejeebee's Avatar
    Join Date
    Nov 2006
    Location
    Intergalactic Cruise
    Posts
    1,050
    Thank Post
    68
    Thanked 75 Times in 59 Posts
    Rep Power
    34

    Re: HELP - I think I just screwed up!

    Hmmm, here's something that I can't find by Googling: If one of your DCs has an issue with AD does that problem replicate to the others or do any others somehow know that it's borked and put a good copy back?

    HBJB

  11. #11
    zag
    zag is offline
    zag's Avatar
    Join Date
    Mar 2007
    Posts
    3,762
    Thank Post
    897
    Thanked 416 Times in 350 Posts
    Blog Entries
    12
    Rep Power
    86

    Re: HELP - I think I just screwed up!

    When mine went tits up the other DC was absolutely fine.

  12. #12
    tazz's Avatar
    Join Date
    May 2007
    Location
    Notts
    Posts
    224
    Thank Post
    48
    Thanked 16 Times in 9 Posts
    Rep Power
    17

    Re: HELP - I think I just screwed up!

    Changing the schema master role fixed it Dos_Box - thanks again.

    I'm a lucky gal BTW djm968!

  13. #13

    Join Date
    Sep 2006
    Location
    Essex
    Posts
    777
    Thank Post
    1
    Thanked 31 Times in 29 Posts
    Rep Power
    23

    Re: HELP - I think I just screwed up!

    Quote Originally Posted by tazz
    Changing the schema master role fixed it Dos_Box - thanks again.

    I'm a lucky gal BTW djm968!
    Sorry tazz........ I always put my foot in it! ops:

  14. #14
    Grommit's Avatar
    Join Date
    Sep 2006
    Location
    Weston-super-Mare
    Posts
    1,335
    Thank Post
    31
    Thanked 54 Times in 31 Posts
    Rep Power
    24

    Re: HELP - I think I just screwed up!

    One question......

    If the DC with the FMSO roles on crashes can the users still log on ?

  15. #15

    Join Date
    Sep 2006
    Location
    Essex
    Posts
    777
    Thank Post
    1
    Thanked 31 Times in 29 Posts
    Rep Power
    23

    Re: HELP - I think I just screwed up!

    If the the DC is also the Global Catalog then not normally no. However you should not have all your eggs in one basket so to speak ie. split the rolls accross other DC's

SHARE:
+ Post New Thread
Page 1 of 2 12 LastLast

Similar Threads

  1. LEA Server Upgrade Screwed website!
    By DSapseid in forum Web Development
    Replies: 2
    Last Post: 18th December 2007, 01:31 PM
  2. Exchange 2003 - screwed
    By Gatt in forum Windows
    Replies: 1
    Last Post: 20th July 2007, 08:49 AM
  3. Squid Screwed
    By Gatt in forum Wireless Networks
    Replies: 11
    Last Post: 10th October 2006, 02:12 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •