+ Post New Thread
Results 1 to 9 of 9
Windows Thread, IE10 Homepage via GPP - every other setting works apart from home page? in Technical; I've been trying to configure a group policy preference to set the homepage in IE10. There have been a few ...
  1. #1

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    160
    Thanked 152 Times in 116 Posts
    Rep Power
    49

    IE10 Homepage via GPP - every other setting works apart from home page?

    I've been trying to configure a group policy preference to set the homepage in IE10. There have been a few other threads about this I know but none have helped.
    The thing is, the preferences are definately applying, as if I tick a random option anywhere else and then check it on a client, it has worked. It is only the homepage that will not work - it insists on defaulting to about:blank
    I know about pressing F6 to make the line green underneath the setting, which I have done (screenshot attached)

    I'm setting the GPO on our 2012 DC, domain level is still only 2008R2 (though that shouldnt matter surely?) and clients are Win 7 x86

    What am I doing wrong?

    ie10.PNG

  2. #2
    tomgrindle's Avatar
    Join Date
    Oct 2010
    Location
    Gloucestershire
    Posts
    210
    Thank Post
    53
    Thanked 18 Times in 15 Posts
    Rep Power
    22
    When I tried using Group Policy it didn't work for me either.

    I ended up importing the following into the Registry at login:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
    "Start Page"="http://www.google.co.uk"
    "Default_Page_URL"="http://www.google.co.uk"
    Tom

  3. #3
    tomgrindle's Avatar
    Join Date
    Oct 2010
    Location
    Gloucestershire
    Posts
    210
    Thank Post
    53
    Thanked 18 Times in 15 Posts
    Rep Power
    22
    Did it by having saved as a .reg file and ran the following script in our login.bat:

    objShell.Run("cmd.exe /c regedit.exe /s " & AUP & "\\domain.local\netlogon\InternetSettingsStaff.reg ")

  4. #4

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    160
    Thanked 152 Times in 116 Posts
    Rep Power
    49
    Thanks. I've tried adding those registry entries using a GPP registry option which should work as well as a script but still it gets set to about:blank. I have a suspicion that something else is setting this!

  5. #5

    Join Date
    Jul 2006
    Location
    London
    Posts
    2,962
    Thank Post
    160
    Thanked 152 Times in 116 Posts
    Rep Power
    49
    Ok this is driving me insane - why does the GPP registry setting not apply??? I've even created a brand new GPO with just this setting and applied it to another OU but no, it will not change the settings in HKCU. No errors are logged. Changing settings in HKLM always works fine, why not HKCU? Tried update, create and replace, none work.

  6. #6

    Join Date
    Jan 2007
    Posts
    988
    Thank Post
    14
    Thanked 48 Times in 28 Posts
    Rep Power
    25
    Did you ever sort this? This is happening to us too despite trying the registry keys!

  7. #7
    InterwebsGuy's Avatar
    Join Date
    Jan 2011
    Posts
    237
    Thank Post
    61
    Thanked 26 Times in 26 Posts
    Rep Power
    12
    I got this to work, I had to use the GPP Preference Items tool.
    Enable and Disable Settings in a Preference Item
    Edit: Just re-read your original post. I had the same problem, but the preference item setting is definitely what made it work.
    Last edited by InterwebsGuy; 6th November 2013 at 09:46 AM.

  8. #8

    Join Date
    Feb 2008
    Location
    Leeds
    Posts
    19
    Thank Post
    1
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Any Chance you used MDT to deploy your images. Is about:blank the homepage your task sequence sets. I had similar problem. Just showed whatever homepage was set on my task sequence. But after a while I figured it set the homepage on second login just not the first

  9. #9

    Join Date
    Jan 2007
    Posts
    988
    Thank Post
    14
    Thanked 48 Times in 28 Posts
    Rep Power
    25
    We do use MDT, that did go some way to explaining it however not much use to resolving the issue on the 300+ PCs already imaged!

    But just this morning I've found a fix!

    As above you create a GPP for IE8 under User Configuration > GPP > Control Panel Settings > Internet Settings of your relevant group policy putting in the relevant homepage (And pressing F5 to make a green line appear under it before clicking OK!).

    Then you go to C:\windows\sysvol\sysvol\yourdomain.ac.uk\Policies and search for InternetSettings.xml. Once found, open up the file in notepad and modify the line type="VERSION" gte="1" min="8.0.0.0" max="11.1.0.0" to that (so the max is 11).

    Clint Boessen's Blog: Changing Home Page for Internet Explorer 10 through Group Policy

SHARE:
+ Post New Thread

Similar Threads

  1. Set homepage Via Workgroup Manager
    By Mark182 in forum Mac
    Replies: 1
    Last Post: 4th October 2013, 01:12 PM
  2. Replies: 2
    Last Post: 8th October 2012, 12:30 PM
  3. Getting the default printer working Via GPP
    By penfold in forum Windows Server 2008 R2
    Replies: 0
    Last Post: 31st July 2012, 10:20 AM
  4. Replies: 0
    Last Post: 8th August 2011, 02:00 AM
  5. setting safari homepage via xserve
    By goodhead in forum Mac
    Replies: 3
    Last Post: 4th April 2008, 11:34 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •