+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 32
Windows Thread, RM Ones (with RM pre-installed XP) do not appear in WSUS in Technical; Yes, WSUS uses WinHTTP to download updates. WinHTTP proxy settings are independent from IE. You must use the 'proxycfg' tool ...
  1. #16

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Yes, WSUS uses WinHTTP to download updates. WinHTTP proxy settings are independent from IE. You must use the 'proxycfg' tool to configure it.

  2. #17
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Thanks, I've used proxycfg to check the settings on my working WSUS clients, and they don't have the proxy configured. I tried configuring a proxy for the RM ones, but this still doesn't work :?

  3. #18

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    In my opinion then meastaugh1, it's clearly something to do with the RM image these none CC3 machines come with. If you already have a group of machines which work happily with WSUS, then I cannot see what else it could be.

    It definitely isn't a hardware limitation, but probably some custom RM registry hacks which have been implemented. Out of curiosity, can you visit Windows Update or Microsoft Update on these machines? I would also check services on the workstations which are required by Automatic Updates to function.

    If all else fails, you could format these machines and re-install using a standard OEM disc. This would then remove any RM customisations and should connect to WSUS instantly. I know that's asking alot, but if RM won't help you, I cannot see what else you can try.

  4. #19
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Yeah I'm afriad we might have to do that Michael. It's just frustrating that it should work, and there's no good reason for it not to.

  5. #20

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    As I said from the beginning, that's RM for you... I agree with you 100% that it should just work, however on a positive, formatting should do the trick and obtaining drivers shouldn't be a problem.

    I've come to the conclusion that RM will never support WSUS, because Windows Updates are a major source of revenue for them. They get a collection of updates, roll them up into one larger package then sell you that package or Service Release.

    You're now in exactly the same position as I am, as now I have to administer two patching systems at the one school. Good luck

  6. #21

    webman's Avatar
    Join Date
    Nov 2005
    Location
    North East England
    Posts
    8,401
    Thank Post
    637
    Thanked 961 Times in 661 Posts
    Blog Entries
    2
    Rep Power
    319

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    As I've said previously, Michael, I believe RM's motives behind not supporting WSUS is because they would have to clean up after Microsoft's mistakes and software that is incompatible with the way a CC3 network runs.

    What they do do, however, is to test Microsoft's "updates" for their compatability on a CC3 network, and release them (with RM changes if necessary) in a format that is compatible with CC3.

  7. #22

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    I would put MS Network Monitor 3.1 on the box and set it capturing immediately before running the client diag util. Then grope through the results to see exactly what it can't find, throw the URL in IE and see what that says.

  8. #23

    Geoff's Avatar
    Join Date
    Jun 2005
    Location
    Fylde, Lancs, UK.
    Posts
    11,803
    Thank Post
    110
    Thanked 583 Times in 504 Posts
    Blog Entries
    1
    Rep Power
    224

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Also enable logging on the WSUS IIS web server. You can find out where it's tripping up from that too.

  9. #24
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Ok thanks both, will give it a go.

  10. #25

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Any update meastaugh1? The suggestions put forward are all good in trying to determine the source of the problem, however it is intriguing that these machines which aren't controlled by CC3 don't just work as you say.

    @webman - I don't wish to argue, so we'll just have to agree to disagree. Let's concentrate on supporting meastaugh1.

  11. #26

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    it is intriguing that these machines which aren't controlled by CC3 don't just work as you say
    It is, but could be something as simple as which hotfixes have or haven't been pre-installed i.e. nothing especially Machiavellian or stupid on RM's part.

  12. #27

    Michael's Avatar
    Join Date
    Dec 2005
    Location
    Birmingham
    Posts
    9,262
    Thank Post
    242
    Thanked 1,568 Times in 1,250 Posts
    Rep Power
    340

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    I didn't think WSUS was hotfix dependant, so long as Automatic Updates is enabled, a WSUS server has been specified in a GPO (easy way) and you're using Windows 2000 SP3 or later, then you're good to go.

    RM's official position is that they do not support WSUS, however at the one school I support, their admin workstations are HP - so I haven't had the problem meastaugh1 has.
    I do suspect it's the RM image the machines come with, as RM of course want you to use CC3. It wouldn't surprise me if it is some reg hack which has been implemented, which is why I suggested formatting.

  13. #28
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    No, not yet. I've had a quick look through the client and server logs again.

    Although they have SP2, I wanted to try and re-install the WSUS client. It's WUAU22.msi isn't it? Is that in the main WSUS server installation download as I can't seem to find it.

    I'll try and give the netmon and enable any verbose server logging tomorrow. Thanks

  14. #29

    Join Date
    Jan 2006
    Location
    Surburbia
    Posts
    2,178
    Thank Post
    74
    Thanked 307 Times in 243 Posts
    Rep Power
    115

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    To get the latest, greatest WUA v3 (31st-Jul-2007) read here:

    msdn2.microsoft.com/en-us/library/aa387285.aspx

    And if that fixes a test box you might want to compare the versions of say "wuauclt.exe" with an unpatched RM box.

  15. #30
    meastaugh1's Avatar
    Join Date
    Jul 2006
    Location
    London/Hertfordshire
    Posts
    890
    Thank Post
    69
    Thanked 85 Times in 70 Posts
    Rep Power
    32

    Re: RM Ones (with RM pre-installed XP) do not appear in WSUS

    Success at last! As suspected, the RM image is to blame. Downloading the client from http://download.windowsupdate.com/v6...gent20-x86.exe as mentioned in http://msdn2.microsoft.com/en-us/library/aa387285.aspx does the trick.

    Thanks all for your advice.

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 8th November 2006, 09:57 AM
  2. Multiple SQL Apps on same server with WSUS installed
    By ITWombat in forum Educational Software
    Replies: 3
    Last Post: 8th May 2006, 07:14 AM
  3. ok got irm installed
    By russdev in forum Web Development
    Replies: 0
    Last Post: 6th March 2006, 09:17 AM
  4. USB drives on RIS installed machines
    By ChrisH in forum Hardware
    Replies: 3
    Last Post: 14th February 2006, 11:19 AM
  5. vista beta anyone got it installed yet?
    By russdev in forum Windows
    Replies: 16
    Last Post: 15th August 2005, 04:46 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •