+ Post New Thread
Results 1 to 3 of 3
Windows Thread, GPO: Change Language/Regional Settings? in Technical; Hi there for some reason all my Win2k machines are defaulting to US keyboard, is there any way to set ...
  1. #1
    Samson's Avatar
    Join Date
    Mar 2007
    Location
    Wales
    Posts
    201
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    17

    GPO: Change Language/Regional Settings?

    Hi there

    for some reason all my Win2k machines are defaulting to US keyboard, is there any way to set this to UK via GPO?

  2. #2
    Samson's Avatar
    Join Date
    Mar 2007
    Location
    Wales
    Posts
    201
    Thank Post
    7
    Thanked 1 Time in 1 Post
    Rep Power
    17

    Re: GPO: Change Language/Regional Settings?

    This is really bugging me!

  3. #3

    Join Date
    Nov 2006
    Location
    Reading, UK
    Posts
    487
    Thank Post
    30
    Thanked 14 Times in 8 Posts
    Rep Power
    18

    Re: GPO: Change Language/Regional Settings?

    A quick Google came up with this:

    Code:
    CLASS USER 
      CATEGORY "Custom Settings" 
         CATEGORY "Keyboard Layout" 
            POLICY "Set UK Keyboard Layout" 
               KEYNAME "Keyboard Layout\Preload" 
               VALUENAME 1 
               VALUEON 00000809 
               VALUEOFF "" 
            END POLICY ;Set UK Keyboard Layout 
         END CATEGORY ;Keyboard Layout 
      END CATEGORY ;Custom Settings
    INSTRUCTIONS
    ======================
    Step 1: Save the above code as keyboard.adm file into the folder C:Windows\inf on the server

    Step 2: Create and link a new GPO (call it something like “Keyboard Layout”)

    Step 3: Edit the Keyboard Layout GPO

    Step 4: In the Group Policy Editor Window; under User Configuration, right click Administrative Templates and choose Add Template

    Step 5: select the keyboard.adm template and click OK until you are returned to the Group Policy Editor window

    Step 6: with Templates still selected on the left hand side, select view from the toolbar, and filtering

    Step 7: make sure the bottom 2 tick boxes (“only show configured policy settings” and “only show policy settings that can be fully managed”) are un-ticked

    Step 8: Browse to the following setting (using the view on the left hand side) User Configuration > Administrative Templates > Custom Settings > Keyboard Layout

    Step 9: Enable the policy setting listed on the right hand side (“Set UK Keyboard Layout”)

  4. 7 Thanks to plock:

    AngryTechnician (9th May 2012), CHR1S (7th November 2008), Duane_Dibbley (7th July 2010), Joanne (4th November 2013), ngreenwood (13th August 2009), Rydra (29th November 2010), stitch (14th July 2009)

SHARE:
+ Post New Thread

Similar Threads

  1. Regional Language Settings
    By sLiDeR in forum Windows
    Replies: 3
    Last Post: 31st August 2007, 10:56 PM
  2. Windows Regional Settings
    By Jon in forum Windows
    Replies: 3
    Last Post: 19th January 2007, 12:06 PM
  3. default language and regional settings
    By MManjra in forum ICT KS3 SATS Tests
    Replies: 2
    Last Post: 20th March 2006, 02:30 PM
  4. Replies: 4
    Last Post: 22nd February 2006, 11:10 AM
  5. Printer Settings / Language Bar - profile
    By spike in forum Windows
    Replies: 2
    Last Post: 17th February 2006, 09:54 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •