+ Post New Thread
Results 1 to 4 of 4
Windows Thread, Deploying a Nullsoft Installer program in Technical; Hi All, I`m trying to create a deployable package for some software called Quantum GIS Desktop (available at Welcome to ...
  1. #1

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    169
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12

    Deploying a Nullsoft Installer program

    Hi All,

    I`m trying to create a deployable package for some software called Quantum GIS Desktop (available at Welcome to the Quantum GIS Project). I have figured out the installer is the Nullsoft installer and from previous experience I cannot get these to deploy as is. So far I have tried wrapping the installer in an MSI using Witem Installer but half way through the Installation I get an error saying another installation is already running (at this point is is running the C redistributable) so I dont think it will deploy correctly because of this.

    I have also tried creating an MSI using pre and post scan with WinInstallLe it creates the MSI but when I try and run it I get an error saying it encountered an unexpected error error code: 2731.

    Im unsure of where I else I can go to package this anyone any ideas?

  2. #2
    themightymrp's Avatar
    Join Date
    Dec 2009
    Location
    Leeds, West Yorkshire
    Posts
    1,221
    Thank Post
    216
    Thanked 227 Times in 196 Posts
    Rep Power
    73
    Have you tried calling the installer from a script using /S (must be capital letter!), that should do a silent install for Nullsoft installers

  3. #3

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    169
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Yes I had the /S command in there. I think I have sorted it, I was down to the order in which it installs, I changed the order in which it installs so that it installs after the initial msi Installer has finished, seems to have solved the issue. well does when I do a manual install.

    I`m just going to try an install over the network

  4. #4

    Join Date
    Nov 2008
    Location
    Derby, UK
    Posts
    169
    Thank Post
    0
    Thanked 3 Times in 3 Posts
    Rep Power
    12
    Just confirmed it installs over the network now so the issue was due to the wrapped Executable was trying to start its installed before the the MSI completed and it obviously doesnt like to installs running at once.

    So changed the custom action order to only start after the install completes.

SHARE:
+ Post New Thread

Similar Threads

  1. Installing programs without admin rights!
    By HTCIT in forum Windows 7
    Replies: 3
    Last Post: 11th June 2010, 10:24 AM
  2. [SCCM 2007] Deploying Win7 via Advertised programs and using USMT
    By msnriggs in forum O/S Deployment
    Replies: 0
    Last Post: 20th January 2010, 05:14 AM
  3. Uninstalling windows installer programs !!!
    By dolmandj in forum Windows
    Replies: 4
    Last Post: 18th January 2010, 06:28 PM
  4. Replies: 9
    Last Post: 29th September 2008, 03:29 PM
  5. Deploying 7zip silent installers
    By edie209 in forum Windows
    Replies: 6
    Last Post: 10th November 2006, 06:23 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •