+ Post New Thread
Results 1 to 7 of 7
Windows Thread, Hayulp - My Docs defauting to mandatory users' in Technical; Anyone give me a quick pointer to the solution for this? Users home folders are mapped to \<server>\userhome$\<username> What they're ...
  1. #1
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Hayulp - My Docs defauting to mandatory users'

    Anyone give me a quick pointer to the solution for this?

    Users home folders are mapped to \\<server>\userhome$\<username>

    What they're all getting are the setup mandatory users home folder of \\<server>\userhome$\mpm

    Their docs are there showing as a drive in My Computer as usual, just the desktop shortcut and the default save location have changed to 'mpm'.

  2. #2

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,058
    Thank Post
    888
    Thanked 1,731 Times in 1,494 Posts
    Blog Entries
    12
    Rep Power
    454

    Re: Hayulp - My Docs defauting to mandatory users'

    If you get rid of that shortcut put my documents shortcut there and set up folder redirection in the group policy. That will work, it will take them to there home folders.

  3. #3
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: Hayulp - My Docs defauting to mandatory users'

    Folder redirection is set up to Basic > create a folder for each user under the root path

    This hasn't changed since last year - but the My Docs location has!

  4. #4

    FN-GM's Avatar
    Join Date
    Jun 2007
    Location
    UK
    Posts
    16,058
    Thank Post
    888
    Thanked 1,731 Times in 1,494 Posts
    Blog Entries
    12
    Rep Power
    454

    Re: Hayulp - My Docs defauting to mandatory users'

    Have you altered the settings on the folder redirection?

  5. #5
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Hayulp - My Docs defauting to mandatory users'

    That will probably be the permissions in the user hive. (every join in) When you copy a profile, you must use the GUI facility and change the permissions to use to Everyone. If you don't do this, then however created the profile will be the only one to have the write permissions into the user hive to redirect the folders.

    You can manually change the permissions in a user hive by loading the NTUSER.DAT into REGEDIT. The loaded hive will appear under the HKEY_USERS hive with whatever name you specify when you load it. You can then change the permissions on the loaded tree. Remember to unload the hive before exiting from REGEDIT or it can cause problems.

  6. #6
    mark's Avatar
    Join Date
    Jun 2005
    Posts
    3,966
    Thank Post
    248
    Thanked 49 Times in 45 Posts
    Blog Entries
    2
    Rep Power
    46

    Re: Hayulp - My Docs defauting to mandatory users'

    Ah, thanks ajb - I'll try that.

    I'd renamed the dc and reset all the locations in every user so I guess that's where my permissions error is occurring.

  7. #7
    ajbritton's Avatar
    Join Date
    Jul 2005
    Location
    Wandsworth
    Posts
    1,632
    Thank Post
    23
    Thanked 75 Times in 45 Posts
    Rep Power
    34

    Re: Hayulp - My Docs defauting to mandatory users'

    Must confess that if the profile was working previously, I can't really see why the permissions would have changed.

    If it turns out not to be permissions, it might be worth manually setting the entries under "HKCU\Software\Microsoft\Windows\CurrentVersion\Ex plorer\User Shell Folders" (in the NTUSER.DAT registry of course) back to their default values

    eg
    Desktop: %USERPROFILE%\Desktop
    Personal: %USERPROFILE%\My Documents
    My Pictures: %USERPROFILE%\My Documents\My Pictures

    You get the general idea. It may be that because the original location no longer exists at \\(servername)\(sharename)\mpm$, Windows can't do a redirect as it knows it would not be able to copy the existing files.

SHARE:
+ Post New Thread

Similar Threads

  1. Problems with My Docs Sync on laptop.
    By wadeeuk in forum How do you do....it?
    Replies: 6
    Last Post: 13th November 2007, 11:00 PM
  2. BAD dotNet docs
    By PiqueABoo in forum Coding
    Replies: 1
    Last Post: 10th November 2007, 02:54 PM
  3. My Docs access problem
    By Ste_Harve in forum Windows
    Replies: 2
    Last Post: 30th August 2007, 12:32 PM
  4. Replies: 4
    Last Post: 15th August 2007, 05:36 PM
  5. Stopping word docs opening in IE7
    By mattx in forum Windows
    Replies: 4
    Last Post: 4th July 2007, 10:39 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •