Just tried to install this on Windows Vista and got the following error:

Quote Originally Posted by PIC-Logicator Setup Error
The operating system is not adequate for running Economatics PIC-Logicator Version 2.
Yet the old one works fine! (V 1.51!)