+ Post New Thread
Results 1 to 4 of 4
Windows Server 2012 Thread, Help with Logon script in Technical; Hi all, I am moving from a server 2003 domain to a 2012r2 all is going well apart from i ...
  1. #1

    Join Date
    Aug 2011
    Location
    Lincolnshire
    Posts
    88
    Thank Post
    10
    Thanked 2 Times in 1 Post
    Rep Power
    22

    Help with Logon script

    Hi all,
    I am moving from a server 2003 domain to a 2012r2 all is going well apart from i have a script to start a small .exe when the user logs on. I have set this up the same way i did on the 2003 box and the script runs but the .exe wont start. I have run gpresult which tells me the script it running and if i run the script manually after the user has logged on the .exe will start. Can anyone please help?

  2. #2
    nickbro's Avatar
    Join Date
    Jul 2010
    Location
    Gilwern, Wales
    Posts
    3,564
    Thank Post
    38
    Thanked 509 Times in 439 Posts
    Rep Power
    114
    If it's a script to start a program you could try using the Run these programs at user logon group policy instead.

    Or it's something to do with Asynchronously running logon scripts

    q12.PNG

  3. Thanks to nickbro from:

    kai91 (16th June 2014)

  4. #3
    Sephiroth's Avatar
    Join Date
    Mar 2009
    Location
    The Ninth Circle
    Posts
    109
    Thank Post
    11
    Thanked 20 Times in 20 Posts
    Rep Power
    22
    +1 for 'Run these programs at user logon'. I tried scripting Papercut to run at logon. Turns out that GP is much more reliable. I would also look to move everything else to GP as most things needed at logon are not options in GP. Since rolling out 2012 R2 I have decommissioned my logon script in favour of GP options with group level targeting.

  5. Thanks to Sephiroth from:

    kai91 (16th June 2014)

  6. #4

    Join Date
    Aug 2011
    Location
    Lincolnshire
    Posts
    88
    Thank Post
    10
    Thanked 2 Times in 1 Post
    Rep Power
    22
    I have put the .exe in the run at logon gpo setting and it worked first time.
    Thanks for the help!

SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 23
    Last Post: 13th November 2013, 01:29 PM
  2. Replies: 6
    Last Post: 4th March 2012, 09:40 AM
  3. Help with Backup Script
    By soze in forum Scripts
    Replies: 5
    Last Post: 18th June 2008, 12:12 AM
  4. Help with KIX script please
    By salan in forum Windows
    Replies: 8
    Last Post: 8th November 2007, 06:55 PM
  5. Stupid CMD error with logon script
    By tarquel in forum Windows
    Replies: 37
    Last Post: 14th June 2006, 09:07 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •