+ Post New Thread
Results 1 to 14 of 14
Windows Server 2012 Thread, Windows Server Update Services in Technical; I just wondered if anyone has set-up Windows Server Update Services on server 2012? If so, is there anything specific ...
  1. #1

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Windows Server Update Services

    I just wondered if anyone has set-up Windows Server Update Services on server 2012? If so, is there anything specific to look out for compared with older server operating systems?

    I've read this article and wondered if the the steps are the same as it doesn't mention Server 2012 under the 'applies to:'.

    Windows Server Update Services 3.0 SP2 Step By Step Guide

    I've not set this up before so I am reluctant to go ahead before doing a little bit of research.

    Any help or advice would be appreciated.

    Andy

  2. #2

    Join Date
    Jul 2009
    Posts
    594
    Thank Post
    53
    Thanked 111 Times in 96 Posts
    Rep Power
    69
    the default port is 8530 rather than 80 on server 2012/2012r2 (point your clients to http://wsusserver:8530 rather than http://wsusserver:80 in GP)

    Also a good guide here (Use the 2008R2 guide as it's pretty much the same in 2012+)

  3. Thanks to computer_expert from:

    andyk (8th April 2014)

  4. #3

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Perfect, cheers @computer_expert.

    Andy

  5. #4

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Sorry guys one question. Do you install this on your domain controller? The server that I am planning to install this on currently has active directory, file server, dns and dhcp roles.

  6. #5

    Norphy's Avatar
    Join Date
    Jan 2006
    Location
    Harpenden
    Posts
    2,504
    Thank Post
    57
    Thanked 350 Times in 270 Posts
    Blog Entries
    6
    Rep Power
    129
    You can but it's generally considered best practice not to.

  7. Thanks to Norphy from:

    andyk (8th April 2014)

  8. #6
    rich_tech's Avatar
    Join Date
    Mar 2011
    Location
    Wales
    Posts
    1,120
    Thank Post
    134
    Thanked 144 Times in 125 Posts
    Rep Power
    66
    I wouldnt install that on the DC, as said its not recommended, keep your DC to essential stuff only really.

  9. #7
    ricki's Avatar
    Join Date
    Jul 2005
    Location
    uk
    Posts
    1,475
    Thank Post
    20
    Thanked 164 Times in 157 Posts
    Rep Power
    52
    Dont you need the fully qualied domain name as well as the port eg name.domainname.local

  10. #8


    Join Date
    Mar 2009
    Location
    Leeds
    Posts
    6,820
    Thank Post
    231
    Thanked 890 Times in 765 Posts
    Rep Power
    302
    Quote Originally Posted by ricki View Post
    Dont you need the fully qualied domain name as well as the port eg name.domainname.local
    never have server name only seems fine
    Quote Originally Posted by rich_tech View Post
    I wouldnt install that on the DC, as said its not recommended, keep your DC to essential stuff only really.
    i run it on dcs all the time as only usually have one server just be aware you need to do a bit of finagling on 2012 for it to run on a dc or it will fail say it needs a reboot for ever more

  11. #9

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for all of your help. I've installed it following this excellent guide onto an old Server which is no longer a DC. It doesn't have any other roles either. Installation went smoothly. I'm now just waiting for it to synchronise for the first time.
    Last edited by andyk; 9th April 2014 at 01:26 PM.

  12. #10

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    So most Windows 7 computers have been discovered using WSUS, however, some windows 7 machines are giving me an 80244017 error.

    Any help would be great on why some machines are not reporting to WSUS.
    Last edited by andyk; 14th April 2014 at 02:58 PM.

  13. #11

    AngryTechnician's Avatar
    Join Date
    Oct 2008
    Posts
    3,730
    Thank Post
    698
    Thanked 1,212 Times in 761 Posts
    Rep Power
    395
    My first recommendation when clients aren't working right with WSUS is to check the C:\Windows\WindowsUpdate.log file on the offending machines. That should have considerably more detail about what's going on.

  14. #12
    free780's Avatar
    Join Date
    Sep 2012
    Posts
    1,068
    Thank Post
    45
    Thanked 86 Times in 81 Posts
    Rep Power
    23
    It depends on your group policy. This is what I found when installing it on Server 2012.

    WSUS on server 2012 uses the following account/
    NT SERVICE\MSSQL$MICROSOFT##WID
    As the account for the Windows Internal Database.
    It fails to add this to the Log on as a service (particularly if group policy is pushing out settings)

    Add NT SERVICE\ALL SERVICES to the logon as a service right. See "MSSQL$MICROSOFT##WID service was unable to log on as NT SERVICE\MSSQL$MICROSOFT##WID" error when you install WID in Windows Server 2012 .

  15. #13

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for this.

    Here is some info from the update log:

    2014-04-14 14:08:21:171 1000 9a8 AU Triggering AU detection through DetectNow API
    2014-04-14 14:08:21:171 1000 9a8 AU Triggering Online detection (interactive)
    2014-04-14 14:08:21:171 1000 d70 AU #############
    2014-04-14 14:08:21:171 1000 d70 AU ## START ## AU: Search for updates
    2014-04-14 14:08:21:171 1000 d70 AU #########
    2014-04-14 14:08:21:173 1000 d70 AU <<## SUBMITTED ## AU: Search for updates [CallId = {B4EB6A23-7585-47CB-B2A4-837F7303D3C0}]
    2014-04-14 14:08:21:174 1000 f94 Agent *************
    2014-04-14 14:08:21:174 1000 f94 Agent ** START ** Agent: Finding updates [CallerId = AutomaticUpdates]
    2014-04-14 14:08:21:174 1000 f94 Agent *********
    2014-04-14 14:08:21:174 1000 f94 Agent * Online = Yes; Ignore download priority = No
    2014-04-14 14:08:21:174 1000 f94 Agent * Criteria = "IsInstalled=0 and DeploymentAction='Installation' or IsPresent=1 and DeploymentAction='Uninstallation' or IsInstalled=1 and DeploymentAction='Installation' and RebootRequired=1 or IsInstalled=0 and DeploymentAction='Uninstallation' and RebootRequired=1"
    2014-04-14 14:08:21:174 1000 f94 Agent * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
    2014-04-14 14:08:21:174 1000 f94 Agent * Search Scope = {Machine}
    2014-04-14 14:08:21:202 1000 f94 Setup Checking for agent SelfUpdate
    2014-04-14 14:08:21:203 1000 f94 Setup Client version: Core: 7.6.7600.256 Aux: 7.6.7600.256
    2014-04-14 14:08:21:203 1000 f94 Misc Validating signature for C:\Windows\SoftwareDistribution\SelfUpdate\wuident .cab:
    2014-04-14 14:08:21:206 1000 f94 Misc Microsoft signed: Yes
    2014-04-14 14:08:21:530 1000 f94 Misc Validating signature for C:\Windows\SoftwareDistribution\SelfUpdate\wuident .cab:
    2014-04-14 14:08:21:535 1000 f94 Misc Microsoft signed: Yes
    2014-04-14 14:08:21:538 1000 f94 Misc Validating signature for C:\Windows\SoftwareDistribution\SelfUpdate\wsus3se tup.cab:
    2014-04-14 14:08:21:544 1000 f94 Misc Microsoft signed: Yes
    2014-04-14 14:08:21:550 1000 f94 Misc Validating signature for C:\Windows\SoftwareDistribution\SelfUpdate\wsus3se tup.cab:
    2014-04-14 14:08:21:556 1000 f94 Misc Microsoft signed: Yes
    2014-04-14 14:08:21:569 1000 f94 Setup Determining whether a new setup handler needs to be downloaded
    2014-04-14 14:08:21:569 1000 f94 Setup SelfUpdate handler is not found. It will be downloaded
    2014-04-14 14:08:21:569 1000 f94 Setup Evaluating applicability of setup package "WUClient-SelfUpdate-ActiveX~31bf3856ad364e35~amd64~~7.6.7600.256"
    2014-04-14 14:08:22:172 1000 f94 Setup Setup package "WUClient-SelfUpdate-ActiveX~31bf3856ad364e35~amd64~~7.6.7600.256" is already installed.
    2014-04-14 14:08:22:172 1000 f94 Setup Evaluating applicability of setup package "WUClient-SelfUpdate-Aux-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.256"
    2014-04-14 14:08:22:194 1000 f94 Setup Setup package "WUClient-SelfUpdate-Aux-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.256" is already installed.
    2014-04-14 14:08:22:194 1000 f94 Setup Evaluating applicability of setup package "WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.256"
    2014-04-14 14:08:22:219 1000 f94 Setup Setup package "WUClient-SelfUpdate-Core-TopLevel~31bf3856ad364e35~amd64~~7.6.7600.256" is already installed.
    2014-04-14 14:08:22:219 1000 f94 Setup SelfUpdate check completed. SelfUpdate is NOT required.
    2014-04-14 14:08:22:264 1000 f94 PT +++++++++++ PT: Synchronizing server updates +++++++++++
    2014-04-14 14:08:22:264 1000 f94 PT + ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://servernameremoved/ClientWebService/client.asmx
    2014-04-14 14:08:22:331 1000 f94 PT WARNING: Cached cookie has expired or new PID is available
    2014-04-14 14:08:22:331 1000 f94 PT Initializing simple targeting cookie, clientId = bb5162d3-3467-4f57-885b-6bdfedafc344, target group = , DNS name = computer-name-removed.servernameremoved.local
    2014-04-14 14:08:22:331 1000 f94 PT Server URL = http://servernameremoved/SimpleAuthW...impleAuth.asmx
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: GetAuthorizationCookie failure, error = 0x80244017, soap client error = 10, soap error code = 0, HTTP status code = 401
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: Failed to initialize Simple Targeting Cookie: 0x80244017
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: PopulateAuthCookies failed: 0x80244017
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: RefreshCookie failed: 0x80244017
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: RefreshPTState failed: 0x80244017
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: Sync of Updates: 0x80244017
    2014-04-14 14:08:22:341 1000 f94 PT WARNING: SyncServerUpdatesInternal failed: 0x80244017
    2014-04-14 14:08:22:341 1000 f94 Agent * WARNING: Failed to synchronize, error = 0x80244017
    2014-04-14 14:08:22:342 1000 f94 Agent * WARNING: Exit code = 0x80244017
    2014-04-14 14:08:22:342 1000 f94 Agent *********
    2014-04-14 14:08:22:342 1000 f94 Agent ** END ** Agent: Finding updates [CallerId = AutomaticUpdates]
    2014-04-14 14:08:22:342 1000 f94 Agent *************
    2014-04-14 14:08:22:342 1000 f94 Agent WARNING: WU client failed Searching for update with error 0x80244017
    2014-04-14 14:08:22:342 1000 10ec AU >>## RESUMED ## AU: Search for updates [CallId = {B4EB6A23-7585-47CB-B2A4-837F7303D3C0}]
    2014-04-14 14:08:22:342 1000 10ec AU # WARNING: Search callback failed, result = 0x80244017
    2014-04-14 14:08:22:342 1000 10ec AU # WARNING: Failed to find updates with error code 80244017
    2014-04-14 14:08:22:342 1000 10ec AU #########
    2014-04-14 14:08:22:342 1000 10ec AU ## END ## AU: Search for updates [CallId = {B4EB6A23-7585-47CB-B2A4-837F7303D3C0}]
    2014-04-14 14:08:22:342 1000 10ec AU #############
    2014-04-14 14:08:22:342 1000 10ec AU Successfully wrote event for AU health state:0
    2014-04-14 14:08:22:342 1000 10ec AU AU setting next detection timeout to 2014-04-14 14:04:36
    2014-04-14 14:08:22:343 1000 10ec AU Setting AU scheduled install time to 2014-04-15 10:00:00
    2014-04-14 14:08:22:343 1000 10ec AU Successfully wrote event for AU health state:0
    2014-04-14 14:08:22:343 1000 10ec AU Successfully wrote event for AU health state:0
    2014-04-14 14:08:27:343 1000 f94 Report REPORT EVENT: {F19EEF89-035D-4E33-ACBA-46F942F93B73} 2014-04-14 14:08:22:342+0100 1 148 101 {00000000-0000-0000-0000-000000000000} 0 80244017 AutomaticUpdates Failure Software Synchronization Windows Update Client failed to detect with error 0x80244017.
    2014-04-14 14:08:27:350 1000 f94 Report CWERReporter::HandleEvents - WER report upload completed with status 0x8
    2014-04-14 14:08:27:350 1000 f94 Report WER Report sent: 7.6.7600.256 0x80244017 00000000-0000-0000-0000-000000000000 Scan 101 Managed
    2014-04-14 14:08:27:351 1000 f94 Report CWERReporter finishing event handling. (00000000)
    2014-04-14 14:22:31:992 1000 f94 PT WARNING: GetConfig failure, error = 0x80244017, soap client error = 10, soap error code = 0, HTTP status code = 401
    2014-04-14 14:22:31:992 1000 f94 PT WARNING: PTError: 0x80244017
    2014-04-14 14:22:31:992 1000 f94 PT WARNING: GetConfig_WithRecovery failed: 0x80244017
    2014-04-14 14:22:31:992 1000 f94 PT WARNING: RefreshConfig failed: 0x80244017
    2014-04-14 14:22:31:992 1000 f94 PT WARNING: RefreshPTState failed: 0x80244017
    2014-04-14 14:22:31:992 1000 f94 PT WARNING: PTError: 0x80244017
    2014-04-14 14:22:31:992 1000 f94 Report WARNING: Reporter failed to upload events with hr = 80244017.
    2014-04-14 14:36:59:077 1000 f94 PT WARNING: GetConfig failure, error = 0x80244017, soap client error = 10, soap error code = 0, HTTP status code = 401
    2014-04-14 14:36:59:077 1000 f94 PT WARNING: PTError: 0x80244017
    2014-04-14 14:36:59:077 1000 f94 PT WARNING: GetConfig_WithRecovery failed: 0x80244017
    2014-04-14 14:36:59:078 1000 f94 PT WARNING: RefreshConfig failed: 0x80244017
    2014-04-14 14:36:59:078 1000 f94 PT WARNING: RefreshPTState failed: 0x80244017
    2014-04-14 14:36:59:078 1000 f94 PT WARNING: PTError: 0x80244017
    2014-04-14 14:36:59:078 1000 f94 Report WARNING: Reporter failed to upload events with hr = 80244017.
    Last edited by andyk; 14th April 2014 at 04:28 PM.

  16. #14

    Join Date
    Jun 2010
    Posts
    38
    Thank Post
    28
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    For anyone who has the above error, I resolved the problem by restarting IIS. I also added the IUSR_computer name to the \Windows\Microsoft.NET directory and give it read and write permissions. One or the other fixed it :-)
    Last edited by andyk; 23rd April 2014 at 07:14 PM.



SHARE:
+ Post New Thread

Similar Threads

  1. Windows Server 2003 service pack 2 question
    By difinity in forum Windows Server 2000/2003
    Replies: 9
    Last Post: 4th November 2010, 09:23 AM
  2. Replies: 4
    Last Post: 25th January 2010, 06:09 AM
  3. No third service pack for Windows Server 2003
    By cookie_monster in forum Windows
    Replies: 15
    Last Post: 18th September 2009, 10:35 AM
  4. Windows Server Update Services 3.0 Beta 2
    By Geoff in forum Downloads
    Replies: 11
    Last Post: 1st May 2009, 07:36 PM
  5. updating moodle through CVS - Windows Server
    By chrisjako in forum Virtual Learning Platforms
    Replies: 0
    Last Post: 18th March 2009, 04:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •