+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 36
Windows Server 2012 Thread, RemoteApp and RD Gateway in Technical; Yes as I finished typing my essay I saw your last post and was going to suggest that! Glad you ...
  1. #16

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Yes as I finished typing my essay I saw your last post and was going to suggest that!

    Glad you got it all working.


  2. #17

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    Well, i told a lie.

    It isn't working, now i've added those the certificate is complaining again. Sorry about this but AAHHHHHHHHH

  3. #18

    fiza's Avatar
    Join Date
    Dec 2008
    Location
    London
    Posts
    2,174
    Thank Post
    431
    Thanked 317 Times in 268 Posts
    Rep Power
    153
    You may already have checked this but :

    In you RD Gateway Manager look at the properties of the server and check SSL Certificate. Make sure the "Issued to:" option is correct. It should be the public name of your server.

  4. #19

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Hi Nathan, when you say it isn't working, what isn't working? Do you have any error messages you can share? OR is it exactly the same as the issue you were experiencing earlier in the thread?

  5. #20

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Sorry, didn't mean to shout OR!

  6. #21

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    Quote Originally Posted by fiza View Post
    You may already have checked this but :

    In you RD Gateway Manager look at the properties of the server and check SSL Certificate. Make sure the "Issued to:" option is correct. It should be the public name of your server.
    Just checked and thats what i have, it could be that ive bought the incorrect certificate. I have a certificate with only our remote.domain.com external name, should it also have the internal fully qualified server name?

    EDIT: after more reading i dont think the above is correct.
    Last edited by nathan; 12th February 2014 at 10:16 AM.

  7. #22

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Hi Nathan, I need more info for example there are a few answers to your issue.
    You could set up the split DNS as I suggested before so that the gateway always receives a request for remote.domain.com or you could also set your clients up to bypass the gateway altogether if they are internal. if you PM me with how you have it set up I can help you better!

    Thanks

    Harriuk

  8. #23

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    It's strange as im getting a certificate mismatch.

    Requested remote computer: Internal FQDN

    Name on the cert from the remote computer; remote.domain.com

    i thought the only thing showing to the outside world would be the remote.domain.com one and that it wouldnt know anything about the internal one.

  9. #24

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    PM Sent, thank you.

  10. #25

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    I've found this and wondering if it could be whats happening.
    TechNet Change published FQDN for Server 2012 or 2012 R2 RDS Deployment

    Internally we're working fine, no errors at all. I've created an A record for remote.domain.com to point to our internal server.
    Last edited by nathan; 12th February 2014 at 10:51 AM.

  11. #26

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Hi Nathan. This looks like exactly what is happening. At last Microsoft have put in a proper solution for it in RDS 2012 R2.

    This didn't exist in RDS 2008 so we had to come up with other solution.

    Have you run it and did it fix your issue?

  12. #27

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    Havent had a chance to run it yet, things are too busy here everyone wants everything doing now, typical school environment. Most think we sit around doing nothing until someone wants something.

  13. #28

    Join Date
    Feb 2007
    Location
    Leicestershire
    Posts
    268
    Thank Post
    1
    Thanked 5 Times in 5 Posts
    Rep Power
    27
    just done it now, ran it and now they both say the remote.domain.com but it won't connect at all as it's saying remote.domain.com can't be found. Will have another look.

    EDIT: I am getting the following error now though.

    The user "DISCOVERY\username", on client computer "000.000.000.000", did not meet resource authorization policy requirements and was therefore not authorized to resource "remote.domain.org.uk". The following error occurred: "23002".
    Last edited by nathan; 12th February 2014 at 04:28 PM.

  14. #29

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Is the remote.domain.org.uk in your previous post a typo!

  15. #30

    Join Date
    Nov 2008
    Location
    Weston-super-Mare
    Posts
    41
    Thank Post
    2
    Thanked 4 Times in 2 Posts
    Rep Power
    12
    Now you need to check what is in your RAP (Remote authorization policy) in the gateway setup.

    Harriuk

SHARE:
+ Post New Thread
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. RemoteApp and RD Gateway
    By nathan in forum Windows Server 2008 R2
    Replies: 8
    Last Post: 6th February 2014, 12:17 PM
  2. RemoteApp and Desktop Connection
    By Andyhall in forum Windows Server 2008 R2
    Replies: 3
    Last Post: 25th September 2012, 10:33 AM
  3. rds gateway
    By strawberry in forum Thin Client and Virtual Machines
    Replies: 2
    Last Post: 27th August 2010, 11:10 PM
  4. RD Gateway and RD Services
    By wesleyw in forum Windows Server 2008 R2
    Replies: 7
    Last Post: 23rd March 2010, 03:02 PM
  5. Virtualising more server roles and Learning Gateway
    By ranj in forum Thin Client and Virtual Machines
    Replies: 5
    Last Post: 6th February 2009, 03:28 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •