+ Post New Thread
Results 1 to 8 of 8
Windows Server 2012 Thread, Server 2012 R2 / Exchange 2013 in Technical; Hi all, We are currently running our exchange 2010 on Server 2008 which is on a really unstable box. We ...
  1. #1

    Join Date
    Jun 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Server 2012 R2 / Exchange 2013

    Hi all,
    We are currently running our exchange 2010 on Server 2008 which is on a really unstable box. We have a new server with server 2012 R2 setup on and we want to install exchange 2013 and move everything across.

    The issue we are having is that every time i try to install exchange i get this error

    Step 7 of 14 Mailbox Role: Transport Service
    Error:
    The following error was generated when "$error.Clear();
    if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) )
    {
    Update-RmsSharedIdentity -ServerName $RoleNetBIOSName
    }
    " was run: "Database is mandatory on UserMailbox. Property Name: Database".


    Am i able to have 2 exchange servers on the same network for a limited time so i can move mailboxes across?
    Any help would be appreciated

    Thanks !
    Last edited by ljh171; 7th February 2014 at 10:12 AM.

  2. #2
    ascott2's Avatar
    Join Date
    Nov 2007
    Posts
    187
    Thank Post
    18
    Thanked 39 Times in 31 Posts
    Rep Power
    21
    Exchange 2013 is not yet support on Server 2012 R2 just yet, as per Exchange Support For Windows Server 2012 R2 - 250 Hello - Site Home - TechNet Blogs
    It is believed to be coming in SP1 (CU4) due out some time in Q1.

  3. #3

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    3,095
    Thank Post
    161
    Thanked 654 Times in 587 Posts
    Rep Power
    169
    I can confirm that Exchange 2013 (CU3) works very nicely on Server 2012 R1 though, if it's possible for you to roll back. You should be able to upgrade it to R2 when possible.

  4. #4

    Join Date
    Sep 2013
    Location
    Worcestershire
    Posts
    104
    Thank Post
    2
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    That's brilliant me being the idiot I am not looking into that ! Thanks guys

  5. #5

    Join Date
    Mar 2011
    Location
    Hartlepool
    Posts
    3
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi,

    I have recently installed exchange 2013 onto a 2012 r2 server without issue and it is running fine. Although Microsoft say it is not officially supported I have seen this installation combination in several environments with no fault.

    It may be worth a clean install of your OS and check all pre-reqs are installed and running with no errors showing in event viewer?

    Thanks

    Mark

  6. #6
    ascott2's Avatar
    Join Date
    Nov 2007
    Posts
    187
    Thank Post
    18
    Thanked 39 Times in 31 Posts
    Rep Power
    21
    I wouldn't personally install anything that messes with an AD schema until there is official support for it. I guess that's just my paranoia though.

  7. #7

    Join Date
    Jun 2013
    Posts
    4
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    I have now downgraded the server and trying to run Exchange 2013 onto Server 2008 R2 and i am being given this error:
    The following error was generated when "$error.Clear();
    if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) )
    {
    Update-RmsSharedIdentity -ServerName $RoleNetBIOSName
    }
    " was run: "Database is mandatory on UserMailbox. Property Name: Database".

    Any ideas? IT always happens when trying to install the transport Service, and these error codes are not much help.

    Thanks All

  8. #8

    3s-gtech's Avatar
    Join Date
    Mar 2009
    Location
    Wales
    Posts
    3,095
    Thank Post
    161
    Thanked 654 Times in 587 Posts
    Rep Power
    169
    Check this thread on Technet (if you haven't already): Database is mandatory on UserMailbox error during install of Hub Transport

    Exchange 2010 and 2013 have a lot in common when it comes to fault diagnosis.



SHARE:
+ Post New Thread

Similar Threads

  1. Replies: 0
    Last Post: 15th November 2013, 01:29 AM
  2. Server 2012 R2 forum
    By gmonks in forum Comments and Suggestions
    Replies: 6
    Last Post: 24th October 2013, 01:55 PM
  3. Replies: 0
    Last Post: 16th October 2013, 07:55 PM
  4. Replies: 18
    Last Post: 4th October 2013, 04:13 PM
  5. Virtual Server 2005 R2 + Exchange 2007
    By Simcfc73 in forum Windows
    Replies: 4
    Last Post: 8th February 2007, 12:04 AM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •