+ Post New Thread
Results 1 to 12 of 12
Windows Server 2012 Thread, Hyper-V replication error in Technical; Hi We are having a problem enabling replication on our VMs. we have two hyper visors each running 2012r2. The ...
  1. #1
    ROB
    ROB is offline

    Join Date
    May 2008
    Location
    Lancashire
    Posts
    12
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0

    Hyper-V replication error

    Hi
    We are having a problem enabling replication on our VMs.
    we have two hyper visors each running 2012r2.
    The Hyper-V manager is being run from win8.1
    If i set up a vm on hyper-A then try to enable replication to hyper-B i get the following error:
    hyper-v failed to enable replication for virtual machine. The server name or address could not be resolved (0x00002EE7)
    If I set up a vm on hyper-B and try to enable replication to hyper-A it works fine.
    I can ping both servers from each other
    I have tied the "fix" suggested here

    Does any one else have a suggestion to try?

    Rob

  2. #2
    kevin_lane's Avatar
    Join Date
    Mar 2007
    Location
    Derby
    Posts
    505
    Thank Post
    23
    Thanked 20 Times in 20 Posts
    Blog Entries
    5
    Rep Power
    19
    I take it this is part of a cluster?

  3. #3
    ROB
    ROB is offline

    Join Date
    May 2008
    Location
    Lancashire
    Posts
    12
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Thanks for replying.

    No neither Hyper-V machine are in a cluster.

  4. #4

    Join Date
    Oct 2010
    Location
    Bristol, UK
    Posts
    53
    Thank Post
    5
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    Can Hyper-vA ping Hyper-vB?
    Firewall ports open
    Are you using http or https?

    Thanks

    Gareth

  5. #5
    ROB
    ROB is offline

    Join Date
    May 2008
    Location
    Lancashire
    Posts
    12
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Yes
    Hyper-A can ping Hyper-B.
    I have opened the firewall ports, for testing I have turned off the firewall as well.
    Using http - kerberos

    Thanks

  6. #6

    Join Date
    Oct 2010
    Location
    Bristol, UK
    Posts
    53
    Thank Post
    5
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    Ok Cool,
    Have you tried adding the servers to the hosts file?
    Have you delegated the server in kerberos?

    Any other events being logged in eventvwr?

    Cheers

    Gareth

  7. #7
    ROB
    ROB is offline

    Join Date
    May 2008
    Location
    Lancashire
    Posts
    12
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi thanks,
    I have delegated the server in kerberos (AD users and computers)
    There are no untoward events being logged.
    I just tried adding the servers to their local hosts file (I had not done this before) and it appears to make no difference.

    Rob

  8. #8

    Join Date
    Oct 2010
    Location
    Bristol, UK
    Posts
    53
    Thank Post
    5
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    Have you tried turning off Replication on the Hyper-V host and enabling it again?

    Cheers

    Gareth

  9. #9
    ROB
    ROB is offline

    Join Date
    May 2008
    Location
    Lancashire
    Posts
    12
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Hi
    yes have tried this no joy im afraid.

    Rob

  10. #10

    Join Date
    Oct 2010
    Location
    Bristol, UK
    Posts
    53
    Thank Post
    5
    Thanked 7 Times in 6 Posts
    Rep Power
    9
    Ok I out of ideas...

    Log a call with Microsoft I guess

  11. #11
    kevin_lane's Avatar
    Join Date
    Mar 2007
    Location
    Derby
    Posts
    505
    Thank Post
    23
    Thanked 20 Times in 20 Posts
    Blog Entries
    5
    Rep Power
    19
    What does the event logs say dont forget 2012 r2 is still new and might need to wait for patches

  12. #12
    ROB
    ROB is offline

    Join Date
    May 2008
    Location
    Lancashire
    Posts
    12
    Thank Post
    0
    Thanked 0 Times in 0 Posts
    Rep Power
    0
    Success... It appears that the NIC drivers for my HP Proliant had an update that would only work using server 2012 not 2012r2 when applied replication works as it should do to another 2012 server. I have discovered that replication can not go from a 2012r2 host to a 2012 host but will work the other way round (OK unless you want to failover) I have also discovered that you can not migrate vms from a 2012r2 host to a 2012 host. If the os of your vm is linux based then you can create a new vm on a 2012 host and attach the vhdx however if it is a windows os then this will not work. So I have now downgraded my servers both to 2012 updated the drivers on my HP (the other is a Dell) . I have also rebuilt all my vms (they are using 2012r2). see also spiceworks and technet Thanks for all your suggestions.

    Rob

SHARE:
+ Post New Thread

Similar Threads

  1. File Replication Errors in Backup
    By enjay in forum Windows Server 2008 R2
    Replies: 0
    Last Post: 14th February 2013, 10:34 AM
  2. File Replication error on W2k servers
    By randle in forum Windows
    Replies: 0
    Last Post: 21st July 2008, 10:42 AM
  3. Server 2003 Replication Error
    By bmdixon in forum Windows
    Replies: 12
    Last Post: 18th April 2008, 02:19 PM
  4. AD Replication Error
    By kerrymoralee9280 in forum Wireless Networks
    Replies: 3
    Last Post: 12th July 2007, 09:39 AM
  5. Replies: 0
    Last Post: 2nd July 2007, 03:27 PM

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •